summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-11-18 01:36:07 +0200
committerStelios Tsampas2023-11-18 01:36:07 +0200
commitdc0960f5609f4793c9f51aa19997133d5a7fd96b (patch)
tree2f5597641ae3d5c4a324f395b3d86a67627c10bb
parenta01b66f3a4f4e727be25ec0da1774cf4031b7186 (diff)
downloadaur-dc0960f5609f4793c9f51aa19997133d5a7fd96b.tar.gz
[vkd3d-proton-mingw-git] Adjust submodules and update patch
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
-rw-r--r--PKGBUILD.testing35
3 files changed, 25 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 888b921e3dde..c20dca03a661 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vkd3d-proton-mingw-git
pkgdesc = Fork of VKD3D. Development branches for Protons Direct3D 12 implementation
- pkgver = 2.9.r0.g6365efeb
+ pkgver = 2.10.r150.g7531dd5e
pkgrel = 1
url = https://github.com/HansKristian-Work/vkd3d-proton
arch = x86_64
@@ -13,23 +13,17 @@ pkgbase = vkd3d-proton-mingw-git
makedepends = mingw-w64-tools
provides = vkd3d-proton
provides = d3d12.dll
- provides = vkd3d-proton=2.9.r0.g6365efeb
+ provides = vkd3d-proton=2.10.r150.g7531dd5e
conflicts = vkd3d-proton
conflicts = d3d12.dll
options = !lto
options = !staticlibs
source = git+https://github.com/HansKristian-Work/vkd3d-proton.git
- source = git+https://github.com/HansKristian-Work/dxil-spirv.git
- source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
- source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
source = setup_vkd3d_proton
source = vkd3d-proton-extraopts.patch
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
sha256sums = 67815eed9d47bbf610e23c6a1e4954c11371886c2ca73555dd9f1d6fbebb1323
- sha256sums = 8fc019d1dca8c52b6af96c40ff06a6c215aad3e713ae17be72c7422f1ba45634
+ sha256sums = bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362
pkgname = vkd3d-proton-mingw-git
depends = vulkan-icd-loader
diff --git a/PKGBUILD b/PKGBUILD
index 1cf3489abdc2..1162a4698913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel @at gmail .dot com>
pkgname=vkd3d-proton-mingw-git
-pkgver=2.9.r0.g6365efeb
+pkgver=2.10.r150.g7531dd5e
pkgrel=1
pkgdesc='Fork of VKD3D. Development branches for Protons Direct3D 12 implementation'
arch=('x86_64')
@@ -13,9 +13,6 @@ conflicts=('vkd3d-proton' 'd3d12.dll')
options=(!lto !staticlibs)
source=(
"git+https://github.com/HansKristian-Work/vkd3d-proton.git"
- "git+https://github.com/HansKristian-Work/dxil-spirv.git"
- "git+https://github.com/KhronosGroup/Vulkan-Headers.git"
- "git+https://github.com/KhronosGroup/SPIRV-Headers.git"
"setup_vkd3d_proton"
"vkd3d-proton-extraopts.patch"
)
@@ -28,16 +25,13 @@ pkgver() {
prepare() {
cd vkd3d-proton
- for submodule in subprojects/{dxil-spirv,Vulkan-Headers,SPIRV-Headers}; do
- git submodule init "${submodule}"
- git submodule set-url "${submodule}" "$srcdir"/"${submodule#*/}"
- git -c protocol.file.allow=always submodule update "${submodule}"
- done
- pushd subprojects/dxil-spirv
- git submodule init third_party/spirv-headers
- git submodule set-url third_party/spirv-headers "$srcdir"/SPIRV-Headers
- git -c protocol.file.allow=always submodule update third_party/spirv-headers
- popd
+ # Explicitly set origin URL for submodules using relative paths
+ git remote set-url origin https://github.com/HansKristian-Work/vkd3d-proton.git
+ git submodule update --init --filter=tree:0 --recursive
+
+ # Uncomment to enable extra optimizations
+ # Patch crossfiles with extra optimizations from makepkg.conf
+ patch -p1 -i "$srcdir"/vkd3d-proton-extraopts.patch
# By default export FLAGS used by proton and ignore makepkg
# This overrides FLAGS from makepkg.conf, if you comment these you are on your own
@@ -67,10 +61,6 @@ prepare() {
CFLAGS+=" -mno-avx2"
CXXFLAGS+=" -mno-avx2"
- # Uncomment to enable extra optimizations
- # Patch crossfiles with extra optimizations from makepkg.conf
- patch -p1 -i "$srcdir"/vkd3d-proton-extraopts.patch
-
local cross_ldflags="$LDFLAGS"
local cross_cflags="$CFLAGS -mcmodel=small"
@@ -89,7 +79,7 @@ prepare() {
}
build() {
- meson vkd3d-proton "build/x64" \
+ meson setup vkd3d-proton "build/x64" \
--prefix "/usr/share/vkd3d-proton/x64" \
--cross-file vkd3d-proton/build-win64.txt \
--bindir "" --libdir "" \
@@ -98,7 +88,7 @@ build() {
-Denable_tests=false
ninja -C "build/x64" -v
- meson vkd3d-proton "build/x86" \
+ meson setup vkd3d-proton "build/x86" \
--cross-file vkd3d-proton/build-win32.txt \
--prefix "/usr/share/vkd3d-proton/x86" \
--bindir "" --libdir "" \
@@ -120,8 +110,5 @@ package() {
}
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'67815eed9d47bbf610e23c6a1e4954c11371886c2ca73555dd9f1d6fbebb1323'
- '8fc019d1dca8c52b6af96c40ff06a6c215aad3e713ae17be72c7422f1ba45634')
+ 'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362')
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 3225767a70bc..a9d08fa5d89a 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel @at gmail .dot com>
pkgname=vkd3d-proton-mingw-git
-pkgver=2.9.r0.g6365efeb
+pkgver=2.10.r150.g7531dd5e
pkgrel=1
pkgdesc='Fork of VKD3D. Development branches for Protons Direct3D 12 implementation'
arch=('x86_64')
@@ -13,9 +13,6 @@ conflicts=('vkd3d-proton' 'd3d12.dll')
options=(!lto !staticlibs)
source=(
"git+https://github.com/HansKristian-Work/vkd3d-proton.git"
- "git+https://github.com/HansKristian-Work/dxil-spirv.git"
- "git+https://github.com/KhronosGroup/Vulkan-Headers.git"
- "git+https://github.com/KhronosGroup/SPIRV-Headers.git"
"setup_vkd3d_proton"
"vkd3d-proton-extraopts.patch"
)
@@ -28,16 +25,13 @@ pkgver() {
prepare() {
cd vkd3d-proton
- for submodule in subprojects/{dxil-spirv,Vulkan-Headers,SPIRV-Headers}; do
- git submodule init "${submodule}"
- git submodule set-url "${submodule}" "$srcdir"/"${submodule#*/}"
- git -c protocol.file.allow=always submodule update "${submodule}"
- done
- pushd subprojects/dxil-spirv
- git submodule init third_party/spirv-headers
- git submodule set-url third_party/spirv-headers "$srcdir"/SPIRV-Headers
- git -c protocol.file.allow=always submodule update third_party/spirv-headers
- popd
+ # Explicitly set origin URL for submodules using relative paths
+ git remote set-url origin https://github.com/HansKristian-Work/vkd3d-proton.git
+ git submodule update --init --filter=tree:0 --recursive
+
+ # Uncomment to enable extra optimizations
+ # Patch crossfiles with extra optimizations from makepkg.conf
+ patch -p1 -i "$srcdir"/vkd3d-proton-extraopts.patch
# By default export FLAGS used by proton and ignore makepkg
# This overrides FLAGS from makepkg.conf, if you comment these you are on your own
@@ -67,10 +61,6 @@ prepare() {
CFLAGS+=" -mno-avx2"
CXXFLAGS+=" -mno-avx2"
- # Uncomment to enable extra optimizations
- # Patch crossfiles with extra optimizations from makepkg.conf
- patch -p1 -i "$srcdir"/vkd3d-proton-extraopts.patch
-
local cross_ldflags="$LDFLAGS"
local cross_cflags="$CFLAGS -mcmodel=small"
@@ -89,7 +79,7 @@ prepare() {
}
build() {
- meson vkd3d-proton "build/x64" \
+ meson setup vkd3d-proton "build/x64" \
--prefix "/usr/share/vkd3d-proton/x64" \
--cross-file vkd3d-proton/build-win64.txt \
--bindir "" --libdir "" \
@@ -98,7 +88,7 @@ build() {
-Denable_tests=false
ninja -C "build/x64" -v
- meson vkd3d-proton "build/x86" \
+ meson setup vkd3d-proton "build/x86" \
--cross-file vkd3d-proton/build-win32.txt \
--prefix "/usr/share/vkd3d-proton/x86" \
--bindir "" --libdir "" \
@@ -120,8 +110,5 @@ package() {
}
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'67815eed9d47bbf610e23c6a1e4954c11371886c2ca73555dd9f1d6fbebb1323'
- '8fc019d1dca8c52b6af96c40ff06a6c215aad3e713ae17be72c7422f1ba45634')
+ 'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362')