summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMadeline Mewmews2023-09-16 13:59:27 -0500
committerMadeline Mewmews2023-09-16 13:59:27 -0500
commitc946810772da1dfd5e8f2a7870925ef5677b1680 (patch)
tree3da3c1e9621f92e756bd2556a06c20414b41fdbf
downloadaur-c946810772da1dfd5e8f2a7870925ef5677b1680.tar.gz
Initial Commit
-rw-r--r--.SRCINFO49
-rw-r--r--0001-Fix-file-paths.patch47
-rw-r--r--PKGBUILD81
-rw-r--r--vkdoom.desktop11
4 files changed, 188 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63cd679664dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,49 @@
+pkgbase = vkdoom-git
+ pkgdesc = Feature centric port for all Doom engine games, with a focus on Vulkan and modern computers (git version)
+ pkgver = v0.9+207+gc282c4781
+ pkgrel = 1
+ url = http://www.vkdoom.org/
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = BSD
+ license = GPL3
+ license = LGPL3
+ makedepends = cmake
+ makedepends = desktop-file-utils
+ makedepends = git
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libgl
+ depends = libjpeg
+ depends = libvpx>=1.13
+ depends = openal
+ depends = sdl2
+ depends = zmusic>=1.1.8
+ optdepends = blasphemer-wad: Blasphemer (free Heretic) game data
+ optdepends = chexquest3-wad: Chex Quest 3 game data
+ optdepends = doom1-wad: Doom shareware game data
+ optdepends = freedm: FreeDM game data
+ optdepends = freedoom: Freedoom game data
+ optdepends = gxmessage: crash dialog (GNOME)
+ optdepends = hacx-wad: HacX game data
+ optdepends = harmony-wad: Harmony game data
+ optdepends = heretic1-wad: Heretic shareware game data
+ optdepends = hexen1-wad: Hexen demo game data
+ optdepends = kdialog: crash dialog (KDE)
+ optdepends = strife0-wad: Strife shareware game data
+ optdepends = square1-wad: The Adventures of Square, Episode 1 game data
+ optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
+ optdepends = xorg-xmessage: crash dialog (other)
+ optdepends = vulkan-driver: Vulkan renderer
+ optdepends = vulkan-icd-loader: Vulkan renderer
+ provides = vkdoom
+ conflicts = vkdoom
+ source = vkdoom::git+https://github.com/dpjudas/VkDoom/
+ source = vkdoom.desktop
+ source = 0001-Fix-file-paths.patch
+ b2sums = SKIP
+ b2sums = 66d946f4deb49d0f655c889280677cdd489d4e1d8c2bc67ec635f667b316dff611f4a6a18521e0029f25031282e1cf781d0799db487481478d5ab89ba1e9b266
+ b2sums = fbec476e07feadccbe60fe8059f063fc810fbc3ca5fcfc57c05baa5b2bb75e46408e7462ba23ca0a993ffc0662e0e5fb77edd731300e526bd0c00e71e8897ec6
+
+pkgname = vkdoom-git
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
new file mode 100644
index 000000000000..5df3f66c809e
--- /dev/null
+++ b/0001-Fix-file-paths.patch
@@ -0,0 +1,47 @@
+From 749acb5c34edad113b083e37df034887674aad3e Mon Sep 17 00:00:00 2001
+From: Jan Cholasta <jan@cholasta.net>
+Date: Tue, 25 Feb 2020 12:53:07 +0100
+Subject: [PATCH] Fix file paths
+
+---
+ src/gameconfigfile.cpp | 10 ++--------
+ 1 file changed, 2 insertions(+), 8 deletions(-)
+
+diff --git a/src/gameconfigfile.cpp b/src/gameconfigfile.cpp
+index 82b8071b60..a6584fa6f5 100644
+--- a/src/gameconfigfile.cpp
++++ b/src/gameconfigfile.cpp
+@@ -121,8 +121,6 @@ FGameConfigFile::FGameConfigFile ()
+ // Arch Linux likes them in /usr/share/doom
+ // Debian likes them in /usr/share/games/doom
+ // I assume other distributions don't do anything radically different
+- SetValueForKey ("Path", "/usr/local/share/doom", true);
+- SetValueForKey ("Path", "/usr/local/share/games/doom", true);
+ SetValueForKey ("Path", "/usr/share/doom", true);
+ SetValueForKey ("Path", "/usr/share/games/doom", true);
+ #endif
+@@ -143,8 +141,6 @@ FGameConfigFile::FGameConfigFile ()
+ SetValueForKey ("Path", "$HOME/" GAME_DIR, true);
+ SetValueForKey ("Path", "$HOME/.local/share/games/doom", true);
+ SetValueForKey ("Path", SHARE_DIR, true);
+- SetValueForKey ("Path", "/usr/local/share/doom", true);
+- SetValueForKey ("Path", "/usr/local/share/games/doom", true);
+ SetValueForKey ("Path", "/usr/share/doom", true);
+ SetValueForKey ("Path", "/usr/share/games/doom", true);
+ #endif
+@@ -172,10 +168,8 @@ FGameConfigFile::FGameConfigFile ()
+ SetValueForKey("Path", "$HOME/" GAME_DIR "/fm_banks", true);
+ SetValueForKey("Path", "$HOME/.local/share/games/doom/soundfonts", true);
+ SetValueForKey("Path", "$HOME/.local/share/games/doom/fm_banks", true);
+- SetValueForKey("Path", "/usr/local/share/doom/soundfonts", true);
+- SetValueForKey("Path", "/usr/local/share/doom/fm_banks", true);
+- SetValueForKey("Path", "/usr/local/share/games/doom/soundfonts", true);
+- SetValueForKey("Path", "/usr/local/share/games/doom/fm_banks", true);
++ SetValueForKey("Path", "$PROGDIR/soundfonts", true);
++ SetValueForKey("Path", "$PROGDIR/fm_banks", true);
+ SetValueForKey("Path", "/usr/share/doom/soundfonts", true);
+ SetValueForKey("Path", "/usr/share/doom/fm_banks", true);
+ SetValueForKey("Path", "/usr/share/games/doom/soundfonts", true);
+--
+2.38.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a0d78de47ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: Maddie Mewmews <maddie at mewmews gay>
+# Contributor: Jan Cholasta <grubber at grubber cz>
+
+pkgname=vkdoom-git
+pkgver=v0.9+207+gc282c4781
+pkgrel=1
+pkgdesc='Feature centric port for all Doom engine games, with a focus on Vulkan and modern computers (git version)'
+arch=('i686' 'x86_64' 'aarch64')
+url='http://www.vkdoom.org/'
+license=('BSD' 'GPL3' 'LGPL3')
+depends=('gtk3'
+ 'hicolor-icon-theme'
+ 'libgl'
+ 'libjpeg'
+ 'libvpx>=1.13'
+ 'openal'
+ 'sdl2'
+ 'zmusic>=1.1.8')
+makedepends=('cmake' 'desktop-file-utils' 'git')
+optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
+ 'chexquest3-wad: Chex Quest 3 game data'
+ 'doom1-wad: Doom shareware game data'
+ 'freedm: FreeDM game data'
+ 'freedoom: Freedoom game data'
+ 'gxmessage: crash dialog (GNOME)'
+ 'hacx-wad: HacX game data'
+ 'harmony-wad: Harmony game data'
+ 'heretic1-wad: Heretic shareware game data'
+ 'hexen1-wad: Hexen demo game data'
+ 'kdialog: crash dialog (KDE)'
+ 'strife0-wad: Strife shareware game data'
+ 'square1-wad: The Adventures of Square, Episode 1 game data'
+ 'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
+ 'xorg-xmessage: crash dialog (other)'
+ 'vulkan-driver: Vulkan renderer'
+ 'vulkan-icd-loader: Vulkan renderer')
+provides=('vkdoom')
+conflicts=('vkdoom')
+source=('vkdoom::git+https://github.com/dpjudas/VkDoom/'
+ 'vkdoom.desktop'
+ '0001-Fix-file-paths.patch')
+b2sums=('SKIP'
+ '66d946f4deb49d0f655c889280677cdd489d4e1d8c2bc67ec635f667b316dff611f4a6a18521e0029f25031282e1cf781d0799db487481478d5ab89ba1e9b266'
+ 'fbec476e07feadccbe60fe8059f063fc810fbc3ca5fcfc57c05baa5b2bb75e46408e7462ba23ca0a993ffc0662e0e5fb77edd731300e526bd0c00e71e8897ec6')
+
+pkgver() {
+ cd vkdoom
+ git describe --tags --match '[Vv]*' | sed -r 's/^[Gg]//;s/-/+/g'
+}
+
+prepare() {
+ cd vkdoom
+ patch -i "$srcdir"/0001-Fix-file-paths.patch -p 1
+}
+
+build() {
+ cd vkdoom
+ mkdir -p build
+ cmake -B build \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D CMAKE_CXX_FLAGS="$CXXFLAGS -ffile-prefix-map=\"$PWD\"=. -DSHARE_DIR=\\\"/usr/share/vkdoom\\\"" \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D SYSTEMINSTALL=ON \
+ -D INSTALL_PK3_PATH=share/vkdoom \
+ -D INSTALL_SOUNDFONT_PATH=share/vkdoom \
+ -D INSTALL_RPATH=/usr/lib \
+ -D DYN_GTK=OFF \
+ -D DYN_OPENAL=OFF \
+ -D CMAKE_C_COMPILER="$CC" \
+ -D CMAKE_CXX_COMPILER="$CCX"
+ make -C build
+}
+
+package() {
+ cd vkdoom
+ make -C build install DESTDIR="$pkgdir"
+ install -d "$pkgdir"/usr/share/licenses
+ mv "$pkgdir"/usr/share/doc/vkdoom/licenses "$pkgdir"/usr/share/licenses/vkdoom
+ desktop-file-install "$srcdir"/vkdoom.desktop --dir="$pkgdir"/usr/share/applications
+ install src/posix/zdoom.xpm -D -m 644 "$pkgdir"/usr/share/icons/hicolor/256x256/apps/vkdoom.xpm
+}
diff --git a/vkdoom.desktop b/vkdoom.desktop
new file mode 100644
index 000000000000..7cc15265dfdd
--- /dev/null
+++ b/vkdoom.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=VKDoom
+GenericName=Advanced Doom source port with a focus on Vulkan and modern computers
+Icon=vkdoom
+Exec=vkdoom %F
+Terminal=false
+MimeType=application/x-doom-wad;
+Categories=Game;ActionGame;
+X-Desktop-File-Install-Version=0.26