summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2020-05-18 10:44:44 +0200
committerMichal Wojdyla2020-05-18 10:44:44 +0200
commitefcbd0c76d04a2e8e792fd8bd383a2c7e613754f (patch)
tree8453d6a3ad5723f9dbab5bc71751dc6a393a91d3
parent73cfab922dd33115d31865dbaf877c58b5f50468 (diff)
downloadaur-efcbd0c76d04a2e8e792fd8bd383a2c7e613754f.tar.gz
Fix build, check issue #222 vkquake and issue #1230 vulkan-docs for more info
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--fix-build.patch11
3 files changed, 28 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a88b4cb381b3..670f7f56304a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vkquake
pkgdesc = A modern Quake 1 engine. Forked from Fitzquake. This version contains Vulkan API support.
pkgver = 1.04.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Novum/vkquake
install = vkquake.install
arch = x86_64
@@ -11,24 +11,22 @@ pkgbase = vkquake
depends = glibc
depends = libgl
depends = libmad
- depends = libmikmod
- depends = libogg
depends = libvorbis
depends = libx11
- depends = opusfile
depends = sdl2
depends = vulkan-validation-layers
- depends = tslib
provides = vkquake
conflicts = vkquake
source = git+https://github.com/Novum/vkquake.git#tag=1.04.1
source = vkquake.desktop
source = vkquake.png
source = vkquake.svg
+ source = fix-build.patch
md5sums = SKIP
md5sums = 202e1efb0491aafcc9de6f44295dc272
md5sums = ffc3103326b0378af770b1318cf4e7e6
md5sums = d6b9553906db3cbadfbc40aafafa2b5d
+ md5sums = 0c17db6ff55638f027a4b12458a1680f
pkgname = vkquake
diff --git a/PKGBUILD b/PKGBUILD
index 550f82bc8c3f..5fdc16ac859d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,34 @@
pkgname=vkquake
pkgver=1.04.1
-pkgrel=1
+pkgrel=2
pkgdesc="A modern Quake 1 engine. Forked from Fitzquake. This version contains Vulkan API support."
arch=('x86_64')
conflicts=('vkquake')
provides=('vkquake')
url="https://github.com/Novum/vkquake"
license=('GPL2')
-depends=(
- 'git' 'flac' 'glibc' 'libgl' 'libmad' 'libmikmod' 'libogg'
- 'libvorbis' 'libx11' 'opusfile' 'sdl2' 'vulkan-validation-layers'
- 'tslib'
+depends=( 'git' 'flac' 'glibc' 'libgl' 'libmad'
+ 'libvorbis' 'libx11' 'sdl2' 'vulkan-validation-layers'
)
install=$pkgname.install
source=("git+https://github.com/Novum/vkquake.git#tag=${pkgver}"
'vkquake.desktop'
'vkquake.png'
- 'vkquake.svg')
+ 'vkquake.svg'
+ 'fix-build.patch')
md5sums=('SKIP'
'202e1efb0491aafcc9de6f44295dc272'
'ffc3103326b0378af770b1318cf4e7e6'
- 'd6b9553906db3cbadfbc40aafafa2b5d')
+ 'd6b9553906db3cbadfbc40aafafa2b5d'
+ '0c17db6ff55638f027a4b12458a1680f')
+
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ # https://github.com/Novum/vkQuake/issues/222
+ patch -Np1 -i ../fix-build.patch
+}
build() {
diff --git a/fix-build.patch b/fix-build.patch
new file mode 100644
index 000000000000..64904bd1afc4
--- /dev/null
+++ b/fix-build.patch
@@ -0,0 +1,11 @@
+--- vkquake/Quake/gl_rmisc.c 2020-05-18 10:01:19.180100819 +0200
++++ vkquake/Quake/gl_rmisc.c 2020-05-18 10:26:56.293423637 +0200
+@@ -1426,7 +1426,7 @@
+ VkPipelineDynamicStateCreateInfo dynamic_state_create_info;
+ memset(&dynamic_state_create_info, 0, sizeof(dynamic_state_create_info));
+ dynamic_state_create_info.sType = VK_STRUCTURE_TYPE_PIPELINE_DYNAMIC_STATE_CREATE_INFO;
+- VkDynamicState dynamic_states[VK_DYNAMIC_STATE_RANGE_SIZE];
++ VkDynamicState dynamic_states[3];
+ dynamic_state_create_info.pDynamicStates = dynamic_states;
+
+ VkPipelineShaderStageCreateInfo shader_stages[2];