summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordoragasu2015-08-21 12:07:42 +0200
committerdoragasu2015-08-21 12:07:42 +0200
commit9046c8a00f3564384e5edc2171d401a414e42ff1 (patch)
tree90ab1c60a474b70c74617ffc0eb7dde2b056bea2
downloadaur-9046c8a00f3564384e5edc2171d401a414e42ff1.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9156227536e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vlc-htsp-plugin-git
+ pkgdesc = The HTSP VLC plugin allows VLC to act as a standalone Tvheadend client.
+ pkgver = r147
+ pkgrel = 1
+ url = https://github.com/BtbN/vlc-htsp-plugin/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = vlc
+ provides = vlc-htsp-plugin
+ conflicts = vlc-htsp-plugin
+ source = git+https://github.com/BtbN/vlc-htsp-plugin.git
+ md5sums = SKIP
+
+pkgname = vlc-htsp-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c0fcb5f6417
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: doragasu: doragasu <yawn> hotmail <roll> com
+
+_basename=vlc-htsp-plugin
+pkgname=${_basename}-git
+pkgver=r147
+pkgrel=1
+pkgdesc="The HTSP VLC plugin allows VLC to act as a standalone Tvheadend client."
+arch=('i686' 'x86_64')
+url="https://github.com/BtbN/vlc-htsp-plugin/"
+license=('GPL2')
+depends=('vlc')
+conflicts=("$_basename")
+provides=("$_basename")
+
+source=("git+https://github.com/BtbN/${_basename}.git")
+md5sums=('SKIP')
+
+build() {
+ # Just build...
+ cd "${_basename}"
+ make
+}
+
+package() {
+ # ... and install
+ cd "${_basename}"
+ DESTDIR=${pkgdir} make install
+}
+