summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522024-01-21 13:59:24 +0100
committertytan6522024-01-21 13:59:24 +0100
commit03b3bb75a2aefc96e9f91315c59ee70a31a594b1 (patch)
tree0c9a54ff4de7c0dd5d5d4699281474195e77a6d0
parentaff18557a590a36d3f9022424e8e36995f6fc1eb (diff)
downloadaur-03b3bb75a2aefc96e9f91315c59ee70a31a594b1.tar.gz
build: Enable FluidSynth support for MIDI playback
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a17cabe4d59..ddeb637beb56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = vlc-luajit
pkgdesc = Multi-platform MPEG, VCD/DVD, and DivX player built with luajit for OBS Studio compatibility
pkgver = 3.0.20
- pkgrel = 4
+ pkgrel = 5
url = https://www.videolan.org/vlc/
- arch = i686
arch = x86_64
arch = aarch64
- license = LGPL2.1
- license = GPL2
+ license = GPL-2.0-or-later
+ license = LGPL-2.1-or-later
makedepends = gst-plugins-base-libs
makedepends = live-media>=2023.01.19
makedepends = libnotify
@@ -69,6 +68,7 @@ pkgbase = vlc-luajit
makedepends = x265>=3.5
makedepends = protobuf>=25
makedepends = srt>=1.5
+ makedepends = fluidsynth
depends = a52dec
depends = aribb24
depends = libdvbpsi
@@ -114,6 +114,7 @@ pkgbase = vlc-luajit
optdepends = systemd-libs: udev services discovery
optdepends = smbclient: SMB access plugin
optdepends = libcdio: audio CD playback
+ optdepends = fluidsynth: FluidSynth based MIDI playback plugin
optdepends = gnu-free-fonts: subtitle font
optdepends = ttf-dejavu: subtitle font
optdepends = libssh2: sftp access
diff --git a/PKGBUILD b/PKGBUILD
index ab7dafa1bb1d..2e130bf25f39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,14 @@ _vlcver=3.0.20
# optional fixup version including hyphen
_vlcfixupver=
pkgver=${_vlcver}${_vlcfixupver//-/.r}
-pkgrel=4
+pkgrel=5
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player built with luajit for OBS Studio compatibility'
url='https://www.videolan.org/vlc/'
-arch=('i686' 'x86_64' 'aarch64')
-license=('LGPL2.1' 'GPL2')
+arch=('x86_64' 'aarch64')
+license=(
+ 'GPL-2.0-or-later'
+ 'LGPL-2.1-or-later'
+)
# To manage dependency rebuild easily, this will prevent you to rebuild VLC on non-updated system
_aomver=3
_dav1dver=1.3.0
@@ -49,7 +52,7 @@ makedepends=(
"libdc1394>=$_libdc1394ver"
"libmicrodns>=$_libmicrodnsver" "libvpx>=$_libvpxver"
"x264>=$_x264ver" "x265>=$_x265ver" "protobuf>=$_protobufver"
- "srt>=$_srtver"
+ "srt>=$_srtver" fluidsynth
)
optdepends=(
'avahi: service discovery using bonjour protocol'
@@ -67,7 +70,8 @@ optdepends=(
'systemd-libs: udev services discovery'
'smbclient: SMB access plugin'
'libcdio: audio CD playback'
- 'gnu-free-fonts: subtitle font '
+ 'fluidsynth: FluidSynth based MIDI playback plugin'
+ 'gnu-free-fonts: subtitle font'
'ttf-dejavu: subtitle font'
'libssh2: sftp access'
'libnfs: NFS access'
@@ -210,6 +214,7 @@ build() {
--enable-a52 \
--enable-dca \
--enable-flac \
+ --enable-fluidsynth \
--enable-libmpeg2 \
--enable-vorbis \
--enable-speex \