summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-10-07 12:12:53 -0400
committerSolomon Choina2018-10-07 12:12:53 -0400
commita8e05ba1043cfb419b16cd0354fb758c15605521 (patch)
treed41e2f03f6f662a5385a34d94342af5aa94082f5
parentc367df03772542dac60327d3972b3b99eac4ecbb (diff)
downloadaur-a8e05ba1043cfb419b16cd0354fb758c15605521.tar.gz
changing to nightlies.videolan and adding depends and features
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 21 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d50d56c2273..aa129321d1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = vlc-nightly
pkgdesc = Multi-platform MPEG, VCD/DVD, and DivX player - nightly snapshot
- pkgver = 4.0.0v20180624
+ pkgver = 4.0.0v20181007
pkgrel = 1
- url = https://www.videolan.org/vlc/
+ url = https://nightlies.videolan.org/
arch = x86_64
license = LGPL2.1
license = GPL2
+ makedepends = aribb24
makedepends = gst-plugins-base-libs
makedepends = live-media
makedepends = libnotify
makedepends = glibc
makedepends = libbluray
makedepends = flac
- makedepends = kdelibs
makedepends = libdc1394
makedepends = libavc1394
makedepends = libcaca
@@ -66,7 +66,10 @@ pkgbase = vlc-nightly
makedepends = portaudio
makedepends = sidplay2-libs
makedepends = sndio
+ depends = aribb25
+ depends = libmfx
depends = a52dec
+ depends = libidn
depends = libdvbpsi
depends = libxpm
depends = libdca
@@ -105,7 +108,6 @@ pkgbase = vlc-nightly
optdepends = libdvdcss: decoding encrypted DVDs
optdepends = libavc1394: devices using the 1394ta AV/C
optdepends = libdc1394: IEEE 1394 access plugin
- optdepends = kdelibs: KDE Solid hardware integration
optdepends = kwallet: kwallet keystore
optdepends = libva-vdpau-driver: vdpau backend nvidia
optdepends = libva-intel-driver: video backend intel
@@ -143,6 +145,7 @@ pkgbase = vlc-nightly
optdepends = libx264: H264 encoding
optdepends = x265: HEVC/H.265 encoder
optdepends = zvbi: VBI/Teletext decoding
+ optdepends = aribb24: ARIB subtitles
optdepends = libass: Subtitle support
optdepends = libkate: Kate codec
optdepends = libtiger: Tiger rendering for Kate streams
@@ -172,11 +175,11 @@ pkgbase = vlc-nightly
conflicts = vlc
replaces = vlc-plugin
options = !emptydirs
- source = http://nightlies.videolan.org/build/source/vlc-4.0.0-20180624-0251-dev.tar.xz
+ source = http://nightlies.videolan.org/build/source/vlc-4.0.0-20181007-0231-dev.tar.xz
source = update-vlc-plugin-cache.hook
source = 0001-lua-fix-build-using-lua-5.3.patch
source = find-deps.py
- sha256sums = ff08f92a87f707e4d85ed8d84c34725ecb3fc48a19b4ef26107578cf7bb571eb
+ sha256sums = 875078ec8a3912a51225701cb29ca7fb75d66a48adf2546ad63930c58569ec5e
sha256sums = c6f60c50375ae688755557dbfc5bd4a90a8998f8cf4d356c10d872a1a0b44f3a
sha256sums = 75ad8802bad1a79754e40fd107f5a6922c54f7467dadef8b439b49d410c8f7d2
sha256sums = 90b0e34d5772d2307ba07a1c2aa715db7488389003cfe6d3570b2a9c63061db7
diff --git a/PKGBUILD b/PKGBUILD
index b748529b3a6..a9d3b0252df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,25 @@
_appname_=vlc
pkgname=${_appname_}-nightly
-pkgver=4.0.0v20180624
+pkgver=4.0.0v20181007
_pkgver=4.0.0
-_snapshot_=20180624
-_snapver_=0251
+_snapshot_=20181007
+_snapver_=0231
_suffix_=dev
_nightly_=${_snapshot_}-${_snapver_}
pkgrel=1
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player - nightly snapshot'
-url='https://www.videolan.org/vlc/'
+url='https://nightlies.videolan.org/'
arch=('x86_64')
license=('LGPL2.1' 'GPL2')
-depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy' 'glibc' 'libtiger' 'lua'
+depends=('aribb25' 'libmfx' 'a52dec' 'libidn' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy' 'glibc' 'libtiger' 'lua'
'libmatroska' 'taglib' 'libmpcdec' 'ffmpeg' 'faad2' 'libupnp' 'libmad'
'libmpeg2' 'xcb-util-keysyms' 'mesa' 'libtar' 'libxinerama' 'libxkbcommon' 'libsecret'
'libarchive' 'qt5-base' 'qt5-x11extras' 'qt5-svg' 'freetype2'
'fribidi' 'harfbuzz' 'fontconfig' 'libxml2' 'gnutls' 'libplacebo'
'wayland-protocols')
-makedepends=('gst-plugins-base-libs' 'live-media' 'libnotify' 'glibc' 'libbluray'
- 'flac' 'kdelibs' 'libdc1394' 'libavc1394' 'libcaca' 'gtk3'
+makedepends=('aribb24' 'gst-plugins-base-libs' 'live-media' 'libnotify' 'glibc' 'libbluray'
+ 'flac' 'libdc1394' 'libavc1394' 'libcaca' 'gtk3'
'librsvg' 'libgme' 'xosd' 'twolame' 'aalib' 'avahi' 'libsystemd'
'libmtp' 'libmicrodns' 'libdvdcss' 'smbclient'
'vcdimager' 'libssh2' 'mesa' 'protobuf' 'libnfs' 'mpg123'
@@ -40,7 +40,6 @@ optdepends=('avahi: service discovery using bonjour protocol'
'libdvdcss: decoding encrypted DVDs'
'libavc1394: devices using the 1394ta AV/C'
'libdc1394: IEEE 1394 access plugin'
- 'kdelibs: KDE Solid hardware integration'
'kwallet: kwallet keystore'
'libva-vdpau-driver: vdpau backend nvidia'
'libva-intel-driver: video backend intel'
@@ -78,6 +77,7 @@ optdepends=('avahi: service discovery using bonjour protocol'
'libx264: H264 encoding'
'x265: HEVC/H.265 encoder'
'zvbi: VBI/Teletext decoding'
+ 'aribb24: ARIB subtitles'
'libass: Subtitle support'
'libkate: Kate codec'
'libtiger: Tiger rendering for Kate streams'
@@ -230,7 +230,9 @@ build() {
\
--libexecdir=/usr/lib \
--disable-daala \
- --enable-fdkaac
+ --enable-fdkaac \
+ --with-kde-solid=/usr/share/solid/actions/ \
+ --enable-aribsub
make V=1
}
@@ -254,7 +256,7 @@ package() {
# depends=("${_detected_depends[@]}" "${_undetected_depends[@]}")
}
-sha256sums=('ff08f92a87f707e4d85ed8d84c34725ecb3fc48a19b4ef26107578cf7bb571eb'
+sha256sums=('875078ec8a3912a51225701cb29ca7fb75d66a48adf2546ad63930c58569ec5e'
'c6f60c50375ae688755557dbfc5bd4a90a8998f8cf4d356c10d872a1a0b44f3a'
'75ad8802bad1a79754e40fd107f5a6922c54f7467dadef8b439b49d410c8f7d2'
'90b0e34d5772d2307ba07a1c2aa715db7488389003cfe6d3570b2a9c63061db7')