summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2015-06-10 18:31:25 -0400
committerSolomon Choina2015-06-10 18:31:25 -0400
commitc64851b37fa1e9a4e96da2bf2825213684d1f9ca (patch)
tree6e601f722574f062358d1d3a86423d0734d2f1a3
downloadaur-c64851b37fa1e9a4e96da2bf2825213684d1f9ca.tar.gz
first import
-rw-r--r--.SRCINFO104
-rw-r--r--PKGBUILD107
-rw-r--r--vlc-nightly.install18
3 files changed, 229 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90dd549b0412
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,104 @@
+# Generated by makepkg 4.2.1
+# Fri May 15 03:49:49 UTC 2015
+pkgbase = vlc-nightly
+ pkgdesc = A multi-platform MPEG, VCD/DVD, and DivX player - nightly GIT snapshot
+ pkgver = 3.0.0
+ pkgrel = 4
+ url = http://www.videolan.org/vlc/
+ install = vlc-nightly.install
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ license = GPL2
+ makedepends = live-media
+ makedepends = libnotify
+ makedepends = libbluray
+ makedepends = flac
+ makedepends = kdelibs
+ makedepends = fluidsynth
+ makedepends = libdc1394
+ makedepends = libavc1394
+ makedepends = lirc-utils
+ makedepends = libcaca
+ makedepends = librsvg
+ makedepends = portaudio
+ makedepends = libgme
+ makedepends = xosd
+ makedepends = projectm
+ makedepends = twolame
+ makedepends = aalib
+ makedepends = libmtp
+ makedepends = libdvdcss
+ makedepends = gnome-vfs
+ makedepends = libgoom2
+ makedepends = libtar
+ makedepends = vcdimager
+ makedepends = opus
+ makedepends = libssh2
+ makedepends = mesa
+ depends = a52dec
+ depends = libdvbpsi
+ depends = libxpm
+ depends = libdca
+ depends = qt4
+ depends = libproxy
+ depends = sdl_image
+ depends = libdvdnav
+ depends = libtiger
+ depends = lua
+ depends = libmatroska
+ depends = zvbi
+ depends = taglib
+ depends = libmpcdec
+ depends = ffmpeg
+ depends = faad2
+ depends = libupnp
+ depends = libshout
+ depends = libmad
+ depends = directfb
+ depends = libmpeg2
+ depends = libmodplug
+ depends = libass
+ depends = xcb-util-keysyms
+ optdepends = avahi: for service discovery using bonjour protocol
+ optdepends = libnotify: for notification plugin
+ optdepends = ncurses: for ncurses interface support
+ optdepends = libdvdcss: for decoding encrypted DVDs
+ optdepends = lirc-utils: for lirc plugin
+ optdepends = libavc1394: for devices using the 1394ta AV/C
+ optdepends = libdc1394: for IEEE 1394 plugin
+ optdepends = kdelibs: KDE Solid hardware integration
+ optdepends = libva-vdpau-driver: vdpau back-end for nvidia
+ optdepends = libva-intel-driver: back-end for intel cards
+ optdepends = libbluray: for Blu-Ray support
+ optdepends = flac: for Free Lossless Audio Codec plugin
+ optdepends = portaudio: for portaudio support
+ optdepends = twolame: for TwoLAME mpeg2 encoder plugin
+ optdepends = projectm: for ProjectM visualisation plugin
+ optdepends = libcaca: for colored ASCII art video output
+ optdepends = libgme: for libgme plugin
+ optdepends = librsvg: for SVG plugin
+ optdepends = gnome-vfs: for GNOME Virtual File System support
+ optdepends = libgoom2: for libgoom plugin
+ optdepends = vcdimager: navigate VCD with libvcdinfo
+ optdepends = xosd: for xosd support
+ optdepends = aalib: for ASCII art plugin
+ optdepends = libmtp: for MTP devices support
+ optdepends = fluidsynth: for synthesizer MIDI FluidSynth
+ optdepends = smbclient: for SMB access plugin
+ optdepends = libcdio: for audio CD playback support
+ optdepends = ttf-freefont: for subtitle font
+ optdepends = ttf-dejavu: for subtitle font
+ optdepends = opus: for opus support
+ optdepends = libssh2: for sftp support
+ provides = vlc
+ conflicts = vlc-plugin
+ conflicts = vlc
+ replaces = vlc-plugin
+ options = !libtool
+ options = !emptydirs
+ source = http://nightlies.videolan.org/build/source/vlc-3.0.0-20150511-0533.tar.xz
+ sha1sums = fad00a10e8c78ea0b1a5b619278d8c024de90eef
+
+pkgname = vlc-nightly
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb31777bbabc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,107 @@
+# $Id$
+# Maintainer: Sebastian Weiland <sebastianweiland97@gmail.com>
+# Original package: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+_appname_=vlc
+pkgname=${_appname_}-nightly
+pkgver=3.0.0
+_snapshot_=20150511-0533
+pkgrel=4
+pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player - nightly GIT snapshot"
+arch=("i686" "x86_64")
+url="http://www.videolan.org/vlc/"
+license=("LGPL2.1" "GPL2")
+depends=("a52dec" "libdvbpsi" "libxpm" "libdca" "qt4" "libproxy"
+ "sdl_image" "libdvdnav" "libtiger" "lua" "libmatroska"
+ "zvbi" "taglib" "libmpcdec" "ffmpeg" "faad2" "libupnp"
+ "libshout" "libmad" "directfb" "libmpeg2" "libmodplug" "libass"
+ "xcb-util-keysyms")
+makedepends=("live-media" "libnotify" "libbluray" "flac" "kdelibs"
+ "fluidsynth" "libdc1394" "libavc1394" "lirc-utils"
+ "libcaca" "librsvg" "portaudio" "libgme" "xosd"
+ "projectm" "twolame" "aalib" "libmtp" "libdvdcss"
+ "gnome-vfs" "libgoom2" "libtar" "vcdimager" "opus" "libssh2"
+ "mesa")
+optdepends=("avahi: for service discovery using bonjour protocol"
+ "libnotify: for notification plugin"
+ "ncurses: for ncurses interface support"
+ "libdvdcss: for decoding encrypted DVDs"
+ "lirc-utils: for lirc plugin"
+ "libavc1394: for devices using the 1394ta AV/C"
+ "libdc1394: for IEEE 1394 plugin"
+ "kdelibs: KDE Solid hardware integration"
+ "libva-vdpau-driver: vdpau back-end for nvidia"
+ "libva-intel-driver: back-end for intel cards"
+ "libbluray: for Blu-Ray support"
+ "flac: for Free Lossless Audio Codec plugin"
+ "portaudio: for portaudio support"
+ "twolame: for TwoLAME mpeg2 encoder plugin"
+ "projectm: for ProjectM visualisation plugin"
+ "libcaca: for colored ASCII art video output"
+ "libgme: for libgme plugin"
+ "librsvg: for SVG plugin"
+ "gnome-vfs: for GNOME Virtual File System support"
+ "libgoom2: for libgoom plugin"
+ "vcdimager: navigate VCD with libvcdinfo"
+ "xosd: for xosd support"
+ "aalib: for ASCII art plugin"
+ "libmtp: for MTP devices support"
+ "fluidsynth: for synthesizer MIDI FluidSynth"
+ "smbclient: for SMB access plugin"
+ "libcdio: for audio CD playback support"
+ "ttf-freefont: for subtitle font "
+ "ttf-dejavu: for subtitle font"
+ "opus: for opus support"
+ "libssh2: for sftp support")
+conflicts=("${_appname_}-plugin" "${_appname_}")
+provides=("${_appname_}")
+replaces=("${_appname_}-plugin")
+#backup=("usr/share/${_appname_}/lua/http/.hosts"
+# "usr/share/${_appname_}/lua/http/dialogs/.hosts")
+options=("!libtool" "!emptydirs")
+install="${pkgname}.install"
+source=("http://nightlies.videolan.org/build/source/vlc-${pkgver}-${_snapshot_}.tar.xz")
+
+build() {
+ cd "${_appname_}-3.0.0-git"
+
+ ./bootstrap
+
+ # Patch
+ sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype.c
+ sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
+
+ # Config
+ [ ${CARCH} = 'x86_64' ] && CXXFLAGS="$CXXFLAGS -fPIC"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-rpath \
+ --enable-faad \
+ --enable-nls \
+ --enable-lirc \
+ --enable-pvr \
+ --enable-ncurses \
+ --enable-realrtsp \
+ --enable-xosd \
+ --enable-aa \
+ --enable-vcdx \
+ --enable-upnp \
+ --enable-opus \
+ --enable-sftp
+
+ make -i
+}
+
+package() {
+ cd "${_appname_}-3.0.0-git"
+
+ make -i DESTDIR="${pkgdir}" install
+
+ for res in 16 32 48 128; do
+ install -D -m644 "${srcdir}/${_appname_}-3.0.0-git/share/icons/${res}x${res}/${_appname_}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/${_appname_}.png"
+ done
+}
+
+sha1sums=('fad00a10e8c78ea0b1a5b619278d8c024de90eef')
diff --git a/vlc-nightly.install b/vlc-nightly.install
new file mode 100644
index 000000000000..dc4961caee92
--- /dev/null
+++ b/vlc-nightly.install
@@ -0,0 +1,18 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ rm -f usr/lib/vlc/plugins/plugins-*.dat
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}