summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBooloki2020-11-11 08:33:46 +0100
committerBooloki2020-11-11 08:33:46 +0100
commitb72f8c74faf99e1698925332baf93264e64a1487 (patch)
tree1c4f7b7ff25a2db198b6039173cdf8d4d6502239
parent9aaa3de13067c5e03a9f89869b8f20f785258cce (diff)
downloadaur-b72f8c74faf99e1698925332baf93264e64a1487.tar.gz
Add aribcam plugin
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 841c8c505b5c..0f6239647e8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vlc-nox
pkgdesc = Multi-platform MPEG, VCD/DVD, and DivX player (without X support)
pkgver = 3.0.11.1
- pkgrel = 2
+ pkgrel = 3
url = https://www.videolan.org/vlc/
arch = x86_64
license = LGPL2.1
@@ -61,6 +61,9 @@ pkgbase = vlc-nox
makedepends = aom
makedepends = srt
makedepends = dav1d
+ makedepends = aribb24
+ makedepends = aribb25
+ makedepends = pcsclite
depends = a52dec
depends = libdvbpsi
depends = libxpm
@@ -149,6 +152,9 @@ pkgbase = vlc-nox
optdepends = projectm: ProjectM visualisation
optdepends = ncurses: ncurses interface
optdepends = libnotify: notification plugin
+ optdepends = aribb24: aribsub support
+ optdepends = aribb25: aribcam support
+ optdepends = pcsclite: aribcam support
conflicts = vlc
conflicts = vlc-plugin
conflicts = vlc-git
diff --git a/PKGBUILD b/PKGBUILD
index d84899323b8e..c5ac7d194380 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_pkgbase=vlc
pkgname=vlc-nox
pkgver=3.0.11.1
-pkgrel=2
+pkgrel=3
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player (without X support)'
url='https://www.videolan.org/vlc/'
arch=('x86_64')
@@ -26,7 +26,8 @@ makedepends=('live-media' 'libbluray' 'flac' 'libdc1394' 'libavc1394' 'libcaca'
'libvorbis' 'speex' 'opus' 'libtheora' 'libpng' 'libjpeg-turbo'
'libx265.so' 'libx264.so' 'zvbi' 'libass' 'libkate' 'libtiger'
'sdl_image' 'libpulse' 'alsa-lib' 'jack' 'libsamplerate' 'libsoxr'
- 'lirc' 'libgoom2' 'projectm' 'chromaprint' 'aom' 'srt' 'dav1d')
+ 'lirc' 'libgoom2' 'projectm' 'chromaprint' 'aom' 'srt' 'dav1d'
+ 'aribb24' 'aribb25' 'pcsclite')
optdepends=('avahi: service discovery using bonjour protocol'
'aom: AOM AV1 codec'
'dav1d: dav1d AV1 decoder'
@@ -86,7 +87,10 @@ optdepends=('avahi: service discovery using bonjour protocol'
'libgoom2: Goom visualization'
'projectm: ProjectM visualisation'
'ncurses: ncurses interface'
- 'libnotify: notification plugin')
+ 'libnotify: notification plugin'
+ 'aribb24: aribsub support'
+ 'aribb25: aribcam support'
+ 'pcsclite: aribcam support')
conflicts=('vlc' 'vlc-plugin' 'vlc-git')
replaces=('vlc' 'vlc-plugin' 'vlc-git')
options=('!emptydirs')
@@ -209,6 +213,7 @@ build() {
--enable-libplacebo \
--enable-vlc \
--enable-aribsub \
+ --enable-aribcam \
--enable-aom \
--enable-srt \
--enable-dav1d