summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2016-01-26 21:04:39 +0100
committerMichael Straube2016-01-26 21:04:39 +0100
commitecdfd55a44feb9eaae5d0ddae9af60d898cee847 (patch)
tree807912eb3b747f26393766535b3af41092c6ad97
downloadaur-ecdfd55a44feb9eaae5d0ddae9af60d898cee847.tar.gz
Initial Import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--pause-click.install4
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..382eac826c4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Jan 26 20:04:14 UTC 2016
+pkgbase = vlc-pause-click-plugin
+ pkgdesc = This plugin allows you to pause/play a video by clicking on the video image.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/nurupo/vlc-pause-click-plugin
+ install = pause-click.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = vlc
+ source = https://github.com/nurupo/vlc-pause-click-plugin/archive/0.2.1.tar.gz
+ sha256sums = c8252f388729546d34d15327fbd477f99cf7a9faf81b422e7d6e27a16b6bdc63
+
+pkgname = vlc-pause-click-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a07e71abdd6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Michael Straube <m.s.online gmx.de>
+
+pkgname=vlc-pause-click-plugin
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='This plugin allows you to pause/play a video by clicking on the video image.'
+arch=('i686' 'x86_64')
+license=('LGPL')
+url='https://github.com/nurupo/vlc-pause-click-plugin'
+depends=('vlc')
+install=pause-click.install
+source=("https://github.com/nurupo/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('c8252f388729546d34d15327fbd477f99cf7a9faf81b422e7d6e27a16b6bdc63')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/vlc-2.2.x+/"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/vlc-2.2.x+/"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/pause-click.install b/pause-click.install
new file mode 100644
index 000000000000..9fde6610e1b2
--- /dev/null
+++ b/pause-click.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "==> For instructions on how to activate the plugin see:"
+ echo "==> <https://github.com/nurupo/vlc-pause-click-plugin/tree/master/vlc-2.2.x%2B#usage>"
+}