summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorozgursarier2015-09-16 03:58:40 +0300
committerozgursarier2015-09-16 03:58:40 +0300
commit2423b0ec1db15b2e10ab61f7b7fb2dbee5f2c6e6 (patch)
tree649ecf26624c37fe70e9e65399819eadfc6adaf9
downloadaur-2423b0ec1db15b2e10ab61f7b7fb2dbee5f2c6e6.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD35
-rw-r--r--notes.install17
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90b73e81136f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = vlc-plugin-fluidsynth
+ pkgdesc = FluidSynth plugin for VLC
+ pkgver = 2.2.1
+ pkgrel = 4
+ url = http://www.videolan.org/vlc/
+ install = notes.install
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ depends = vlc
+ depends = fluidsynth
+ optdepends = soundfont-fluid: FluidR3_GM soundfont
+ optdepends = soundfont-toh: Don Allen's Timbres of Heaven soundfont
+ provides = vlc-plugin-fluidsynth=2.2.1
+ conflicts = vlc-plugin-fluidsynth-git
+ source = notes.install
+ md5sums = 08522396ead8dc126392fea4a26a7940
+ source_i686 = vlc-plugin-fluidsynth.deb::http://ftp.us.debian.org/debian/pool/main/v/vlc/vlc-plugin-fluidsynth_2.2.1-4_i386.deb
+ md5sums_i686 = 221cc6cca2507ee5f5584b2f757f040c
+ source_x86_64 = vlc-plugin-fluidsynth.deb::http://ftp.us.debian.org/debian/pool/main/v/vlc/vlc-plugin-fluidsynth_2.2.1-4_amd64.deb
+ md5sums_x86_64 = fa948b33dda99e25a2f17feaa07a1b86
+
+pkgname = vlc-plugin-fluidsynth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a30d76b044d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
+
+pkgname=vlc-plugin-fluidsynth
+pkgver=2.2.1
+pkgrel=4
+pkgdesc="FluidSynth plugin for VLC"
+arch=('i686' 'x86_64')
+url="http://www.videolan.org/vlc/"
+license=('LGPL2.1')
+depends=('vlc' 'fluidsynth')
+optdepends=("soundfont-fluid: FluidR3_GM soundfont"
+ "soundfont-toh: Don Allen's Timbres of Heaven soundfont")
+conflicts=("${pkgname}-git")
+provides=("${pkgname}=${pkgver}")
+install="notes.install"
+
+source_i686=("${pkgname}.deb::http://ftp.us.debian.org/debian/pool/main/v/vlc/${pkgname}_${pkgver}-${pkgrel}_i386.deb")
+source_x86_64=("${pkgname}.deb::http://ftp.us.debian.org/debian/pool/main/v/vlc/${pkgname}_${pkgver}-${pkgrel}_amd64.deb")
+source=("notes.install")
+
+md5sums_i686=('221cc6cca2507ee5f5584b2f757f040c')
+md5sums_x86_64=('fa948b33dda99e25a2f17feaa07a1b86')
+md5sums=('08522396ead8dc126392fea4a26a7940')
+
+prepare() {
+ cd "${srcdir}/"
+ mkdir -p "${srcdir}/data/"
+ tar -xf data.tar.xz -C "${srcdir}/data/"
+}
+
+package() {
+ cd "${srcdir}/"
+
+ install -Dm0755 "${srcdir}/data/usr/lib/vlc/plugins/codec/libfluidsynth_plugin.so" "$pkgdir/usr/lib/vlc/plugins/codec/libfluidsynth_plugin.so"
+}
diff --git a/notes.install b/notes.install
new file mode 100644
index 000000000000..cd7662f13cf0
--- /dev/null
+++ b/notes.install
@@ -0,0 +1,17 @@
+post_upgrade() {
+ usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
+}
+
+post_remove() {
+ post_upgrade
+}
+
+post_install() {
+ post_upgrade
+ printf "\e[37;1m\e[44;1m%s\e[0m\n" "\
+ Please install a soundfont in order fluidsynth plugin to
+ be able to play your midi files. Then, open vlc and select
+ your soundfont in Tools > Preferences > Show settings/All
+ (Advanced Preferences) > Input / Codecs > Audio codecs
+ > FluidSynth"
+}