summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-12-26 13:30:20 +0000
committerDaniel Bermond2020-12-26 13:30:20 +0000
commit9d4b6af580bede452d51e5f53753f02cf7ece3ef (patch)
treecd7817edae09ba42f4a1e5ae982611a8f47bf6d1
parent764538af807591d83f8825a3936abfbb9835e16b (diff)
downloadaur-9d4b6af580bede452d51e5f53753f02cf7ece3ef.tar.gz
Fix tests
It looks like that vmaf needs vim during build time for correctly handling the built-in models, as it searchs for the 'xxd' command (provided by vim) during the meson configuration. Without vim ('xxd' command), the test 'test_model' fails to run.
-rw-r--r--.SRCINFO6
-rw-r--r--010-vmaf-skip-test_model.patch25
-rw-r--r--PKGBUILD16
3 files changed, 8 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6ea3ff1c486..79f4bbf00cfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = vmaf-git
pkgdesc = Perceptual video quality assessment algorithm based on multi-method fusion (git version)
pkgver = 2.0.0.r27.g9f5ecc65
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Netflix/vmaf/
arch = x86_64
license = BSD
makedepends = git
makedepends = meson
makedepends = nasm
+ makedepends = vim
+ makedepends = doxygen
depends = gcc-libs
provides = vmaf
provides = libvmaf-git
@@ -15,9 +17,7 @@ pkgbase = vmaf-git
conflicts = libvmaf-git
replaces = libvmaf-git
source = git+https://github.com/Netflix/vmaf.git
- source = 010-vmaf-skip-test_model.patch
sha256sums = SKIP
- sha256sums = dcdf877aa1d21d635ec003b0c703343f30dfb772e1f9033a2708e0fc3726f39f
pkgname = vmaf-git
diff --git a/010-vmaf-skip-test_model.patch b/010-vmaf-skip-test_model.patch
deleted file mode 100644
index f6361b2c8253..000000000000
--- a/010-vmaf-skip-test_model.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/libvmaf/test/meson.build
-+++ b/libvmaf/test/meson.build
-@@ -33,14 +33,6 @@ test_thread_pool = executable('test_thread_pool',
- dependencies : thread_lib,
- )
-
--test_model = executable('test_model',
-- ['test.c', 'test_model.c', '../src/dict.c', '../src/svm.cpp', '../src/pdjson.c', '../src/read_json_model.c', '../src/log.c', json_model_c_sources],
-- include_directories : [libvmaf_inc, test_inc, include_directories('../src')],
-- c_args : vmaf_cflags_common,
-- cpp_args : vmaf_cflags_common,
-- dependencies : thread_lib,
--)
--
- test_predict = executable('test_predict',
- ['test.c', 'test_predict.c', '../src/predict.c', '../src/dict.c',
- '../src/feature/feature_collector.c', '../src/feature/alias.c', '../src/model.c', '../src/svm.cpp', '../src/log.c',
-@@ -82,7 +74,6 @@ test_ref = executable('test_ref',
- test('test_picture', test_picture)
- test('test_feature_collector', test_feature_collector)
- test('test_thread_pool', test_thread_pool)
--test('test_model', test_model)
- test('test_predict', test_predict)
- test('test_feature_extractor', test_feature_extractor)
- test('test_dict', test_dict)
diff --git a/PKGBUILD b/PKGBUILD
index 5222eca38fbf..e302bc856b08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,18 @@
pkgname=vmaf-git
pkgver=2.0.0.r27.g9f5ecc65
-pkgrel=1
+pkgrel=2
pkgdesc='Perceptual video quality assessment algorithm based on multi-method fusion (git version)'
arch=('x86_64')
url='https://github.com/Netflix/vmaf/'
license=('BSD')
depends=('gcc-libs')
-makedepends=('git' 'meson' 'nasm')
+makedepends=('git' 'meson' 'nasm' 'vim' 'doxygen')
provides=('vmaf' 'libvmaf-git')
conflicts=('vmaf' 'libvmaf-git')
replaces=('libvmaf-git')
-source=('git+https://github.com/Netflix/vmaf.git'
- '010-vmaf-skip-test_model.patch')
-sha256sums=('SKIP'
- 'dcdf877aa1d21d635ec003b0c703343f30dfb772e1f9033a2708e0fc3726f39f')
-
-prepare() {
- patch -d vmaf -Np1 -i "${srcdir}/010-vmaf-skip-test_model.patch"
-}
+source=('git+https://github.com/Netflix/vmaf.git')
+sha256sums=('SKIP')
pkgver() {
git -C vmaf describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
@@ -38,5 +32,5 @@ package() {
DESTDIR="$pkgdir" ninja -v -C vmaf/libvmaf/build install
install -D -m755 vmaf/libvmaf/build/tools/vmafossexec -t "${pkgdir}/usr/bin"
install -D -m644 vmaf/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- cp -a vmaf/model "${pkgdir}/usr/share"
+ cp -dr --no-preserve='ownership' vmaf/model "${pkgdir}/usr/share"
}