summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-12-03 02:58:43 +0000
committerDaniel Bermond2020-12-03 02:58:43 +0000
commita34a60b4df24c222a5eba1b43c8dcb79a68ac01b (patch)
treecf0938ab592df078d5d54a8ce7da7a3b8c6b35f2
parentb9b94c480993b8c924dd8f29b857582562cfafdd (diff)
downloadaur-a34a60b4df24c222a5eba1b43c8dcb79a68ac01b.tar.gz
Fix tests and match latest upstream changes
-rw-r--r--.SRCINFO4
-rw-r--r--010-vmaf-skip-test_model.patch25
-rw-r--r--PKGBUILD15
3 files changed, 39 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a787e8ca3121..f93f91ce2248 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vmaf-git
pkgdesc = Perceptual video quality assessment algorithm based on multi-method fusion (git version)
- pkgver = 1.5.2.r33.g08160410
+ pkgver = 1.5.3.r126.gca93c006
pkgrel = 1
url = https://github.com/Netflix/vmaf/
arch = x86_64
@@ -15,7 +15,9 @@ pkgbase = vmaf-git
conflicts = libvmaf-git
replaces = libvmaf-git
source = git+https://github.com/Netflix/vmaf.git
+ source = 010-vmaf-skip-test_model.patch
sha256sums = SKIP
+ sha256sums = 9e116b0a6a9b668c4f1d62929b7a0ab989bda97d5a57c41aad17668ae361f97c
pkgname = vmaf-git
diff --git a/010-vmaf-skip-test_model.patch b/010-vmaf-skip-test_model.patch
new file mode 100644
index 000000000000..f4d03cc3c25b
--- /dev/null
+++ b/010-vmaf-skip-test_model.patch
@@ -0,0 +1,25 @@
+--- a/libvmaf/test/meson.build
++++ b/libvmaf/test/meson.build
+@@ -28,14 +28,6 @@ test_thread_pool = executable('test_thread_pool',
+ dependencies : thread_lib,
+ )
+
+-test_model = executable('test_model',
+- ['test.c', 'test_model.c', '../src/dict.c', '../src/svm.cpp', '../src/pdjson.c', '../src/read_json_model.c', json_model_c_sources],
+- include_directories : [libvmaf_inc, test_inc, include_directories('../src')],
+- c_args : vmaf_cflags_common,
+- cpp_args : vmaf_cflags_common,
+- dependencies : thread_lib,
+-)
+-
+ test_predict = executable('test_predict',
+ ['test.c', 'test_predict.c', '../src/predict.c', '../src/dict.c',
+ '../src/feature/feature_collector.c', '../src/feature/alias.c', '../src/model.c', '../src/svm.cpp',
+@@ -77,7 +69,6 @@ test_ref = executable('test_ref',
+ test('test_picture', test_picture)
+ test('test_feature_collector', test_feature_collector)
+ test('test_thread_pool', test_thread_pool)
+-test('test_model', test_model)
+ test('test_predict', test_predict)
+ test('test_feature_extractor', test_feature_extractor)
+ test('test_dict', test_dict)
diff --git a/PKGBUILD b/PKGBUILD
index a1ec877e6559..3429d210e388 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=vmaf-git
-pkgver=1.5.2.r33.g08160410
+pkgver=1.5.3.r126.gca93c006
pkgrel=1
pkgdesc='Perceptual video quality assessment algorithm based on multi-method fusion (git version)'
arch=('x86_64')
@@ -12,8 +12,14 @@ makedepends=('git' 'meson' 'nasm')
provides=('vmaf' 'libvmaf-git')
conflicts=('vmaf' 'libvmaf-git')
replaces=('libvmaf-git')
-source=('git+https://github.com/Netflix/vmaf.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/Netflix/vmaf.git'
+ '010-vmaf-skip-test_model.patch')
+sha256sums=('SKIP'
+ '9e116b0a6a9b668c4f1d62929b7a0ab989bda97d5a57c41aad17668ae361f97c')
+
+prepare() {
+ patch -d vmaf -Np1 -i "${srcdir}/010-vmaf-skip-test_model.patch"
+}
pkgver() {
git -C vmaf describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
@@ -30,6 +36,7 @@ check() {
package() {
DESTDIR="$pkgdir" ninja -v -C vmaf/libvmaf/build install
- install -D -m755 vmaf/libvmaf/build/tools/vmaf_{feature,rc} -t "${pkgdir}/usr/bin"
+ install -D -m755 vmaf/libvmaf/build/tools/vmafossexec -t "${pkgdir}/usr/bin"
install -D -m644 vmaf/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cp -a vmaf/model "${pkgdir}/usr/share"
}