summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2020-06-13 09:39:27 +0300
committerAnton Kudelin2020-06-13 09:39:27 +0300
commit13a6e37b88e6b0b53e51b3286ccf5388c0418c7c (patch)
tree0aa4cd0e3b6746008d1e7c9a8eed2ad6a9923ee7
parentb76e49a197f9ca85917562e7126903efef435a8c (diff)
downloadaur-13a6e37b88e6b0b53e51b3286ccf5388c0418c7c.tar.gz
Updated to the latest alpha 43
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--configure.patch34
3 files changed, 28 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a52081318d41..91004ab76b01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vmd-src
pkgdesc = Visual Molecular Dynamics
- pkgver = 1.9.4a38
+ pkgver = 1.9.4a43
pkgrel = 1
url = http://www.ks.uiuc.edu/Research/vmd/
arch = x86_64
@@ -21,11 +21,11 @@ pkgbase = vmd-src
optdepends = cuda: NVIDIA CUDA GPU acceleration functions
conflicts = vmd
conflicts = vmd-bin
- source = local://vmd-1.9.4a38.src.tar.gz
+ source = local://vmd-1.9.4a43.src.tar.gz
source = configure.patch
source = mpi.patch
- sha256sums = 5ae1448c59369f99d0c9408b0acbc08a55bea9fa69f9b25fccc565ddac671fa9
- sha256sums = 96ce10c2d9728b416dbac83bfc30d84248044ea7371de7bbfbe854ba7e0adef5
+ sha256sums = 84323b2c34db8ce5739372dd6e225ef1fa1dc5c4b82d3810d55923a653b1bdc0
+ sha256sums = a0f4a14355aaa00c4b80b4c1115ea7731b7a5a1d65d5c0df6ed7f13665fecf75
sha256sums = e281a57831b8ff60c5a644219f0b6289d32bee239978af676474941c7d8548c0
pkgname = vmd-src
diff --git a/PKGBUILD b/PKGBUILD
index b8313040abd8..dcb6c123e0ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=vmd-src
_pkgname=vmd
-pkgver=1.9.4a38
+pkgver=1.9.4a43
pkgrel=1
pkgdesc="Visual Molecular Dynamics"
url="http://www.ks.uiuc.edu/Research/vmd/"
@@ -24,8 +24,8 @@ conflicts=("$_pkgname" "$_pkgname-bin")
source=("local://$_pkgname-${pkgver}.src.tar.gz"
"configure.patch"
"mpi.patch")
-sha256sums=('5ae1448c59369f99d0c9408b0acbc08a55bea9fa69f9b25fccc565ddac671fa9'
- '96ce10c2d9728b416dbac83bfc30d84248044ea7371de7bbfbe854ba7e0adef5'
+sha256sums=('84323b2c34db8ce5739372dd6e225ef1fa1dc5c4b82d3810d55923a653b1bdc0'
+ 'a0f4a14355aaa00c4b80b4c1115ea7731b7a5a1d65d5c0df6ed7f13665fecf75'
'e281a57831b8ff60c5a644219f0b6289d32bee239978af676474941c7d8548c0')
prepare() {
@@ -51,7 +51,7 @@ prepare() {
}
build() {
- cd $srcdir/plugins
+ cd "$srcdir/plugins"
make -j1 LINUXAMD64 world
make distrib
cd ../$_pkgname-$pkgver
@@ -62,8 +62,8 @@ build() {
}
package() {
- cd $srcdir/$_pkgname-$pkgver
- install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ cd "$srcdir/$_pkgname-$pkgver"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd src; make install
- sed -i 's#set defaultvmddir=.*#set defaultvmddir=/usr/lib/vmd#' $pkgdir/usr/bin/vmd
+ sed -i 's#set defaultvmddir=.*#set defaultvmddir=/usr/lib/vmd#' "$pkgdir/usr/bin/vmd"
}
diff --git a/configure.patch b/configure.patch
index 62d58821acf0..7f927d353a76 100644
--- a/configure.patch
+++ b/configure.patch
@@ -4,7 +4,7 @@
$arch_cc = "cc";
$arch_ccpp = "CC";
--$arch_nvcc = "/usr/local/cuda-10.0/bin/nvcc";
+-$arch_nvcc = "/usr/local/cuda-10.2/bin/nvcc";
+$arch_nvcc = "nvcc";
$arch_nvccflags = "-lineinfo --ptxas-options=-v " .
"-gencode arch=compute_30,code=compute_30 " .
@@ -39,29 +39,29 @@
# This option enables the use of CUDA GPU acceleration functions.
#######################
$cuda_defines = "-DVMDCUDA -DMSMPOT_CUDA";
--$cuda_dir = "/usr/local/cuda-10.0";
+-$cuda_dir = "/usr/local/cuda-10.2";
+$cuda_dir = "/opt/cuda";
$cuda_include = "";
$cuda_library = "";
$cuda_libs = "-Wl,-rpath -Wl,\$\$ORIGIN/ -lcudart_static -lrt";
-@@ -1098,7 +1092,7 @@
- # $liboptix_dir = "/usr/local/encap/NVIDIA-OptiX-SDK-4.1.1-linux64";
- # $liboptix_dir = "/usr/local/encap/NVIDIA-OptiX-SDK-5.0.0-linux64";
+@@ -1145,7 +1145,7 @@
# $liboptix_dir = "/usr/local/encap/NVIDIA-OptiX-SDK-5.0.1-linux64";
--$liboptix_dir = "/usr/local/encap/NVIDIA-OptiX-SDK-5.1.0-linux64";
-+$liboptix_dir = "/opt/optix";
+ # $liboptix_dir = "/usr/local/encap/NVIDIA-OptiX-SDK-5.1.0-linux64";
# $liboptix_dir = "/usr/local/encap/NVIDIA-OptiX-SDK-6.0.0-linux64";
+-$liboptix_dir = "/usr/local/encap/NVIDIA-OptiX-SDK-6.5.0-linux64";
++$liboptix_dir = "/opt/optix";
+ # $liboptix_dir = "/usr/local/encap/NVIDIA-OptiX-SDK-7.0.0-linux64";
# NCSA Blue Waters
-@@ -1148,7 +1142,7 @@
- $libospray_dir = "/usr/local/ospray-1.7.0.x86_64.linux";
- $libospray_include = "-I$libospray_dir/include -I$libospray_dir/ospray/include ";
- $libospray_library = "-L$libospray_dir/lib ";
--$libospray_libs = "-lospray -lospray_common -lembree -ltbb -ltbbmalloc ";
-+$libospray_libs = "-lospray -lospray_common -lembree3 -ltbb -ltbbmalloc ";
- # Both OptiX and OSPRay renderers use the Tachyon glwin code,
- # so we have to make sure we don't build/link it twice
- if ($config_liboptix) {
+@@ -1211,7 +1211,7 @@
+ $libospray_dir = "/usr/local/ospray-1.8.5.x86_64.linux";
+ $libospray_include = "-I$libospray_dir/include -I$libospray_dir/ospray/include ";
+ $libospray_library = "-L$libospray_dir/lib ";
+- $libospray_libs = "-lospray -lospray_common -lembree -ltbb -ltbbmalloc ";
++ $libospray_libs = "-lospray -lospray_common -lembree3 -ltbb -ltbbmalloc ";
+ }
+
+
@@ -1459,20 +1453,20 @@
###################
# location of Python library and include file.
@@ -105,7 +105,7 @@
if ($config_cuda) {
$arch_nvccflags .= " --machine 64 -O3 $cuda_include";
-- $cuda_library = "-L/usr/local/cuda-10.0/lib64";
+- $cuda_library = "-L/usr/local/cuda-10.2/lib64";
+ $cuda_library = "-L/opt/cuda/lib64";
}