summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2020-12-02 12:54:18 +0300
committerAnton Kudelin2020-12-02 12:54:18 +0300
commit300f01b7b07c0575d610f2d6083784222f909fdc (patch)
tree04bcbb8fb89b31a1c0d46a6020bbafdaebb62a42
parent524dcecf1ed071d2ce751668f234f0f6d2928716 (diff)
downloadaur-300f01b7b07c0575d610f2d6083784222f909fdc.tar.gz
python update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--configure.patch57
3 files changed, 40 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90e4d9f32ce1..c112f0569802 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmd-src
pkgdesc = Visual Molecular Dynamics
pkgver = 1.9.4a48
- pkgrel = 1
+ pkgrel = 2
url = http://www.ks.uiuc.edu/Research/vmd/
arch = x86_64
license = custom
@@ -26,7 +26,7 @@ pkgbase = vmd-src
source = mpi.patch
source = wkfthreads_reversal.patch
sha256sums = d1ef1260be2bb43aed891832cc2ad15df1bb8402cb47d848073342c3df917ea4
- sha256sums = dcda14b9a4b43824a968ccb6613e4f704f50ecbdce3bbdfde1257185b5a6af32
+ sha256sums = 1a36eeea92a362576fc1167f0bafb12ecf4c97562e0ae4b001743f5de6f0a48c
sha256sums = e281a57831b8ff60c5a644219f0b6289d32bee239978af676474941c7d8548c0
sha256sums = 1284e19124743fe85969ebbee67e4e4e5b6ec07e9c4c83f75f960db75b0587ad
diff --git a/PKGBUILD b/PKGBUILD
index c13c5ac74e11..5d3e46436514 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=vmd-src
_pkgname=vmd
pkgver=1.9.4a48
-pkgrel=1
+pkgrel=2
pkgdesc="Visual Molecular Dynamics"
url="http://www.ks.uiuc.edu/Research/vmd/"
license=('custom')
@@ -26,7 +26,7 @@ source=("local://$_pkgname-${pkgver}.src.tar.gz"
"mpi.patch"
"wkfthreads_reversal.patch")
sha256sums=('d1ef1260be2bb43aed891832cc2ad15df1bb8402cb47d848073342c3df917ea4'
- 'dcda14b9a4b43824a968ccb6613e4f704f50ecbdce3bbdfde1257185b5a6af32'
+ '1a36eeea92a362576fc1167f0bafb12ecf4c97562e0ae4b001743f5de6f0a48c'
'e281a57831b8ff60c5a644219f0b6289d32bee239978af676474941c7d8548c0'
'1284e19124743fe85969ebbee67e4e4e5b6ec07e9c4c83f75f960db75b0587ad')
@@ -60,7 +60,7 @@ build() {
make -j1 LINUXAMD64
make distrib
cd ../$_pkgname-$pkgver
- ./configure LINUXAMD64 OPENGL EGLPBUFFER FLTKOPENGL FLTK TK $ACC IMD OPENCL MPI XINERAMA XINPUT LIBOSPRAY LIBPNG ZLIB NETCDF COLVARS TCL PYTHON PTHREADS GCC
+ ./configure LINUXAMD64 OPENGL EGLPBUFFER FLTKOPENGL FLTK TK $ACC IMD OPENCL MPI XINERAMA XINPUT LIBOSPRAY LIBPNG ZLIB NETCDF COLVARS TCL PYTHON NUMPY PTHREADS GCC
cd src
make veryclean
make
diff --git a/configure.patch b/configure.patch
index f7679a54a503..1bff7361f8aa 100644
--- a/configure.patch
+++ b/configure.patch
@@ -1,6 +1,6 @@
---- configure 2020-01-23 14:40:20.000000000 +0300
-+++ configure 2020-01-23 14:56:53.679636518 +0300
-@@ -493,11 +493,10 @@
+--- configure 2020-12-02 12:41:14.529198213 +0300
++++ configure 2020-12-02 12:45:30.914220944 +0300
+@@ -496,19 +496,19 @@
$arch_cc = "cc";
$arch_ccpp = "CC";
@@ -10,12 +10,25 @@
- "-gencode arch=compute_30,code=compute_30 " .
- "-gencode arch=compute_30,code=sm_35 " .
- "-gencode arch=compute_30,code=sm_37 " .
+- "-gencode arch=compute_50,code=compute_50 " .
+ "-gencode arch=compute_35,code=sm_35 " .
+ "-gencode arch=compute_35,code=sm_37 " .
- "-gencode arch=compute_50,code=compute_50 " .
"-gencode arch=compute_50,code=sm_50 " .
- "-gencode arch=compute_60,code=compute_60 " .
-@@ -777,8 +776,8 @@
+- "-gencode arch=compute_60,code=compute_60 " .
++ "-gencode arch=compute_52,code=sm_52 " .
+ "-gencode arch=compute_60,code=sm_60 " .
+- "-gencode arch=compute_70,code=compute_70 " .
++ "-gencode arch=compute_61,code=sm_61 " .
+ "-gencode arch=compute_70,code=sm_70 " .
++ "-gencode arch=compute_75,code=sm_75 " .
++ "-gencode arch=compute_80,code=sm_80 " .
++ "-gencode arch=compute_86,code=sm_86 " .
+ "--ftz=true ";
+-# "-gencode arch=compute_75,code=sm_75 " .
+ $arch_gcc = "gcc";
+ $arch_gccpp = "g++";
+ $arch_lex = "lex";
+@@ -780,8 +780,8 @@
if ($config_tk) { $tcl_include .= " -I$stock_tk_include_dir"; }
$tcl_library = "-L$stock_tcl_library_dir";
if ($config_tk) { $tcl_library .= " -L$stock_tk_library_dir"; }
@@ -26,7 +39,7 @@
@tcl_cc = ();
@tcl_cu = ();
-@@ -906,13 +905,7 @@
+@@ -909,13 +909,7 @@
$system_dir = "";
$system_include = "-I.";
$system_library = "";
@@ -41,7 +54,7 @@
@system_cc = ();
@system_cu = ();
@system_ccpp = ();
-@@ -942,7 +935,7 @@
+@@ -971,7 +965,7 @@
# This option enables the use of CUDA GPU acceleration functions.
#######################
$cuda_defines = "-DVMDCUDA -DMSMPOT_CUDA";
@@ -50,7 +63,7 @@
$cuda_include = "";
$cuda_library = "";
$cuda_libs = "-Wl,-rpath -Wl,\$\$ORIGIN/ -lcudart_static -lrt";
-@@ -1151,7 +1144,7 @@
+@@ -1180,7 +1174,7 @@
# $liboptix_dir = "/usr/local/encap/NVIDIA-OptiX-SDK-5.0.1-linux64";
# $liboptix_dir = "/usr/local/encap/NVIDIA-OptiX-SDK-5.1.0-linux64";
# $liboptix_dir = "/usr/local/encap/NVIDIA-OptiX-SDK-6.0.0-linux64";
@@ -59,7 +72,7 @@
# $liboptix_dir = "/usr/local/encap/NVIDIA-OptiX-SDK-7.0.0-linux64";
# NCSA Blue Waters
-@@ -1217,7 +1210,7 @@
+@@ -1246,7 +1240,7 @@
$libospray_dir = "/usr/local/ospray-1.8.5.x86_64.linux";
$libospray_include = "-I$libospray_dir/include -I$libospray_dir/ospray/include ";
$libospray_library = "-L$libospray_dir/lib ";
@@ -68,7 +81,7 @@
}
-@@ -1629,16 +1622,16 @@
+@@ -1629,16 +1623,16 @@
$stock_numpy_library_dir=$ENV{"NUMPY_LIBRARY_DIR"} || "$conda_root/lib/python-3.7/site-packages/numpy/core/include";
$python_libs = "-fno-lto -lpython3.7m -lpthread";
} else {
@@ -82,20 +95,20 @@
- $stock_numpy_include_dir=$ENV{"NUMPY_INCLUDE_DIR"} || "$vmd_library_dir/numpy/lib_$config_arch/include";
- $stock_numpy_library_dir=$ENV{"NUMPY_LIBRARY_DIR"} || "$vmd_library_dir/python/lib_$config_arch/lib/python2.5/site-packages/numpy/core/include";
- $python_libs = "-lpython2.5 -lpthread";
-+ $stock_python_include_dir=$ENV{"PYTHON_INCLUDE_DIR"} || "/usr/include/python3.8";
-+ $stock_python_library_dir=$ENV{"PYTHON_LIBRARY_DIR"} || "/usr/lib/python3.8/config-3.8-x86_64-linux-gnu";
++ $stock_python_include_dir=$ENV{"PYTHON_INCLUDE_DIR"} || "/usr/include/python3.9";
++ $stock_python_library_dir=$ENV{"PYTHON_LIBRARY_DIR"} || "/usr/lib/python3.9/config-3.9-x86_64-linux-gnu";
+# $stock_python_include_dir=$ENV{"PYTHON_INCLUDE_DIR"} || "$vmd_library_dir/python/lib_$config_arch/include/python2.5";
+# $stock_python_library_dir=$ENV{"PYTHON_LIBRARY_DIR"} || "$vmd_library_dir/python/lib_$config_arch/lib/python2.5/config";
+
-+ $stock_numpy_include_dir=$ENV{"NUMPY_INCLUDE_DIR"} || "/usr/lib/python3.8/site-packages/numpy/core/include/numpy";
-+ $stock_numpy_library_dir=$ENV{"NUMPY_LIBRARY_DIR"} || "/usr/lib/python3.8/site-packages/numpy/core/include";
++ $stock_numpy_include_dir=$ENV{"NUMPY_INCLUDE_DIR"} || "/usr/lib/python3.9/site-packages/numpy/core/include/numpy";
++ $stock_numpy_library_dir=$ENV{"NUMPY_LIBRARY_DIR"} || "/usr/lib/python3.9/site-packages/numpy/core/include";
+# $stock_numpy_include_dir=$ENV{"NUMPY_INCLUDE_DIR"} || "$vmd_library_dir/numpy/lib_$config_arch/include";
+# $stock_numpy_library_dir=$ENV{"NUMPY_LIBRARY_DIR"} || "$vmd_library_dir/python/lib_$config_arch/lib/python2.5/site-packages/numpy/core/include";
-+ $python_libs = "-lpython3.8 -lpthread";
++ $python_libs = "-lpython3.9 -lpthread";
}
$python_defines = "-DVMDPYTHON";
-@@ -2499,9 +2492,9 @@
+@@ -2538,9 +2532,9 @@
# for compiling with g++:
$arch_cc = "gcc";
$arch_ccpp = "g++";
@@ -107,7 +120,7 @@
# so far only STATIC version tested
if ($config_static) {
-@@ -2513,7 +2506,7 @@
+@@ -2552,7 +2546,7 @@
if ($config_cuda) {
$arch_nvccflags .= " --machine 64 -O3 $cuda_include";
@@ -116,7 +129,7 @@
}
$arch_lex = "flex"; # has problems with vendor lex
-@@ -2551,7 +2544,7 @@
+@@ -2590,7 +2584,7 @@
$arch_nvcc = "/usr/local/cuda/bin/nvcc";
$arch_nvccflags = "--ptxas-options=-v " .
@@ -125,7 +138,7 @@
"-gencode arch=compute_70,code=compute_70 " .
"--ftz=true ";
$cuda_library = "-L/usr/local/cuda/lib64";
-@@ -2575,11 +2568,7 @@
+@@ -2614,11 +2608,7 @@
$arch_nvcc = "/usr/local/cuda-5.5/bin/nvcc";
$arch_nvccflags = "--ptxas-options=-v " .
@@ -137,7 +150,7 @@
"--ftz=true ";
$cuda_library = "-L/usr/local/cuda/lib";
$arch_cc = "cc";
-@@ -2913,7 +2902,7 @@
+@@ -2952,7 +2942,7 @@
# Only generate code for SM 7.0 on Summit
$arch_nvccflags = "--ptxas-options=-v " .
@@ -146,7 +159,7 @@
"-gencode arch=compute_70,code=sm_70 " .
"--ftz=true ";
$arch_nvccflags .= " --machine 64 -O3 $cuda_include";
-@@ -3541,7 +3530,7 @@
+@@ -3623,7 +3613,7 @@
.cu.ptx:
\$(ECHO) "Compiling " \$< " --> " \$*.ptx " ..."; \\