summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2021-11-07 20:52:36 +0200
committerAnton Kudelin2021-11-07 20:52:36 +0200
commit997acee6cffc1598279de381f5066566aec65a35 (patch)
tree53a1055da9d4f03f0c6f69bb02bd633000afeb24
parenta21ab5a59c16914bc115fe5c76f4dcde52472f4a (diff)
downloadaur-997acee6cffc1598279de381f5066566aec65a35.tar.gz
updpkg: 1.9a55
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--configure.patch18
3 files changed, 9 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d41b90d0d59..2cb0ba0cccc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmd-src
pkgdesc = Visual Molecular Dynamics
- pkgver = 1.9.4a51
- pkgrel = 5
+ pkgver = 1.9.4a55
+ pkgrel = 1
url = http://www.ks.uiuc.edu/Research/vmd/
arch = x86_64
arch = aarch64
@@ -22,9 +22,9 @@ pkgbase = vmd-src
optdepends = cuda: NVIDIA CUDA GPU acceleration functions
conflicts = vmd
conflicts = vmd-bin
- source = local://vmd-1.9.4a51.src.tar.gz
+ source = local://vmd-1.9.4a55.src.tar.gz
source = configure.patch
- sha256sums = b1c40b21111f5bab56d43d5e442c468d327159b07915af2ec175ba6b12842e5c
- sha256sums = cef0605dfeb529616c7b760696ac0305aa84e80eeffbbcb6e5473bc5a46760f9
+ sha256sums = cc8aef24cb61d8f9973e1b8d71c6356668456c115a846c47621b2edcd080508b
+ sha256sums = 0494d263458014886068276b0d72ea8c93bc3a05466d554aaf7f1ab027768a15
pkgname = vmd-src
diff --git a/PKGBUILD b/PKGBUILD
index 5a13b2da687f..6a7893435eee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgname=vmd-src
_pkgname=vmd
-pkgver=1.9.4a51
-pkgrel=5
+pkgver=1.9.4a55
+pkgrel=1
pkgdesc="Visual Molecular Dynamics"
url="http://www.ks.uiuc.edu/Research/vmd/"
license=('custom')
@@ -24,8 +24,8 @@ conflicts=("$_pkgname" "$_pkgname-bin")
# and put it in the PKGBUILD folder.
source=("local://$_pkgname-${pkgver}.src.tar.gz"
"configure.patch")
-sha256sums=('b1c40b21111f5bab56d43d5e442c468d327159b07915af2ec175ba6b12842e5c'
- 'cef0605dfeb529616c7b760696ac0305aa84e80eeffbbcb6e5473bc5a46760f9')
+sha256sums=('cc8aef24cb61d8f9973e1b8d71c6356668456c115a846c47621b2edcd080508b'
+ '0494d263458014886068276b0d72ea8c93bc3a05466d554aaf7f1ab027768a15')
prepare() {
sed -i 's/ltcl8.5/ltcl/g' plugins/Make-arch
diff --git a/configure.patch b/configure.patch
index fb26fb46ee94..b701c8421f90 100644
--- a/configure.patch
+++ b/configure.patch
@@ -186,21 +186,3 @@
"--ftz=true ";
$cuda_library = "-L/usr/local/cuda/lib";
$arch_cc = "cc";
-@@ -3080,7 +3070,7 @@
-
- # Only generate code for SM 7.0 on Summit
- $arch_nvccflags = "--ptxas-options=-v " .
-- "-gencode arch=compute_30,code=compute_30 " .
-+ "-gencode arch=compute_35,code=compute_35 " .
- "-gencode arch=compute_70,code=sm_70 " .
- "--ftz=true ";
- $arch_nvccflags .= " --machine 64 -O3 $cuda_include";
-@@ -3763,7 +3753,7 @@
-
- .cu.ptx:
- \$(ECHO) "Compiling " \$< " --> " \$*.ptx " ..."; \\
-- \$(NVCC) \$(DEFINES) --use_fast_math $liboptix_include -gencode arch=compute_30,code=compute_30 -ptx \$< $arch_coptout$vmd_arch_dir/\$\@
-+ \$(NVCC) \$(DEFINES) --use_fast_math $liboptix_include -gencode arch=compute_35,code=compute_35 -ptx \$< $arch_coptout$vmd_arch_dir/\$\@
-
- .y.o:
-