summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Fulz2024-04-10 23:42:25 +0200
committerMatthias Fulz2024-04-10 23:42:25 +0200
commit9d039a5b2d4af619e480a6284ca01ea5b8a6217b (patch)
tree769923eba3db3b4a9b05da2ec043f134125365ca
downloadaur-9d039a5b2d4af619e480a6284ca01ea5b8a6217b.tar.gz
vmime for grommunio
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD77
2 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0946db341d51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = vmime-libonly
+ pkgdesc = A C++ class library for working with MIME messages
+ pkgver = 0.9.2.r1270.d03ad5f0
+ pkgrel = 1
+ url = http://www.vmime.org/
+ arch = armv7l
+ arch = aarch64
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = postfix
+ makedepends = doxygen
+ makedepends = xdot
+ makedepends = git
+ depends = gsasl
+ depends = gnutls
+ provides = libvmime
+ conflicts = zarafa-libvmime
+ conflicts = kopano-libvmime
+ conflicts = libvmime
+ source = git+https://github.com/kisli/vmime
+ sha256sums = SKIP
+
+pkgname = vmime-libonly
+
+pkgname = vmime
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cb3f00c41b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Find this package on https://github.com/pietmacom/kopano-pkgbuilds.git
+_pkgname='vmime'
+pkgname=('vmime-libonly'
+ 'vmime')
+pkgver=0.9.2.r1270.d03ad5f0
+pkgrel=1
+provides=(
+ 'libvmime'
+ )
+pkgdesc='A C++ class library for working with MIME messages'
+arch=(
+ 'armv7l'
+ 'aarch64'
+ 'i686'
+ 'x86_64'
+ )
+url='http://www.vmime.org/'
+license=(
+ 'GPL'
+ )
+_url="https://github.com/kisli/${_pkgname}"
+
+conflicts=('zarafa-libvmime'
+ 'kopano-libvmime'
+ 'libvmime')
+
+source=("git+${_url}")
+sha256sums=('SKIP')
+makedepends=(
+ 'cmake'
+ 'postfix'
+ 'doxygen'
+ 'xdot'
+ 'git'
+ )
+depends=(
+ 'gsasl'
+ 'gnutls'
+ )
+
+#pkgver() {
+# cd ${srcdir}/${pkgname}
+# printf "$_ver.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+#}
+
+prepare() {
+ cd ${srcdir}/${_pkgname}
+ git checkout master
+ git pull
+}
+
+build() {
+ cmake \
+ -B build \
+ -S "${_pkgname}" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=/usr/lib/ \
+ -DCMAKE_BUILD_TYPE=Release
+
+ cmake --build build
+}
+
+package_vmime() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}
+
+package_vmime-libonly() {
+ cd build
+ make DESTDIR="$pkgdir" install
+
+ # fix for parallel installation
+ rm -rf ${pkgdir}/usr/include
+ rm -rf ${pkgdir}/usr/lib/libvmime.so
+ rm -rf ${pkgdir}/usr/lib/pkgconfig
+}
+