summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2018-08-01 09:17:04 +0200
committerAlexander F. Rødseth2018-08-01 09:17:04 +0200
commitb22ad829e7c50c8e4c51cae43dff48d01b3bb4c9 (patch)
tree5a7e4270d32a2b82199ce2be4925504c669815e8
parentdcf314b165217967826a9aee5aa14fbedeb50f42 (diff)
downloadaur-b22ad829e7c50c8e4c51cae43dff48d01b3bb4c9.tar.gz
Update the binfmt_misc configuration
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--wasm.conf2
3 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc0be22fafde..756368b2fafa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jul 31 13:09:44 UTC 2018
+# Wed Aug 1 07:16:52 UTC 2018
pkgbase = vmir
pkgdesc = Execute .wasm files directly
pkgver = 0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/andoma/vmir
arch = x86_64
license = MIT
@@ -12,7 +12,7 @@ pkgbase = vmir
source = git+https://github.com/andoma/vmir.git#commit=b8aebf545cbf570c9e4367cf8f162db457c06bc0
source = wasm.conf
sha256sums = SKIP
- sha256sums = f2f9a8401e8ab2ded3b655477e8eecc8cb4798178512bf8a15cf2263a572cd16
+ sha256sums = b10ca7ae90b202b0e1ffb72cfcdd06a5ab9e304b60ee9831854879c0950bf90c
pkgname = vmir
diff --git a/PKGBUILD b/PKGBUILD
index 5dff394a0737..7783c7bdf646 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=vmir
pkgver=0.1
-pkgrel=1
+pkgrel=2
pkgdesc='Execute .wasm files directly'
arch=('x86_64')
url='https://github.com/andoma/vmir'
@@ -11,18 +11,16 @@ makedepends=('clang' 'git')
source=("git+https://github.com/andoma/vmir.git#commit=b8aebf545cbf570c9e4367cf8f162db457c06bc0"
'wasm.conf')
sha256sums=('SKIP'
- 'f2f9a8401e8ab2ded3b655477e8eecc8cb4798178512bf8a15cf2263a572cd16')
+ 'b10ca7ae90b202b0e1ffb72cfcdd06a5ab9e304b60ee9831854879c0950bf90c')
prepare() {
sed -i \
- 's,Need .bc file to parse/run,Please pass a .wasm file as the first argument.,g' \
+ 's,Need .bc file to parse/run,Please provide a .wasm file as the first argument.,g' \
"$pkgname/src/main.c"
}
build() {
- cd "$pkgname"
-
- CC=clang make
+ CC=clang make -C "$pkgname"
}
package() {
@@ -30,7 +28,6 @@ package() {
install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- # TODO: Make sure the magic header for WASM is correct
install -Dm644 "$srcdir/wasm.conf" "$pkgdir/etc/binfmt.d/wasm.conf"
}
diff --git a/wasm.conf b/wasm.conf
index 0392cfde7e19..4c65f882678c 100644
--- a/wasm.conf
+++ b/wasm.conf
@@ -1 +1 @@
-:WebAssembly:E::\x00\x61\x73\x6d::/usr/bin/vmir:
+:WebAssembly:M::\x00\x61\x73\x6d::/usr/bin/vmir: