summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantinos2017-06-17 19:19:59 +0300
committerKonstantinos2017-06-17 19:19:59 +0300
commite87f3397b7c683532745a28f69c781fc87a73283 (patch)
tree3a8520934302c2d4b5ecde387f5948bf4301749b
downloadaur-vmpk-svn.tar.gz
useful commit message
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b2c18d05e02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = vmpk-svn
+ pkgdesc = Virtual MIDI Piano Keyboard. (SVN version)
+ pkgver = 20170416.474
+ pkgrel = 1
+ url = http://vmpk.sourceforge.net
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = cmake
+ makedepends = docbook-xsl
+ makedepends = qt5-tools
+ makedepends = libxkbcommon-x11
+ makedepends = subversion
+ depends = drumstick
+ depends = qt5-x11extras
+ provides = vmpk
+ conflicts = vmpk
+ source = svn+https://svn.code.sf.net/p/vmpk/code/trunk
+ sha256sums = SKIP
+
+pkgname = vmpk-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81e2eed678ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Konstantinos Foutzopoulos <mail@konfou.xyz>
+
+_pkgname=vmpk
+pkgname=${_pkgname}-svn
+pkgver=20170416.474
+pkgrel=1
+pkgdesc="Virtual MIDI Piano Keyboard. (SVN version)"
+arch=('x86_64' 'i686')
+url="http://vmpk.sourceforge.net"
+license=('GPL3')
+depends=('drumstick' 'qt5-x11extras')
+makedepends=('cmake' 'docbook-xsl' 'qt5-tools' 'libxkbcommon-x11' 'subversion')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("svn+https://svn.code.sf.net/p/${_pkgname}/code/trunk")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd trunk
+ svn info | awk '/Revision/{r=$2}/Date/{gsub(/-/,"");d=$4}END{print d"."r}'
+}
+
+build() {
+ cd trunk/desktop
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=release
+ make
+}
+
+package() {
+ cd trunk/desktop
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: