summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefano Angeleri2015-06-09 09:59:27 +0200
committerStefano Angeleri2015-06-09 09:59:27 +0200
commit581d443616ffe49cef350bcec14b535bc6f749e3 (patch)
treef5bf011bbbc4c8da339ce70e299ae277fda9792d
downloadaur-581d443616ffe49cef350bcec14b535bc6f749e3.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..083d89f54c56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vmtouch
+ pkgdesc = Portable file system cache diagnostics and control
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://github.com/hoytech/vmtouch
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = glibc
+ source = https://github.com/hoytech/vmtouch/tarball/vmtouch-0.8.0
+ md5sums = e0b874b5685538bbbb86251cbfead2e3
+
+pkgname = vmtouch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb9c1bbbac49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Stefano Angeleri <weltall2 AT gmail DOT com>
+# Contributor: Boris Shomodjvarac <spam AT shomodj DOT com>
+pkgname=vmtouch
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Portable file system cache diagnostics and control"
+arch=('i686' 'x86_64')
+url="https://github.com/hoytech/vmtouch"
+license=('BSD')
+source=("https://github.com/hoytech/vmtouch/tarball/$pkgname-$pkgver")
+md5sums=('e0b874b5685538bbbb86251cbfead2e3')
+depends=('glibc')
+
+build() {
+ cd "hoytech-vmtouch-a54935b"
+ gcc -Wall -O3 -o vmtouch vmtouch.c
+}
+
+package() {
+ cd "hoytech-vmtouch-a54935b"
+
+ install -Dm755 vmtouch $pkgdir/usr/bin/vmtouch
+ install -Dm644 vmtouch.8 $pkgdir/usr/share/man/man8/vmtouch.8
+}
+
+# vim:set ts=2 sw=2 et: