summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefano Angeleri2016-12-24 13:41:57 +0100
committerStefano Angeleri2016-12-24 13:41:57 +0100
commit70970809daa02f5e98232e0b6084add12bc86e28 (patch)
tree0be9b1410ebe4423d6245b5ac22869516b2a8793
parentfbd5c3f081f95b3199168a249adeb99c8397d631 (diff)
downloadaur-70970809daa02f5e98232e0b6084add12bc86e28.tar.gz
Updated vmtouch to 1.2.0 and changed arch to any
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3f4be6866451..218290cb43c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
# Maintainer: Stefano Angeleri <weltall2 AT gmail DOT com>
# Contributor: Boris Shomodjvarac <spam AT shomodj DOT com>
pkgname=vmtouch
-pkgver=1.0.1
-pkgrel=2
+pkgver=1.2.0
+pkgrel=1
pkgdesc="Portable file system cache diagnostics and control"
-arch=('i686' 'x86_64')
+arch=('any')
url="https://github.com/hoytech/vmtouch"
license=('BSD')
-source=("https://github.com/hoytech/vmtouch/tarball/$pkgname-$pkgver")
-md5sums=('ee7abf6103882d349281f5e166d11f77')
+source=("https://github.com/hoytech/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('09dad8440bad936e8b8accedd7a6b317')
depends=('glibc')
makedepends=('perl')
build() {
- cd "hoytech-vmtouch-ae0c045"
+ cd "vmtouch-$pkgver"
gcc -Wall -O3 -o vmtouch vmtouch.c
pod2man --section 8 vmtouch.pod > vmtouch.8
}
package() {
- cd "hoytech-vmtouch-ae0c045"
-
+ cd "vmtouch-$pkgver"
install -Dm755 vmtouch $pkgdir/usr/bin/vmtouch
install -Dm644 vmtouch.8 $pkgdir/usr/share/man/man8/vmtouch.8
}