summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefano Angeleri2015-10-22 14:55:26 +0200
committerStefano Angeleri2015-10-22 14:55:26 +0200
commitfbd5c3f081f95b3199168a249adeb99c8397d631 (patch)
treec636f3434fe447f8c49184f3fe91671389e2ae96
parente662dfa0e75ff4c1f932aca9ea7d783aef13a8ec (diff)
downloadaur-fbd5c3f081f95b3199168a249adeb99c8397d631.tar.gz
Fixed some package issues
Added perl build dependency (pod2man) and fixed file paths
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 562c7c558ddd..bb7d0a7a043a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = vmtouch
pkgdesc = Portable file system cache diagnostics and control
pkgver = 1.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hoytech/vmtouch
arch = i686
arch = x86_64
license = BSD
+ makedepends = perl
depends = glibc
source = https://github.com/hoytech/vmtouch/tarball/vmtouch-1.0.1
md5sums = ee7abf6103882d349281f5e166d11f77
diff --git a/PKGBUILD b/PKGBUILD
index ee24adf9231d..3f4be6866451 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Boris Shomodjvarac <spam AT shomodj DOT com>
pkgname=vmtouch
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Portable file system cache diagnostics and control"
arch=('i686' 'x86_64')
url="https://github.com/hoytech/vmtouch"
@@ -10,14 +10,16 @@ license=('BSD')
source=("https://github.com/hoytech/vmtouch/tarball/$pkgname-$pkgver")
md5sums=('ee7abf6103882d349281f5e166d11f77')
depends=('glibc')
+makedepends=('perl')
build() {
- cd "hoytech-vmtouch-a54935b"
+ cd "hoytech-vmtouch-ae0c045"
gcc -Wall -O3 -o vmtouch vmtouch.c
+ pod2man --section 8 vmtouch.pod > vmtouch.8
}
package() {
- cd "hoytech-vmtouch-a54935b"
+ cd "hoytech-vmtouch-ae0c045"
install -Dm755 vmtouch $pkgdir/usr/bin/vmtouch
install -Dm644 vmtouch.8 $pkgdir/usr/share/man/man8/vmtouch.8