summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2016-03-18 21:01:56 +0100
committerPiotr Rogoża2016-03-18 21:01:56 +0100
commit562380c985807a30e56b154150ea295d00714f61 (patch)
tree8d21c3057f43742306403caf97324f3df5fb4663
parentd16a3ccd0f9e3a6c4401d29186a337efcff779fc (diff)
downloadaur-562380c985807a30e56b154150ea295d00714f61.tar.gz
Improved PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD44
2 files changed, 13 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c05873d949a0..16bfeca426ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Mar 18 20:01:53 UTC 2016
pkgbase = vmtouch-systemd-git
pkgdesc = Systemd support for vmtouch.
- pkgver = 1.1
+ pkgver = r6.196c4c7
pkgrel = 1
url = https://github.com/dracorp/vmtouch-systemd
arch = any
license = GPL
makedepends = git
- depends = bash
depends = libui-sh
depends = vmtouch
provides = vmtouch-systemd
conflicts = vmtouch-systemd
backup = etc/vmtouch.conf
backup = etc/default/vmtouch
+ source = git://github.com/dracorp/vmtouch-systemd.git
+ sha256sums = SKIP
pkgname = vmtouch-systemd-git
diff --git a/PKGBUILD b/PKGBUILD
index 66e050245d15..6458d1332f39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,13 @@
-# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
-# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public@gmail.com>
pkgname=vmtouch-systemd-git
-pkgver=1.1
+pkgver=r6.196c4c7
pkgrel=1
pkgdesc='Systemd support for vmtouch.'
arch=('any')
url='https://github.com/dracorp/vmtouch-systemd'
license=('GPL')
-groups=()
-depends=(bash libui-sh vmtouch)
+depends=(libui-sh vmtouch)
makedepends=(git)
provides=(vmtouch-systemd)
conflicts=(vmtouch-systemd)
@@ -18,39 +15,14 @@ backup=(
etc/vmtouch.conf
etc/default/vmtouch
)
-_gitroot='https://github.com/dracorp/vmtouch-systemd.git'
+source=('git://github.com/dracorp/vmtouch-systemd.git')
+sha256sums=('SKIP')
_gitname='vmtouch-systemd'
-
pkgver() {
- if [ -d "$srcdir"/$_gitname ]; then
- cd "$srcdir"/$_gitname
- git describe --always | sed 's|-|.|g'
- fi
-}
-build(){
- cd "$srcdir"
- msg2 "Connecting to GIT server...."
-
- if [ -d ${_gitname}/.git ] ; then
- cd $_gitname
- git pull --depth 1 origin
- msg2 "The local files are updated."
- else
- git clone --depth 1 $_gitroot $_gitname
- cd $_gitname
- fi
-
- msg2 "GIT checkout done or server timeout"
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
-package(){
+package() {
cd "$srcdir"/$_gitname
-
make DESTDIR="$pkgdir" install
-
-# install -Dm755 vmtouch.sh "$pkgdir"/usr/lib/systemd/scripts/vmtouch
-# install -Dm644 vmtouch.service "$pkgdir"/usr/lib/systemd/system/vmtouch.service
-# install -Dm644 vmtouch.default "$pkgdir"/etc/default/vmtouch
-# install -Dm644 vmtouch.conf "$pkgdir"/etc/vmtouch.conf
-
}
-