summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Potapenko2024-01-28 19:01:07 +0100
committerAlex Potapenko2024-01-28 19:01:07 +0100
commit4f257b37b0dbb1dd0b2a209e4d92ef27f8166259 (patch)
tree680a54472826811d18505bf24279f06c54953e1d
parent86e838f17de6c3c62191a3ee505ded9d846beabd (diff)
downloadaur-4f257b37b0dbb1dd0b2a209e4d92ef27f8166259.tar.gz
Workstation 17.5.0. Since there's no tag for 17.5.0, change naming convention to (branch_version).d(date).(hash), bump epoch. Remove unneeded legacy code.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
2 files changed, 12 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26b98e845d18..82d16e3e01e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = vmware-host-modules-dkms-git
pkgdesc = Patches needed to build VMware Player host modules against recent kernels
- pkgver = w17.0.1.r12.g78b7781
+ pkgver = 17.5.0.d20240112.2c6d66f
pkgrel = 1
- epoch = 1
+ epoch = 2
url = https://github.com/mkubecek/vmware-host-modules
arch = x86_64
arch = aarch64
@@ -16,7 +16,7 @@ pkgbase = vmware-host-modules-dkms-git
conflicts = vmware-host-modules-dkms
conflicts = vmware-host-modules
conflicts = vmware-workstation
- source = git+https://github.com/mkubecek/vmware-host-modules.git#branch=workstation-17.0.1
+ source = git+https://github.com/mkubecek/vmware-host-modules.git#branch=workstation-17.5.0
source = dkms-vmmon.conf
source = dkms-vmnet.conf
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8046a96f3471..36c2dcca4881 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
-# Maintainer: Imperator Storm <ImperatorStorm11@protonmail.com>
+# Maintainer: Alex Potapenko <opotapenko@gmail.com>
+# Submitter and original maintainer: Imperator Storm <ImperatorStorm11@protonmail.com>
pkgname=vmware-host-modules-dkms-git
_pkgname=vmware-host-modules
-pkgver=w17.0.1.r12.g78b7781
-_pkgver=$(echo $pkgver | cut -c 2-7)
+pkgver=17.5.0.d20240112.2c6d66f
+_branch_version=17.5.0
url='https://github.com/mkubecek/vmware-host-modules'
pkgrel=1
-epoch=1
+epoch=2
pkgdesc='Patches needed to build VMware Player host modules against recent kernels'
arch=('x86_64' 'aarch64' 'i386')
license=('GPL2')
provides=(vmware-host-modules-dkms vmware-host-modules)
conflicts=(vmware-host-modules-dkms vmware-host-modules vmware-workstation)
depends=('dkms')
-makedepends=('git' 'fd')
-source=("git+https://github.com/mkubecek/${_pkgname}.git#branch=workstation-$_pkgver"
+makedepends=('git')
+source=("git+https://github.com/mkubecek/${_pkgname}.git#branch=workstation-${_branch_version}"
dkms-vmmon.conf
dkms-vmnet.conf)
sha256sums=('SKIP'
'ed52e41b8f2b525915d47c350f4e6dec064b01d6f894e32b513a01e0f1162c4d'
'b218e4ec45f5c2f960333d209442a0a98fa525ee034947c0be724f2f77d0a4a9')
+
pkgver(){
cd ${srcdir}/${_pkgname}
- git describe --long | sed 's/p//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git show -s --date=short --format=format:"${_branch_version}.d%cd.%h" | tr -d -
}
package() {
@@ -32,17 +34,4 @@ package() {
cp -r "${srcdir}/${_pkgname}/vmnet-only/"* "${pkgdir}/usr/src/vmnet-1/"
cp "${srcdir}/dkms-vmmon.conf" "${pkgdir}/usr/src/vmmon-1/dkms.conf"
cp "${srcdir}/dkms-vmnet.conf" "${pkgdir}/usr/src/vmnet-1/dkms.conf"
- cd "${srcdir}/${_pkgname}/"
- # is there even a point to doing this?
- #make clean
- #make
- #make DESTDIR="${pkgdir}/usr/src/" install
-
- # nuke files we don't want
- for file in o cmd symvers order ko mod
- do
- fd -HIig -tf '*.${file}' ${pkgdir}/usr/src/ -X rm
- done
- fd -HIig -tf 'mod.c' ${pkgdir}/usr/src/ -X rm
}
-# vim:set ts=2 sw=2 etc