summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Kitsinger (SwooshyCueb)2016-05-26 01:35:30 -0500
committerMarkus Kitsinger (SwooshyCueb)2016-05-26 01:35:30 -0500
commitae71137d1eafd0242bd1b83f22192fdfffc7a2ac (patch)
treec40959ae3c1d22d0913c626efc69189fc3fbdb4a
parentc09a9ce303fcfd92e4978ee0997c3ddd985d0230 (diff)
downloadaur-ae71137d1eafd0242bd1b83f22192fdfffc7a2ac.tar.gz
Update patches for 4.6 (untested)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--vmci.patch60
-rw-r--r--vmmon.patch14
-rw-r--r--vmnet.patch16
5 files changed, 92 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 983e7667e2a3..7459ea073bfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-modules-dkms
pkgdesc = VMware Workstation kernel modules (DKMS)
pkgver = 308.0
- pkgrel = 7
+ pkgrel = 8
url = http://www.vmware.com/
install = vmware-modules-dkms.install
arch = i686
@@ -24,9 +24,9 @@ pkgbase = vmware-modules-dkms
sha256sums = 7baecdfd979d57aed7dac0db57e0165fc1730b15ed6bf42ed25571e68ec34b52
sha256sums = 707596776b0b232f7f5de4a0ddff12262df3bc934180afd956ea2ee45ac4db9e
sha256sums = 48951fcb72e1f964e21dc3f7ea4729dd673936abdd28b54008dbca9b0967683f
- sha256sums = 3f6bcef6e88718a4d2b5aba8a10856ad0857006755c2ccaa5de8fc596441770c
- sha256sums = 9a1973abf269d7c9d49b8789e7a2e55595e712e644b2eade849fa19510b0c2f3
- sha256sums = 2eb2ad24722e0ddd97387c48266295204aea95de8970eec427e3931769d15e19
+ sha256sums = 1d773551e51b3eca2be6f71ed77bc563409d309eef661ab6c298117f068d5530
+ sha256sums = cd093ec14f05c1bdf268be2ca3d2ff85616493867de48452d45a527248c5254d
+ sha256sums = 94bb3e6f283ef97b21b1e03a837f37bf65295f0d159582a94b9c70035344e7ee
sha256sums = a97e5096ef1b1595b2d1ed6b86b0fde80e34c6310f566156bcd4f5d660a74a58
pkgname = vmware-modules-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 9a76f7d464ea..cd77a6660163 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=vmware-modules-dkms
_pkgbase=vmware-modules
pkgver=308.0
-pkgrel=7
+pkgrel=8
pkgdesc="VMware Workstation kernel modules (DKMS)"
arch=('i686' 'x86_64')
url="http://www.vmware.com/"
@@ -34,9 +34,9 @@ sha256sums=('ee3e5cfac51703ac392bce540e3375680c579eaac7aa31990e1e08ada589e89b'
'7baecdfd979d57aed7dac0db57e0165fc1730b15ed6bf42ed25571e68ec34b52'
'707596776b0b232f7f5de4a0ddff12262df3bc934180afd956ea2ee45ac4db9e'
'48951fcb72e1f964e21dc3f7ea4729dd673936abdd28b54008dbca9b0967683f'
- '3f6bcef6e88718a4d2b5aba8a10856ad0857006755c2ccaa5de8fc596441770c'
- '9a1973abf269d7c9d49b8789e7a2e55595e712e644b2eade849fa19510b0c2f3'
- '2eb2ad24722e0ddd97387c48266295204aea95de8970eec427e3931769d15e19'
+ '1d773551e51b3eca2be6f71ed77bc563409d309eef661ab6c298117f068d5530'
+ 'cd093ec14f05c1bdf268be2ca3d2ff85616493867de48452d45a527248c5254d'
+ '94bb3e6f283ef97b21b1e03a837f37bf65295f0d159582a94b9c70035344e7ee'
'a97e5096ef1b1595b2d1ed6b86b0fde80e34c6310f566156bcd4f5d660a74a58')
build()
diff --git a/vmci.patch b/vmci.patch
index 465fa2dd6192..353822bda541 100644
--- a/vmci.patch
+++ b/vmci.patch
@@ -1,5 +1,5 @@
diff --git a/vmci/linux/driver.c b/vmci/linux/driver.c
-index 64a3cca..08ec0c5 100644
+index 64a3cca..526f9a9 100644
--- a/vmci/linux/driver.c
+++ b/vmci/linux/driver.c
@@ -26,6 +26,7 @@
@@ -31,7 +31,19 @@ index 64a3cca..08ec0c5 100644
retval = VMCIContext_InitContext(initBlock.cid, initBlock.flags,
0 /* Unused */, vmciLinux->userVersion,
&user, &vmciLinux->context);
-@@ -1683,7 +1688,11 @@ vmci_guest_init(void)
+@@ -1467,7 +1472,11 @@ VMCIUserVALockPage(VA addr) // IN:
+ int retval;
+
+ down_read(&current->mm->mmap_sem);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
++ retval = get_user_pages(addr,
++#else
+ retval = get_user_pages(current, current->mm, addr,
++#endif
+ 1, 1, 0, &page, NULL);
+ up_read(&current->mm->mmap_sem);
+
+@@ -1683,7 +1692,11 @@ vmci_guest_init(void)
/* This should be last to make sure we are done initializing. */
retval = pci_register_driver(&vmci_driver);
if (retval < 0) {
@@ -43,7 +55,7 @@ index 64a3cca..08ec0c5 100644
data_buffer = NULL;
return retval;
}
-@@ -2470,7 +2479,11 @@ vmci_exit(void)
+@@ -2470,7 +2483,11 @@ vmci_exit(void)
if (guestDeviceInit) {
pci_unregister_driver(&vmci_driver);
@@ -55,7 +67,7 @@ index 64a3cca..08ec0c5 100644
guestDeviceInit = FALSE;
}
-@@ -2479,12 +2492,16 @@ vmci_exit(void)
+@@ -2479,12 +2496,16 @@ vmci_exit(void)
VMCI_HostCleanup();
@@ -73,7 +85,7 @@ index 64a3cca..08ec0c5 100644
hostDeviceInit = FALSE;
}
diff --git a/vmci/linux/vmciKernelIf.c b/vmci/linux/vmciKernelIf.c
-index 8b1788f..15766bf 100644
+index 8b1788f..12cce68 100644
--- a/vmci/linux/vmciKernelIf.c
+++ b/vmci/linux/vmciKernelIf.c
@@ -40,6 +40,7 @@
@@ -124,6 +136,44 @@ index 8b1788f..15766bf 100644
if (err != 0) {
if (kernelIf->host) {
kunmap(kernelIf->u.h.page[pageIndex]);
+@@ -1834,7 +1851,11 @@ VMCIReleasePages(struct page **pages, // IN
+ if (dirty) {
+ set_page_dirty(pages[i]);
+ }
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
++ put_page(pages[i]);
++#else
+ page_cache_release(pages[i]);
++#endif
+ pages[i] = NULL;
+ }
+ }
+@@ -2048,8 +2069,12 @@ VMCIHost_GetUserMemory(VA64 produceUVA, // IN
+ int err = VMCI_SUCCESS;
+
+ down_write(&current->mm->mmap_sem);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
++ retval = get_user_pages(
++#else
+ retval = get_user_pages(current,
+ current->mm,
++#endif
+ (VA)produceUVA,
+ produceQ->kernelIf->numPages,
+ 1, 0,
+@@ -2062,8 +2087,12 @@ VMCIHost_GetUserMemory(VA64 produceUVA, // IN
+ goto out;
+ }
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
++ retval = get_user_pages(
++#else
+ retval = get_user_pages(current,
+ current->mm,
++#endif
+ (VA)consumeUVA,
+ consumeQ->kernelIf->numPages,
+ 1, 0,
diff --git a/vmci/shared/vm_device_version.h b/vmci/shared/vm_device_version.h
index e2cb477..3dd7097 100644
--- a/vmci/shared/vm_device_version.h
diff --git a/vmmon.patch b/vmmon.patch
index b0aeddea1e13..fe1231c1704e 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -12,7 +12,7 @@ index 0a72335..63cea5d 100644
{
TSCDelta tscDelta;
diff --git a/vmmon/linux/hostif.c b/vmmon/linux/hostif.c
-index d1bc8ba..918e8ce 100644
+index d1bc8ba..4d5018b 100644
--- a/vmmon/linux/hostif.c
+++ b/vmmon/linux/hostif.c
@@ -74,6 +74,7 @@
@@ -23,6 +23,18 @@ index d1bc8ba..918e8ce 100644
#include "vmware.h"
#include "x86apic.h"
+@@ -1162,7 +1163,11 @@ HostIFGetUserPages(void *uvAddr, // IN
+ int retval;
+
+ down_read(&current->mm->mmap_sem);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
++ retval = get_user_pages((unsigned long)uvAddr,
++#else
+ retval = get_user_pages(current, current->mm, (unsigned long)uvAddr,
++#endif
+ numPages, 0, 0, ppages, NULL);
+ up_read(&current->mm->mmap_sem);
+
diff --git a/vmmon/linux/vmmonInt.h b/vmmon/linux/vmmonInt.h
index 4dc04e9..993212d 100644
--- a/vmmon/linux/vmmonInt.h
diff --git a/vmnet.patch b/vmnet.patch
index 910cbc07c8f8..05e990a76187 100644
--- a/vmnet.patch
+++ b/vmnet.patch
@@ -1,3 +1,19 @@
+diff --git a/vmnet/userif.c b/vmnet/userif.c
+index 4e457ba..b7b186a 100644
+--- a/vmnet/userif.c
++++ b/vmnet/userif.c
+@@ -113,7 +113,11 @@ UserifLockPage(VA addr) // IN
+ int retval;
+
+ down_read(&current->mm->mmap_sem);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
++ retval = get_user_pages(addr,
++#else
+ retval = get_user_pages(current, current->mm, addr,
++#endif
+ 1, 1, 0, &page, NULL);
+ up_read(&current->mm->mmap_sem);
+
diff --git a/vmnet/vm_device_version.h b/vmnet/vm_device_version.h
index e2cb477..3dd7097 100644
--- a/vmnet/vm_device_version.h