summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRains2017-03-01 11:14:43 +0800
committerRains2017-03-01 11:14:43 +0800
commit26132fd04f480258b12357a14cc6f5dda14ada65 (patch)
tree911ad20a7d02f83e5721737f0af1d0a8f5f6f33a
parent0f9b3431098f822d6d8111a76beadd99af1f5427 (diff)
downloadaur-26132fd04f480258b12357a14cc6f5dda14ada65.tar.gz
add linux 4.9 & 4.10 support
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--vmmon-12.5.2-4.9.patch21
-rw-r--r--vmnet-12.5.2-4.9.patch21
4 files changed, 58 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 679870dd31e8..bf644035f1ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# 三 3月 1 03:14:27 UTC 2017
pkgbase = vmware-patch
pkgdesc = A post-install configuration solution for VMware Workstation (Pro) and Player (Plus and Pro)
- pkgver = 12.0.0
- pkgrel = 4
+ pkgver = 12.5.2
+ pkgrel = 1
url = https://wiki.archlinux.org/index.php/VMware#Configuration
install = vmware-patch.install
arch = i686
@@ -18,6 +20,8 @@ pkgbase = vmware-patch
source = vmware.service
source = vmware-usbarbitrator.service
source = vmware-workstation.service
+ source = vmmon-12.5.2-4.9.patch
+ source = vmnet-12.5.2-4.9.patch
source = vmci-12.0.0-4.2.patch
source = vmblock-11.1.2-4.2.patch
source = vmmon-11.1.2-4.2.patch
@@ -42,6 +46,8 @@ pkgbase = vmware-patch
md5sums = c12e765985b324585a548718a6ac9b43
md5sums = ea3817fb7952932707bfedcf33a70697
md5sums = 56f7f642683e54250372bb57faaf4e95
+ md5sums = 7acdc91c88c64d55bd775d2fcdc1b242
+ md5sums = 5eb0567825f0dea3d7c9f21038463de9
md5sums = 133f3ba5c19ceb00a4ae8f44dc08352a
md5sums = 36727e319ce5379e5227f618401fd313
md5sums = 905d6daa87b314e541eec00ca4f927c6
diff --git a/PKGBUILD b/PKGBUILD
index a42ae43ed51a..b2936cd24011 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Det <nimetonmaili g-mail>
+# Maintainer: Det <nimetonmaili g-mail>, Rains <rains31@gmail>
# Contributors: Igor Duarte Cardoso, haagch, Olivier Médoc
pkgname=vmware-patch
-pkgver=12.0.0
-pkgrel=4
+pkgver=12.5.2
+pkgrel=1
pkgdesc="A post-install configuration solution for VMware Workstation (Pro) and Player (Plus and Pro)"
arch=('i686' 'x86_64')
url="https://wiki.archlinux.org/index.php/VMware#Configuration"
@@ -12,6 +12,9 @@ depends=('fuse' 'gtkmm' 'linux-headers' 'ncurses5-compat-libs')
options=('!emptydirs')
install=$pkgname.install
source=('vmware-patch.sh' 'vmware-unpatch.sh' 'common-functions.sh' 'vmware.service' 'vmware-usbarbitrator.service' 'vmware-workstation.service'
+ # Workstation Pro/Player 12.5.2
+ 'vmmon-12.5.2-4.9.patch'
+ 'vmnet-12.5.2-4.9.patch'
# Workstation Pro/Player 12.0.0
'vmci-12.0.0-4.2.patch'
# Workstation 11.1.2 / Player (Pro) 7.1.2
@@ -63,6 +66,8 @@ md5sums=('1fe73e49d253eeba8be2c9d066cf42cb'
'c12e765985b324585a548718a6ac9b43'
'ea3817fb7952932707bfedcf33a70697'
'56f7f642683e54250372bb57faaf4e95'
+ '7acdc91c88c64d55bd775d2fcdc1b242'
+ '5eb0567825f0dea3d7c9f21038463de9'
'133f3ba5c19ceb00a4ae8f44dc08352a'
'36727e319ce5379e5227f618401fd313'
'905d6daa87b314e541eec00ca4f927c6'
diff --git a/vmmon-12.5.2-4.9.patch b/vmmon-12.5.2-4.9.patch
new file mode 100644
index 000000000000..f0761e25d328
--- /dev/null
+++ b/vmmon-12.5.2-4.9.patch
@@ -0,0 +1,21 @@
+diff --git vmmon-only/linux/hostif.c vmmon-only/linux/hostif.c
+index 7053a83..614e181 100644
+--- vmmon-only/linux/hostif.c
++++ vmmon-only/linux/hostif.c
+@@ -1162,12 +1162,16 @@ HostIFGetUserPages(void *uvAddr, // IN
+ int retval;
+
+ down_read(&current->mm->mmap_sem);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 9, 0)
++ retval = get_user_pages((unsigned long)uvAddr, numPages, 0, ppages, NULL);
++#else
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
+ retval = get_user_pages((unsigned long)uvAddr, numPages, 0, 0, ppages, NULL);
+ #else
+ retval = get_user_pages(current, current->mm, (unsigned long)uvAddr,
+ numPages, 0, 0, ppages, NULL);
+ #endif
++#endif
+ up_read(&current->mm->mmap_sem);
+
+ return retval != numPages;
diff --git a/vmnet-12.5.2-4.9.patch b/vmnet-12.5.2-4.9.patch
new file mode 100644
index 000000000000..c1b9569f1fb0
--- /dev/null
+++ b/vmnet-12.5.2-4.9.patch
@@ -0,0 +1,21 @@
+diff --git vmnet-only/userif.c vmnet-only/userif.c
+index 2b976d7..f157f68 100644
+--- vmnet-only/userif.c
++++ vmnet-only/userif.c
+@@ -113,12 +113,16 @@ UserifLockPage(VA addr) // IN
+ int retval;
+
+ down_read(&current->mm->mmap_sem);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 9, 0)
++ retval = get_user_pages(addr, 1, 0, &page, NULL);
++#else
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
+ retval = get_user_pages(addr, 1, 1, 0, &page, NULL);
+ #else
+ retval = get_user_pages(current, current->mm, addr,
+ 1, 1, 0, &page, NULL);
+ #endif
++#endif
+ up_read(&current->mm->mmap_sem);
+
+ if (retval != 1) {