summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-08-26 20:14:20 +0300
committerDet2015-08-26 20:14:20 +0300
commitd27a3c4fce49afe7adab22509e178b3280981d0e (patch)
tree82654e3467d2645ca9db8a05f55135032258e7c1
parent2ef714c6ca3bb0147360540878cc65eb39129525 (diff)
downloadaur-d27a3c4fce49afe7adab22509e178b3280981d0e.tar.gz
Upgpkg: 12.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--[-rwxr-xr-x]common-functions.sh22
-rw-r--r--vmware-patch.sh54
4 files changed, 51 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15b58604f928..3760710b339a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-patch
- pkgdesc = A post-install configuration solution for VMware Workstation and Player (Plus and Pro)
- pkgver = 11.1.0
- pkgrel = 5
+ pkgdesc = A post-install configuration solution for VMware Workstation (Pro) and Player (Plus and Pro)
+ pkgver = 12.0.0
+ pkgrel = 1
url = https://wiki.archlinux.org/index.php/VMware#Configuration
install = vmware-patch.install
arch = i686
@@ -29,9 +29,9 @@ pkgbase = vmware-patch
source = vmnet-10.0.4-3.14.patch
source = vsock-10.0.4-3.14.patch
source = vmnet-10.0.1-3.13.patch
- md5sums = 2704cbc8b571d60e37ba3837638ccaef
+ md5sums = 5ead10eb9675f74d709586ce061e6f3a
md5sums = ba054b375308442d43a408dbae5e9401
- md5sums = e86bf4634661c8eb48823b4c69388bfc
+ md5sums = ca1382966804d694894539c7bcac6bbb
md5sums = c12e765985b324585a548718a6ac9b43
md5sums = ea3817fb7952932707bfedcf33a70697
md5sums = 56f7f642683e54250372bb57faaf4e95
diff --git a/PKGBUILD b/PKGBUILD
index 1025107257ef..701712207a11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributors: Igor Duarte Cardoso, haagch, Olivier Médoc
pkgname=vmware-patch
-pkgver=11.1.0
-pkgrel=5
-pkgdesc="A post-install configuration solution for VMware Workstation and Player (Plus and Pro)"
+pkgver=12.0.0
+pkgrel=1
+pkgdesc="A post-install configuration solution for VMware Workstation (Pro) and Player (Plus and Pro)"
arch=('i686' 'x86_64')
url="https://wiki.archlinux.org/index.php/VMware#Configuration"
license=('GPL')
@@ -49,9 +49,9 @@ package() {
}
# Generated using 'updpkgsums'
-md5sums=('2704cbc8b571d60e37ba3837638ccaef'
+md5sums=('5ead10eb9675f74d709586ce061e6f3a'
'ba054b375308442d43a408dbae5e9401'
- 'e86bf4634661c8eb48823b4c69388bfc'
+ 'ca1382966804d694894539c7bcac6bbb'
'c12e765985b324585a548718a6ac9b43'
'ea3817fb7952932707bfedcf33a70697'
'56f7f642683e54250372bb57faaf4e95'
diff --git a/common-functions.sh b/common-functions.sh
index 37d9102c3a23..81c05875e355 100755..100644
--- a/common-functions.sh
+++ b/common-functions.sh
@@ -72,9 +72,19 @@ vmware_check() {
set_product_name() {
ver=$(vmware-installer -l |& grep -Po "(player|workstation) *\K(\d+\.){2}\d+")
if vmware-installer -l |& grep -q "workstation"; then
- name="VMware Workstation"
+ if [[ $ver = 12.* ]]; then
+ name="VMware Workstation Pro"
+ else
+ name="VMware Workstation"
+ fi
else
- name="VMware Player (Plus)"
+ if [[ $ver = 12.* ]]; then
+ name="VMware Workstation Player"
+ elif [[ $ver = 7.* ]]; then
+ name="VMware Player (Pro)"
+ else
+ name="VMware Player (Plus)"
+ fi
fi
}
@@ -156,7 +166,13 @@ patch_sources() {
# Print vmware-modconfig-*.logs and exit
print_logs() {
- for log in /tmp/vmware-root/vmware-modconfig-*.log; do
+ if [[ $ver = 12.* ]]; then
+ logs=(/tmp/vmware-root/vmware-[0-9]*.log)
+ else
+ logs=(/tmp/vmware-root/vmware-modconfig*.log)
+ fi
+
+ for log in ${logs[@]}; do
error2 "$log"
done
exit 1
diff --git a/vmware-patch.sh b/vmware-patch.sh
index 2375cbc01318..8899fca7a51f 100644
--- a/vmware-patch.sh
+++ b/vmware-patch.sh
@@ -61,22 +61,17 @@ vmware_check
# Product name
set_product_name
-# Make sure vmware.service includes our USB Arbitrator service
-if ! grep -q "usbarbitrator" /usr/lib/systemd/system/vmware.service; then
- msg "Updating vmware.service.."
- sed '/Description/a Requires=vmware-usbarbitrator.service\nBefore=vmware-usbarbitrator.service' \
- -i /usr/lib/systemd/system/vmware.service
-fi
-
# Use VMware's bundled libcurl.so.4 to prevent crashes at startup/checking for updates
-for script in vmware vmplayer; do
- if [[ -f /usr/bin/$script ]]; then
- if ! grep -q "libcurl" /usr/bin/$script; then
- sed '/$vmmon/a\ export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libcurl.so.4' \
- -i /usr/bin/$script
+if [[ $ver != 12.* ]]; then
+ for script in vmware vmplayer; do
+ if [[ -f /usr/bin/$script ]]; then
+ if ! grep -q "libcurl" /usr/bin/$script; then
+ sed '/$vmmon/a\ export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libcurl.so.4' \
+ -i /usr/bin/$script
+ fi
fi
- fi
-done
+ done
+fi
# Make sure there's a version in /etc/arch-release for Workstation 9 / Player 5
# https://wiki.archlinux.org/index.php?title=VMware&oldid=274532#2.29_The_vmware-usbarbitrator_binary_is_segfaulting
@@ -88,19 +83,12 @@ if [[ $ver = 9.* ]] || [[ $ver = 5.* ]]; then
fi
# Fix VMCI/VSOCK loading for Workstation 10 / Player (Plus) 6 and earlier
-if [[ $ver != 11.* ]] && [[ $ver != 7.* ]]; then
+if [[ $ver != 12.* ]] && [[ $ver != 11.* ]] && [[ $ver != 7.* ]]; then
if grep -q '$vsock_alias' /etc/init.d/vmware; then
sed -e 's/mod=$(vmwareRealModName $vmci $vmci_alias)/mod=vmci/' \
-e 's/mod=$(vmwareRealModName $vsock $vsock_alias)/mod=vsock/' \
-i /etc/init.d/vmware
fi
-else
- if grep -q 'mod=vmci' /etc/init.d/vmware; then
- # Revert the tweak for Workstation 11 / Player (Pro) 7
- sed -e 's/mod=vmci/mod=$(vmwareRealModName $vmci $vmci_alias)/' \
- -e 's/mod=vsock/mod=$(vmwareRealModName $vsock $vsock_alias)/' \
- -i /etc/init.d/vmware
- fi
fi
# Remove leftover module locations
@@ -143,12 +131,14 @@ for kernel in ${kernels[@]}; do
exit 1
fi
- # Unload conflicting in-kernel modules in less than Workstation 11 / Player (Pro) 7
- if [[ $ver != 11.* ]] && [[ $ver != 7.* ]]; then
- rmmod "vsock" "vmw_vsock_vmci_transport" "vmw_vmci" 2>/dev/null || true
- else
- modprobe "vsock" "vmw_vsock_vmci_transport" "vmw_vmci" 2>/dev/null || true
- fi
+# # Unload conflicting in-kernel modules in less than Workstation 11 / Player (Pro) 7
+# if [[ $ver != 12.* ]] && [[ $ver != 11.* ]] && [[ $ver != 7.* ]]; then
+# rmmod "vsock" "vmw_vsock_vmci_transport" "vmw_vmci" 2>/dev/null || true
+# else
+# for mod in "vsock" "vmw_vsock_vmci_transport" "vmw_vmci"; do
+# modprobe $mod 2>/dev/null || true
+# done
+# fi
# Detect applicable patches (/usr/lib/vmware/modules/patches/[mod]-[ver]-[kernel].patch)
unset patches
@@ -158,9 +148,9 @@ for kernel in ${kernels[@]}; do
kernel_patch=$(echo $patch | grep -Po ".*-\K\d+\.\d+")
kernel_major=$(echo $kernel | cut -d "." -f-2)
- # Sync VMware Player (Plus) version by incrementing by 4
+ # Sync VMware Player (Pro / Plus) version by incrementing by 4
ver2=$ver
- if [[ $name =~ Player ]]; then
+ if [[ $name =~ Player ]] && [[ $ver != 12.* ]]; then
major=$(( ${ver/.*} + 4 ))
ver2=$major.${ver#*.}
fi
@@ -243,7 +233,7 @@ for kernel in ${kernels[@]}; do
# Run vmware-modconfig
if ! vmware-modconfig --console --install-all -k "$kernel"; then
# See logs
- if ls /tmp/vmware-root/vmware-modconfig-*.log &>/dev/null; then
+ if ls /tmp/vmware-root/vmware-[0-9]*.log &>/dev/null; then
error "Unable to build. See:"
print_logs
else
@@ -256,7 +246,7 @@ for kernel in ${kernels[@]}; do
# Run vmware-modconfig
if ! vmware-modconfig --console --install-all -k "$kernel" &>/dev/null; then
# See logs
- if ls /tmp/vmware-root/vmware-modconfig-*.log &>/dev/null; then
+ if ls /tmp/vmware-root/vmware-*.log &>/dev/null; then
error "Unable to build. Re-run with '-v' (--verbose) or see:"
print_logs
else