summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimPilotAdamT2022-05-29 13:59:45 +0100
committerSimPilotAdamT2022-05-29 13:59:45 +0100
commit9e40ee8d2bda2851f99051ff4d57eb62bf9e326c (patch)
tree13f4d536876cc8c01ac2dfd390f61c712fe984c0
parentf6f229209a47915caec5ac158924a4abd638cf69 (diff)
downloadaur-9e40ee8d2bda2851f99051ff4d57eb62bf9e326c.tar.gz
4.2.1-1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD25
3 files changed, 19 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e7ac97dfc7b..900941bd5de5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = vmware-unlocker
pkgdesc = VMware macOS utilities
- pkgver = 4.2.0
- pkgrel = 11
- url = https://github.com/DrDonk/unlocker
+ pkgver = 4.2.1
+ pkgrel = 1
+ url = https://github.com/SimPilotAdamT/unlocker
arch = x86_64
license = MIT
+ makedepends = git
+ makedepends = zsh
conflicts = vmware-unlocker-bin
- source = https://github.com/DrDonk/unlocker/releases/download/v4.2.0/unlocker420.zip
+ source = vmware-unlocker::git+https://github.com/SimPilotAdamT/unlocker#tag=v4.2.1
source = vmware-unlocker-post.hook
source = vmware-unlocker-pre.hook
- md5sums = 403f60e1a71debbfcbc6393f7184d3de
- md5sums = fdab28536a0508852c98fe48e05789ab
- md5sums = 35779837b2e8311db198fb80517fd2e8
- sha512sums = ead5851d50bf4e3a9e528d67b012c7b1a009e38f11d9ba1ce6e246a47dc7e305f8aed8e7ba0c094435f9070c5c82bd0192c3d834603aaa6b55268be78b2d4e2a
+ sha512sums = SKIP
sha512sums = 9562d829c593d45fd77eee19652b30ef3c33b0c67057b7e3fb4d39695d6b39659ddc06f64d0325ea02a400121a050e2bd0858a606e2a6627a40af8e87c8a378b
sha512sums = c95c021915665fbda50c4ce739b76d92c0616d102e05033aa5b4e0ebd933e61b775ffb6ef0cf65eaf392958b8bb4125932c3cf49dd705ebb6f43cc121eccb0b3
diff --git a/.gitignore b/.gitignore
index c238889ae6c7..4fae3be1d9b5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
.git
pkg
src
+vmware-unlocker
*.pkg.tar.zst
*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 007204886a9d..3e2abe5fde0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,31 @@
# Maintainer SimPilotAdamT <adam_tazul@outlook.com>
pkgname=vmware-unlocker
-pkgver=4.2.0
-pkgrel=11
+pkgver=4.2.1
+pkgrel=1
pkgdesc="VMware macOS utilities"
arch=('x86_64')
-url="https://github.com/DrDonk/unlocker"
+url="https://github.com/SimPilotAdamT/unlocker"
license=('MIT')
#depends=('vmware-workstation>=16.0.0')
-#makedepends=('git')
+makedepends=('git' "zsh")
conflicts=('vmware-unlocker-bin')
-source=("https://github.com/DrDonk/unlocker/releases/download/v$pkgver/unlocker420.zip" "vmware-unlocker-post.hook" "vmware-unlocker-pre.hook")
-md5sums=('403f60e1a71debbfcbc6393f7184d3de'
- 'fdab28536a0508852c98fe48e05789ab'
- '35779837b2e8311db198fb80517fd2e8'
-)
-sha512sums=('ead5851d50bf4e3a9e528d67b012c7b1a009e38f11d9ba1ce6e246a47dc7e305f8aed8e7ba0c094435f9070c5c82bd0192c3d834603aaa6b55268be78b2d4e2a'
+source=("$pkgname::git+https://github.com/SimPilotAdamT/unlocker#tag=v$pkgver" "vmware-unlocker-post.hook" "vmware-unlocker-pre.hook")
+sha512sums=('SKIP'
'9562d829c593d45fd77eee19652b30ef3c33b0c67057b7e3fb4d39695d6b39659ddc06f64d0325ea02a400121a050e2bd0858a606e2a6627a40af8e87c8a378b'
'c95c021915665fbda50c4ce739b76d92c0616d102e05033aa5b4e0ebd933e61b775ffb6ef0cf65eaf392958b8bb4125932c3cf49dd705ebb6f43cc121eccb0b3'
)
build() {
- printf ""
+ cd "$srcdir"/"$pkgname"/
+ zsh build.sh "$pkgver"
}
package() {
mkdir -p "$pkgdir"/usr/bin/iso/
mkdir -p "$pkgdir"/usr/backup/
mkdir -p "$pkgdir"/etc/pacman.d/hooks/
mkdir -p "$pkgdir"/usr/share/licenses/"$pkgname"/
- install -Dm755 "$srcdir"/linux/* "$pkgdir"/usr/bin/
- install -Dm644 "$srcdir"/iso/* "$pkgdir"/usr/bin/iso/
+ install -Dm755 "$srcdir"/"$pkgname"/dist/linux/* "$pkgdir"/usr/bin/
+ install -Dm644 "$srcdir"/"$pkgname"/dist/iso/* "$pkgdir"/usr/bin/iso/
install -Dm644 "$srcdir"/*.hook "$pkgdir"/etc/pacman.d/hooks/
- install -Dm644 "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ install -Dm644 "$srcdir"/"$pkgname"/dist/LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
}