summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2017-10-01 22:00:08 +0200
committerJean-Marc Lenoir2017-10-01 22:00:08 +0200
commit0330f7f6da40092ac3ea8e9b5ab7e139eb850da3 (patch)
treec1a1bdd205e337962a6f6aa639b2b0742de9fadc
parentd1f37e4d5bb90655e51c35147bf75f2e20397f51 (diff)
downloadaur-0330f7f6da40092ac3ea8e9b5ab7e139eb850da3.tar.gz
Fix a bug with some keyboard layouts using iBus
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--vmware-environment.sh6
-rw-r--r--vmware-profile.sh2
4 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64be24cbdb37..cdd80003e1a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 14.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -34,13 +34,13 @@ pkgbase = vmware-workstation
backup = etc/vmware/netmap.conf
backup = etc/vmware/ssl/hostd.ssl.config
backup = etc/pam.d/vmware-authd
- backup = etc/profile.d/vmware.sh
+ backup = etc/conf.d/vmware
source = https://download3.vmware.com/software/wkst/file/VMware-Workstation-Full-14.0.0-6661328.x86_64.bundle
source = bootstrap
source = config
source = pam.d-vmware-authd
source = configure-initscript.sh
- source = vmware-profile.sh
+ source = vmware-environment.sh
source = config.xml
source = datastores.xml
source = environments.xml
@@ -65,7 +65,7 @@ pkgbase = vmware-workstation
sha256sums = d9a5f8b919d52aa2f279d8eaf0bb495780eb9fd8bbc2c58bba223cdca78cc991
sha256sums = d50aa0a3fe94025178965d988e18d41eb60aa1ce2b28ee6e3ca15edeabfa2ca7
sha256sums = 8e4d08668a66be79a900521792b39c16a026cc90659241edee80b64e701bfbcd
- sha256sums = 6f57e027f0eb95b7cfaf5d7c10089e99be5b9ccab7c3785fcc6f98dbecaf47bc
+ sha256sums = ad2ceafa8a0b9b6e95b10a0650a776b8c0795f863267005751544083c84d31e3
sha256sums = 9f508d5f7ce4b69d9f40f6fb0ff0fb3d5b26a3c48658da994bf63975d1b589ab
sha256sums = 434cd4aa440d36b75ee20e0b588aaad874bb0d796173990bc4046667c66f5099
sha256sums = 57c7568a89e8af1914cf7aea84d8fefd6e7af4155557081292344326d652ae70
diff --git a/PKGBUILD b/PKGBUILD
index c6bde1885e77..27c069448547 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ pkgname=vmware-workstation
pkgver=14.0.0
_buildver=6661328
_pkgver=${pkgver}_${_buildver}
-pkgrel=1
+pkgrel=2
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -60,7 +60,7 @@ backup=(
'etc/vmware/netmap.conf'
'etc/vmware/ssl/hostd.ssl.config'
'etc/pam.d/vmware-authd'
- 'etc/profile.d/vmware.sh'
+ 'etc/conf.d/vmware'
)
source=(
"https://download3.vmware.com/software/wkst/file/VMware-Workstation-Full-${_pkgver/_/-}.${CARCH}.bundle"
@@ -69,7 +69,7 @@ source=(
'config'
'pam.d-vmware-authd'
'configure-initscript.sh'
- 'vmware-profile.sh'
+ 'vmware-environment.sh'
'config.xml'
'datastores.xml'
@@ -97,7 +97,7 @@ sha256sums=(
'd9a5f8b919d52aa2f279d8eaf0bb495780eb9fd8bbc2c58bba223cdca78cc991'
'd50aa0a3fe94025178965d988e18d41eb60aa1ce2b28ee6e3ca15edeabfa2ca7'
'8e4d08668a66be79a900521792b39c16a026cc90659241edee80b64e701bfbcd'
- '6f57e027f0eb95b7cfaf5d7c10089e99be5b9ccab7c3785fcc6f98dbecaf47bc'
+ 'ad2ceafa8a0b9b6e95b10a0650a776b8c0795f863267005751544083c84d31e3'
'9f508d5f7ce4b69d9f40f6fb0ff0fb3d5b26a3c48658da994bf63975d1b589ab'
'434cd4aa440d36b75ee20e0b588aaad874bb0d796173990bc4046667c66f5099'
@@ -419,7 +419,12 @@ fi
_create_database_file
- install -Dm 755 "$srcdir/vmware-profile.sh" "$pkgdir/etc/profile.d/vmware.sh"
+ # Define some environment variables for VMware
+ install -Dm 755 "$srcdir/vmware-environment.sh" "$pkgdir/etc/conf.d/vmware"
+ for program in vmware vmplayer vmware-netcfg vmware-tray; do
+ sed '/export PRODUCT_NAME/asource /etc/conf.d/vmware' \
+ -i "$pkgdir/usr/bin/$program"
+ done
# to solve bugs with incompatibles library versions:
#ln -sf /usr/lib/libz.so.1 "$pkgdir/usr/lib/vmware/lib/libz.so.1/"
diff --git a/vmware-environment.sh b/vmware-environment.sh
new file mode 100644
index 000000000000..decd55971e80
--- /dev/null
+++ b/vmware-environment.sh
@@ -0,0 +1,6 @@
+# Uncomment the line below if you have a problem of incompatible libraries
+#export VMWARE_USE_SHIPPED_LIBS=yes
+
+
+# Avoid an issue with some keyboard layouts using iBus
+export GTK_IM_MODULE_FILE=/dev/null
diff --git a/vmware-profile.sh b/vmware-profile.sh
deleted file mode 100644
index 19f8b62742f2..000000000000
--- a/vmware-profile.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-# Uncomment the line below and restart your session if you have a problem of incompatible libraries
-#export VMWARE_USE_SHIPPED_LIBS=yes