summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2018-02-03 12:20:11 +0100
committerJean-Marc Lenoir2018-02-03 12:20:11 +0100
commit9802c2f216f8d224b4a12681e3d9b7760ec939d0 (patch)
tree52a8344ff4285663df45411f971fae9986e284c6
parentd812eeabf7f3b05e27241c75699752d445bf2083 (diff)
downloadaur-9802c2f216f8d224b4a12681e3d9b7760ec939d0.tar.gz
Cleanup
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--vmmon.patch133
-rw-r--r--vmnet.patch85
4 files changed, 6 insertions, 224 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5e7ff1c1692..f5b7759f37b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation12
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 12.5.9
- pkgrel = 2
+ pkgrel = 3
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -82,8 +82,8 @@ pkgbase = vmware-workstation12
sha256sums = d7a9fbf39a0345ae2f14f7f389f30b1110f605d187e0c241e99bbb18993c250d
sha256sums = 05e26d8b21d190ebabb7f693998114d9d5991d9dfb71acb4d990293a65b6b487
sha256sums = 6ce902b1dab8fc69be253abd8e79017011985eca850ff7acc7282f9ab668e35d
- sha256sums = 88bfe2672d27a224d0ae990a09a2abac2897cec0fdbd905a75685cdceccae940
- sha256sums = 87cfa25d5689b04dd0126517887635992363b0ba05c1d64048415e9e3c7cfe7e
+ sha256sums = 345936611cfe4b49a1c55b33bec3c6761d8b693c87a0efd4c93b5a9eeaff83bf
+ sha256sums = 205093ff15603dcef230dd3399f7d4ee866104a73bffe25577470b2b08e924fd
sha256sums = 78aaa6ba65d178d6242ad73b7e2e552ec707798ce5f4925a0adebf30f844dc17
sha256sums = 6327a76c2503f56d8bc67279f289ed4bb53e236d965ad78c0fcf7ee9e2bbb6c6
sha256sums = b739b0c99fb20dc44838ce137e254773b7be051f327eb67fd8cb1342a3ecf344
diff --git a/PKGBUILD b/PKGBUILD
index b26a9c0e4695..887ca38f7010 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ pkgname=vmware-workstation12
pkgver=12.5.9
_buildver=7535481
_pkgver=${pkgver}_${_buildver}
-pkgrel=2
+pkgrel=3
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -114,8 +114,8 @@ sha256sums=(
'05e26d8b21d190ebabb7f693998114d9d5991d9dfb71acb4d990293a65b6b487'
'6ce902b1dab8fc69be253abd8e79017011985eca850ff7acc7282f9ab668e35d'
- '88bfe2672d27a224d0ae990a09a2abac2897cec0fdbd905a75685cdceccae940'
- '87cfa25d5689b04dd0126517887635992363b0ba05c1d64048415e9e3c7cfe7e'
+ '345936611cfe4b49a1c55b33bec3c6761d8b693c87a0efd4c93b5a9eeaff83bf'
+ '205093ff15603dcef230dd3399f7d4ee866104a73bffe25577470b2b08e924fd'
)
options=(!strip emptydirs)
diff --git a/vmmon.patch b/vmmon.patch
index ad18d2d85ba4..da85c851ec60 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -14,37 +14,6 @@ index de8162e..6124a71 100644
# Header directory for the running kernel
ifdef LINUXINCLUDE
-diff --git a/vmmon/Makefile.kernel b/vmmon/Makefile.kernel
-index bf805e0..9aac585 100644
---- a/vmmon/Makefile.kernel
-+++ b/vmmon/Makefile.kernel
-@@ -22,7 +22,7 @@ CC_OPTS += -DVMMON -DVMCORE
- INCLUDE := -I$(SRCROOT)/include -I$(SRCROOT)/common -I$(SRCROOT)/linux \
- -I$(SRCROOT)/vmcore
-
--EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE)
-+EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE) $(LINUXINCLUDE)
-
- EXTRA_CFLAGS += $(call vm_check_build, $(SRCROOT)/autoconf/smpcall.c, -DVMW_HAVE_SMP_CALL_3ARG, )
- EXTRA_CFLAGS += $(call vm_check_build, $(SRCROOT)/autoconf/tsc_khz.c, -DVMW_HAVE_TSC_KHZ, )
-diff --git a/vmmon/include/compat_module.h b/vmmon/include/compat_module.h
-index 2af7372..729aedc 100644
---- a/vmmon/include/compat_module.h
-+++ b/vmmon/include/compat_module.h
-@@ -80,4 +80,13 @@ static const char __module_cat(tag, __LINE__)[] \
- typedef int compat_mod_param_bool;
- #endif
-
-+/*
-+ * Linux kernel >= 4.3.0 does not return anything from misc_deregister
-+ */
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 3, 0)
-+#define compat_misc_deregister(misc) misc_deregister(misc)
-+#else
-+#define compat_misc_deregister(misc) ({misc_deregister(misc);0;})
-+#endif
-+
- #endif /* __COMPAT_MODULE_H__ */
diff --git a/vmmon/linux/driver.c b/vmmon/linux/driver.c
index 87cf45b..5390a93 100644
--- a/vmmon/linux/driver.c
@@ -58,24 +27,6 @@ index 87cf45b..5390a93 100644
static unsigned int LinuxDriverEstimateTSCkHz(void);
static struct vm_operations_struct vmuser_mops = {
-@@ -126,7 +126,16 @@ static struct vm_operations_struct vmuser_mops = {
- #endif
- };
-
--static struct file_operations vmuser_fops;
-+static struct file_operations vmuser_fops = {
-+ .owner = THIS_MODULE,
-+ .poll = LinuxDriverPoll,
-+ .unlocked_ioctl = LinuxDriver_Ioctl,
-+ .compat_ioctl = LinuxDriver_Ioctl,
-+ .open = LinuxDriver_Open,
-+ .release = LinuxDriver_Close,
-+ .mmap = LinuxDriverMmap
-+};
-+
- static struct timer_list tscTimer;
- static Atomic_uint32 tsckHz;
- static VmTimeStart tsckHzStartTime;
@@ -227,7 +228,7 @@ LinuxDriverEstimateTSCkHz(void)
*----------------------------------------------------------------------
*/
@@ -110,28 +61,6 @@ index 87cf45b..5390a93 100644
linuxState.fastClockThread = NULL;
linuxState.fastClockFile = NULL;
-@@ -319,21 +328,6 @@ init_module(void)
- linuxState.fastClockPriority = -20;
- linuxState.swapSize = VMMON_UNKNOWN_SWAP_SIZE;
-
-- /*
-- * Initialize the file_operations structure. Because this code is always
-- * compiled as a module, this is fine to do it here and not in a static
-- * initializer.
-- */
--
-- memset(&vmuser_fops, 0, sizeof vmuser_fops);
-- vmuser_fops.owner = THIS_MODULE;
-- vmuser_fops.poll = LinuxDriverPoll;
-- vmuser_fops.unlocked_ioctl = LinuxDriver_Ioctl;
-- vmuser_fops.compat_ioctl = LinuxDriver_Ioctl;
-- vmuser_fops.open = LinuxDriver_Open;
-- vmuser_fops.release = LinuxDriver_Close;
-- vmuser_fops.mmap = LinuxDriverMmap;
--
- #ifdef VMX86_DEVEL
- devel_init_module();
- linuxState.minor = 0;
@@ -360,7 +357,13 @@ init_module(void)
linuxState.deviceName, linuxState.major, linuxState.minor);
@@ -146,17 +75,6 @@ index 87cf45b..5390a93 100644
LinuxDriverInitTSCkHz();
Vmx86_InitIDList();
-@@ -389,7 +383,9 @@ cleanup_module(void)
- #ifdef VMX86_DEVEL
- unregister_chrdev(linuxState.major, linuxState.deviceName);
- #else
-- misc_deregister(&linuxState.misc);
-+ if (compat_misc_deregister(&linuxState.misc)) {
-+ Warning("Module %s: error unregistering\n", linuxState.deviceName);
-+ }
- #endif
-
- Log("Module %s: unloaded\n", linuxState.deviceName);
@@ -858,7 +858,7 @@
*/
@@ -166,48 +84,10 @@ index 87cf45b..5390a93 100644
{
LinuxDriverWakeUp(FALSE);
}
-@@ -1287,7 +1283,7 @@ LinuxDriverReadTSC(void *data, // OUT: TSC values
- *-----------------------------------------------------------------------------
- */
-
--__attribute__((always_inline)) static Bool
-+inline __attribute__((always_inline)) static Bool
- LinuxDriverSyncReadTSCs(uint64 *delta) // OUT: TSC max - TSC min
- {
- TSCDelta tscDelta;
diff --git a/vmmon/linux/hostif.c b/vmmon/linux/hostif.c
index fd32013..583d6da 100644
--- a/vmmon/linux/hostif.c
+++ b/vmmon/linux/hostif.c
-@@ -37,6 +37,9 @@
-
- #include <linux/vmalloc.h>
- #include <linux/slab.h>
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
-+#include <linux/sched/signal.h>
-+#endif
-
- #include <linux/preempt.h>
- #include <linux/poll.h>
-@@ -73,6 +76,7 @@
- #include <linux/capability.h>
- #include <linux/kthread.h>
- #include <linux/wait.h>
-+#include <asm/apic.h>
- #include <linux/signal.h>
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
- #include <linux/taskstats_kern.h> // For linux/sched/signal.h without version check
-@@ -142,6 +146,10 @@
- */
- #define LOCKED_PAGE_SLACK 10000
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
-+#define NR_ANON_PAGES NR_ANON_MAPPED
-+#endif
-+
- static struct {
- Atomic_uint64 uptimeBase;
- VersionedAtomic version;
@@ -1164,16 +1172,7 @@
{
int retval;
@@ -303,16 +183,3 @@ index fd32013..583d6da 100644
mod_timer(&uptimeState.timer, jiffies + HZ);
}
-diff --git a/vmmon/linux/vmmonInt.h b/vmmon/linux/vmmonInt.h
-index 4dc04e9..993212d 100644
---- a/vmmon/linux/vmmonInt.h
-+++ b/vmmon/linux/vmmonInt.h
-@@ -28,7 +28,7 @@
- * Hide all kernel compatibility stuff in these macros and functions.
- */
-
--#ifdef VMW_HAVE_SMP_CALL_3ARG
-+#if defined (VMW_HAVE_SMP_CALL_3ARG) || LINUX_VERSION_CODE >= KERNEL_VERSION(3, 0, 0)
- #define compat_smp_call_function(fn, info, wait) smp_call_function(fn, info, wait)
- #else
- #define compat_smp_call_function(fn, info, wait) smp_call_function(fn, info, 1, wait)
diff --git a/vmnet.patch b/vmnet.patch
index 77dd589dfde9..0d17e79a59f9 100644
--- a/vmnet.patch
+++ b/vmnet.patch
@@ -14,19 +14,6 @@ index 459846e..cd29652 100644
# Header directory for the running kernel
ifdef LINUXINCLUDE
-diff --git a/vmnet/Makefile.kernel b/vmnet/Makefile.kernel
-index 2d8e6f6..a14166b 100644
---- a/vmnet/Makefile.kernel
-+++ b/vmnet/Makefile.kernel
-@@ -19,7 +19,7 @@
-
- INCLUDE := -I$(SRCROOT)
-
--EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE)
-+EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE) $(LINUXINCLUDE)
- EXTRA_CFLAGS += $(call vm_check_build, $(SRCROOT)/netdev_has_net.c,-DVMW_NETDEV_HAS_NET, )
- EXTRA_CFLAGS += $(call vm_check_build, $(SRCROOT)/netdev_has_dev_net.c,-DVMW_NETDEV_HAS_DEV_NET, )
- EXTRA_CFLAGS += $(call vm_check_build, $(SRCROOT)/nfhook_uses_skb.c,-DVMW_NFHOOK_USES_SKB, )
diff --git a/vmnet/bridge.c b/vmnet/bridge.c
--- a/vmnet/bridge.c
+++ b/vmnet/bridge.c
@@ -39,51 +26,6 @@ diff --git a/vmnet/bridge.c b/vmnet/bridge.c
clone->dev = dev;
clone->protocol = eth_type_trans(clone, dev);
-diff --git a/vmnet/driver.c b/vmnet/driver.c
-index 7e7ad99..5f508f6 100644
---- a/vmnet/driver.c
-+++ b/vmnet/driver.c
-@@ -137,7 +137,16 @@ static ssize_t VNetFileOpWrite(struct file *filp, const char *buf, size_t count
- static long VNetFileOpUnlockedIoctl(struct file * filp,
- unsigned int iocmd, unsigned long ioarg);
-
--static struct file_operations vnetFileOps;
-+static struct file_operations vnetFileOps = {
-+ .owner = THIS_MODULE,
-+ .read = VNetFileOpRead,
-+ .write = VNetFileOpWrite,
-+ .poll = VNetFileOpPoll,
-+ .unlocked_ioctl = VNetFileOpUnlockedIoctl,
-+ .compat_ioctl = VNetFileOpUnlockedIoctl,
-+ .open = VNetFileOpOpen,
-+ .release = VNetFileOpClose
-+};
-
- /*
- * Utility functions
-@@ -317,22 +326,6 @@ init_module(void)
- goto err_proto;
- }
-
-- /*
-- * Initialize the file_operations structure. Because this code is always
-- * compiled as a module, this is fine to do it here and not in a static
-- * initializer.
-- */
--
-- memset(&vnetFileOps, 0, sizeof vnetFileOps);
-- vnetFileOps.owner = THIS_MODULE;
-- vnetFileOps.read = VNetFileOpRead;
-- vnetFileOps.write = VNetFileOpWrite;
-- vnetFileOps.poll = VNetFileOpPoll;
-- vnetFileOps.unlocked_ioctl = VNetFileOpUnlockedIoctl;
-- vnetFileOps.compat_ioctl = VNetFileOpUnlockedIoctl;
-- vnetFileOps.open = VNetFileOpOpen;
-- vnetFileOps.release = VNetFileOpClose;
--
- retval = register_chrdev(VNET_MAJOR_NUMBER, "vmnet", &vnetFileOps);
- if (retval) {
- LOG(0, (KERN_NOTICE "/dev/vmnet: could not register major device %d\n",
diff --git a/vmnet/userif.c b/vmnet/userif.c
index 94146f6..5298406 100644
--- a/vmnet/userif.c
@@ -106,30 +48,3 @@ index 94146f6..5298406 100644
if (retval != 1) {
return NULL;
-diff --git a/vmnet/vm_device_version.h b/vmnet/vm_device_version.h
-index e2cb477..3dd7097 100644
---- a/vmnet/vm_device_version.h
-+++ b/vmnet/vm_device_version.h
-@@ -53,7 +53,9 @@
- * VMware HD Audio codec
- * VMware HD Audio controller
- */
-+#ifndef PCI_VENDOR_ID_VMWARE
- #define PCI_VENDOR_ID_VMWARE 0x15AD
-+#endif
- #define PCI_DEVICE_ID_VMWARE_SVGA2 0x0405
- #define PCI_DEVICE_ID_VMWARE_SVGA 0x0710
- #define PCI_DEVICE_ID_VMWARE_VGA 0x0711
-diff --git a/vmnet/vmnetInt.h b/vmnet/vmnetInt.h
-index 0ee52ec..4e3b923 100644
---- a/vmnet/vmnetInt.h
-+++ b/vmnet/vmnetInt.h
-@@ -79,7 +79,7 @@
- extern struct proto vmnet_proto;
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 2, 0) || defined(sk_net_refcnt)
- # define compat_sk_alloc(_bri, _pri) sk_alloc(&init_net, \
-- PF_NETLINK, _pri, &vmnet_proto, 1)
-+ PF_NETLINK, _pri, &vmnet_proto, 0)
- #elif defined(VMW_NETDEV_HAS_NET)
- # define compat_sk_alloc(_bri, _pri) sk_alloc(&init_net, \
- PF_NETLINK, _pri, &vmnet_proto)