summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2022-01-05 11:11:02 +0100
committerJean-Marc Lenoir2022-01-05 11:11:02 +0100
commit040e9b73aa04403ee2ed155317611f9ae9a83eae (patch)
tree6ff28cd80deec182d49f75e7e9aeb91387405a79
parentfbb5a65eeb5fa33b98b9e26b6d4180e29b8905c2 (diff)
downloadaur-040e9b73aa04403ee2ed155317611f9ae9a83eae.tar.gz
Compatibility with Linux 5.16-rc8
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--vmmon.patch30
-rw-r--r--vmnet.patch41
4 files changed, 78 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 936a2ad4adc9..1fd9ab49ebea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation15
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 15.5.7
- pkgrel = 5
+ pkgrel = 6
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -84,7 +84,7 @@ pkgbase = vmware-workstation15
sha256sums = fe1b1be8297f4170406f97dd1f8b385d911faf45afe19cbc0c26b8092b3ddf8d
sha256sums = 10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e
sha256sums = 273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac
- sha256sums = 5f90e47b151017d9a101c918380ee7175c71fe6c50adf5fdd9a9f050ba4257f6
- sha256sums = 361a3abf195098a90cbf2a4ce16dbcfcfc224c78284269b6d980972bc3647796
+ sha256sums = ee126feeb07e36b8ba43135fbbb81d20d0bc0d30e4e00f153ecc5aa87cfcf786
+ sha256sums = eb0fcc4b08d304e5a86a5aa3dac191dc7657a6fe7e8f7cc7e481310bcd264a1e
pkgname = vmware-workstation15
diff --git a/PKGBUILD b/PKGBUILD
index 720f13d7141d..ea8cdafb650d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ pkgname=vmware-workstation15
pkgver=15.5.7
_buildver=17171714
_pkgver=${pkgver}_${_buildver}
-pkgrel=5
+pkgrel=6
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -121,8 +121,8 @@ sha256sums=(
'10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e'
'273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac'
- '5f90e47b151017d9a101c918380ee7175c71fe6c50adf5fdd9a9f050ba4257f6'
- '361a3abf195098a90cbf2a4ce16dbcfcfc224c78284269b6d980972bc3647796'
+ 'ee126feeb07e36b8ba43135fbbb81d20d0bc0d30e4e00f153ecc5aa87cfcf786'
+ 'eb0fcc4b08d304e5a86a5aa3dac191dc7657a6fe7e8f7cc7e481310bcd264a1e'
)
options=(!strip emptydirs)
@@ -141,7 +141,7 @@ if [ -n "$_enable_macOS_guests" ]; then
_vmware_fusion_ver=11.5.7_17130923
# List of VMware Fusion versions: https://softwareupdate.vmware.com/cds/vmw-desktop/fusion/
-_unlocker_ver=3.0.6
+_unlocker_ver=3.0.7
makedepends+=(
python
diff --git a/vmmon.patch b/vmmon.patch
index 6b496decf875..27e8fb449b08 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -280,3 +280,33 @@
/*
* Do not exit thread until we are told to do so.
*/
+From 4232f780eb114f22498f3274eaeef81d8c63f2ab Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Tue, 9 Nov 2021 09:01:57 +0100
+Subject: [PATCH] modules: fix stddef.h include
+
+After mainline commit 04e85bbf71c9 ("isystem: delete global -isystem
+compile option") in 5.16-rc1, vm_basic_types.h in both vmmon and vmnet
+does not find (userspace) stddef.h any more. As it should not include this
+header anyway, fix the include directives to include stddef.h from kernel.
+
+Kernel version of stddef.h has been available since the beginning of git so
+that it is safe to include it regardless of kernel version.
+---
+ vmmon-only/include/vm_basic_defs.h | 2 +-
+ vmnet-only/vm_basic_defs.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/vmmon-only/include/vm_basic_defs.h b/vmmon-only/include/vm_basic_defs.h
+index 0ec30b3..b920e2d 100644
+--- a/vmmon-only/include/vm_basic_defs.h
++++ b/vmmon-only/include/vm_basic_defs.h
+@@ -51,7 +51,7 @@
+ * C90 7.17, C99 7.19, C11 7.19
+ */
+ #if !defined(VMKERNEL)
+-# include <stddef.h>
++# include <linux/stddef.h>
+ #else
+ /*
+ * Vmkernel's bogus __FreeBSD__ value causes gcc <stddef.h> to break.
diff --git a/vmnet.patch b/vmnet.patch
index daa16401676f..cb1d33b7af56 100644
--- a/vmnet.patch
+++ b/vmnet.patch
@@ -50,3 +50,44 @@
kunmap(skb_frag_page(frag));
if (err) {
+# Fixing VMWare Player on Linux when using DHCP addresses: https://www.nikhef.nl/~janjust/vmnet/
+@@ -985,6 +996,9 @@
+ userIf = (VNetUserIF *)port->jack.private;
+ hubJack = port->jack.peer;
+
++ /* never send link down events */
++ if (!linkUp) return 0;
++
+ if (port->jack.state == FALSE || hubJack == NULL) {
+ return -EINVAL;
+ }
+From 4232f780eb114f22498f3274eaeef81d8c63f2ab Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Tue, 9 Nov 2021 09:01:57 +0100
+Subject: [PATCH] modules: fix stddef.h include
+
+After mainline commit 04e85bbf71c9 ("isystem: delete global -isystem
+compile option") in 5.16-rc1, vm_basic_types.h in both vmmon and vmnet
+does not find (userspace) stddef.h any more. As it should not include this
+header anyway, fix the include directives to include stddef.h from kernel.
+
+Kernel version of stddef.h has been available since the beginning of git so
+that it is safe to include it regardless of kernel version.
+---
+ vmmon-only/include/vm_basic_defs.h | 2 +-
+ vmnet-only/vm_basic_defs.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/vmnet-only/vm_basic_defs.h b/vmnet-only/vm_basic_defs.h
+index 0ec30b3..b920e2d 100644
+--- a/vmnet-only/vm_basic_defs.h
++++ b/vmnet-only/vm_basic_defs.h
+@@ -51,7 +51,7 @@
+ * C90 7.17, C99 7.19, C11 7.19
+ */
+ #if !defined(VMKERNEL)
+-# include <stddef.h>
++# include <linux/stddef.h>
+ #else
+ /*
+ * Vmkernel's bogus __FreeBSD__ value causes gcc <stddef.h> to break.