summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2023-10-21 15:47:17 +0200
committerJean-Marc Lenoir2023-10-21 15:47:17 +0200
commit22b92ff558f4b59fcb4a5c86fa9fb0120a615d21 (patch)
treee9dcb2a751ab8cfd5b6659e31f20094b66840da7
parent63f28a5a80764053ff4ccf13cc011c979bd6c08f (diff)
downloadaur-22b92ff558f4b59fcb4a5c86fa9fb0120a615d21.tar.gz
Sync with vmware-workstation 17.5.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--vmmon.patch26
-rw-r--r--vmnet.patch133
4 files changed, 75 insertions, 98 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25e29b08d21e..68cd6e519fc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation15
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 15.5.7
- pkgrel = 15
+ pkgrel = 16
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -86,7 +86,7 @@ pkgbase = vmware-workstation15
sha256sums = fe1b1be8297f4170406f97dd1f8b385d911faf45afe19cbc0c26b8092b3ddf8d
sha256sums = 10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e
sha256sums = 273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac
- sha256sums = 359955799da07c7b2d12405daf1b1fd63385504e2ae58f53a755631de629396b
- sha256sums = ad95610e6516e6d82b6b636371911abaca123e72e35e2712c5e5a2d59920c9f4
+ sha256sums = 20d1c1f254b2edf57b4c03620a3a1b424cf9976485ba665885efafd72c0ba695
+ sha256sums = 41729b3b4a827fad2ec624b0f5fbbfbfbf6512df7ef0f7103598e15bfd5b26e1
pkgname = vmware-workstation15
diff --git a/PKGBUILD b/PKGBUILD
index 6620d965e595..f1674f3a5048 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ pkgname=vmware-workstation15
pkgver=15.5.7
_buildver=17171714
_pkgver=${pkgver}_${_buildver}
-pkgrel=15
+pkgrel=16
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -123,8 +123,8 @@ sha256sums=(
'10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e'
'273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac'
- '359955799da07c7b2d12405daf1b1fd63385504e2ae58f53a755631de629396b'
- 'ad95610e6516e6d82b6b636371911abaca123e72e35e2712c5e5a2d59920c9f4'
+ '20d1c1f254b2edf57b4c03620a3a1b424cf9976485ba665885efafd72c0ba695'
+ '41729b3b4a827fad2ec624b0f5fbbfbfbf6512df7ef0f7103598e15bfd5b26e1'
)
options=(!strip emptydirs)
@@ -463,7 +463,7 @@ if [ -n "$_enable_macOS_guests" ]; then
done
msg "Patching EFI firmwares to disable macOS server checking"
- _efi_arch=(32 64)
+ _efi_arch=("32" "64")
for arch in ${_efi_arch[@]}
do
uefipatch "$pkgdir/usr/lib/vmware/roms/EFI${arch}.ROM" "$srcdir/efi-patches.txt" -o "$pkgdir/usr/lib/vmware/roms/EFI${arch}.ROM" > /dev/null
diff --git a/vmmon.patch b/vmmon.patch
index 33efbf177acb..c2f4b36d9ffb 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -20,6 +20,20 @@
include $(SRCROOT)/Makefile.kernel
+--- a/vmmon/include/pgtbl.h
++++ b/vmmon/include/pgtbl.h
+@@ -91,7 +91,11 @@
+ } else {
+ pte_t *pte;
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6,5,0)
++ pte = pte_offset_kernel(pmd, addr);
++#else
+ pte = pte_offset_map(pmd, addr);
++#endif
+ if (pte_present(*pte) == 0) {
+ pte_unmap(pte);
+ return INVALID_MPN;
--- a/vmmon/include/vm_basic_defs.h
+++ b/vmmon/include/vm_basic_defs.h
@@ -50,7 +50,10 @@
@@ -298,15 +312,3 @@
/*
* Do not exit thread until we are told to do so.
*/
-Patch taken from https://raw.githubusercontent.com/jeffersonchua/linux-6.5.0/main/patch-17.0.2-6.5.0
---- a/vmmon/include/pgtbl.h
-+++ b/vmmon/include/pgtbl.h
-@@ -91,7 +91,7 @@
- } else {
- pte_t *pte;
-
-- pte = pte_offset_map(pmd, addr);
-+ pte = pte_offset_kernel(pmd, addr);
- if (pte_present(*pte) == 0) {
- pte_unmap(pte);
- return INVALID_MPN;
diff --git a/vmnet.patch b/vmnet.patch
index 702f6f1d7386..6978f8d8a856 100644
--- a/vmnet.patch
+++ b/vmnet.patch
@@ -22,6 +22,16 @@
--- a/vmnet/bridge.c
+++ b/vmnet/bridge.c
+@@ -26,6 +26,9 @@
+ #include <linux/slab.h>
+ #include <linux/poll.h>
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 4, 10)
++#include <net/gso.h>
++#endif
+ #include <linux/netdevice.h>
+ #include <linux/etherdevice.h>
+ #include <linux/mm.h>
@@ -684,14 +684,11 @@
}
spin_unlock_irqrestore(&bridge->historyLock, flags);
@@ -42,6 +52,50 @@
# if LOGLEVEL >= 4
do_gettimeofday(&vnetTime);
# endif
+--- a/vmnet/driver.c
++++ b/vmnet/driver.c
+@@ -279,7 +279,7 @@ VNetRemovePortFromList(const VNetPort *port) // IN: port to remove from list
+ /*
+ *----------------------------------------------------------------------
+ *
+- * init_module --
++ * LinuxDriverInit --
+ *
+ * linux module entry point. Called by /sbin/insmod command.
+ * Initializes module and Registers this driver for a
+@@ -296,7 +296,7 @@ VNetRemovePortFromList(const VNetPort *port) // IN: port to remove from list
+ */
+
+ int
+-init_module(void)
++LinuxDriverInit(void)
+ {
+ int retval;
+
+@@ -358,7 +358,7 @@ init_module(void)
+ /*
+ *----------------------------------------------------------------------
+ *
+- * cleanup_module --
++ * LinuxDriverExit --
+ *
+ * Called by /sbin/rmmod. Unregisters this driver for a
+ * vnet major #, and deinitializes the modules. The 64-bit
+@@ -375,7 +375,7 @@ init_module(void)
+ */
+
+ void
+-cleanup_module(void)
++LinuxDriverExit(void)
+ {
+ unregister_chrdev(VNET_MAJOR_NUMBER, "vmnet");
+ VNetProtoUnregister();
+@@ -1701,3 +1701,5 @@ MODULE_LICENSE("GPL v2");
+ * by default (i.e., neither mkinitrd nor modprobe will accept it).
+ */
+ MODULE_INFO(supported, "external");
++module_init(LinuxDriverInit);
++module_exit(LinuxDriverExit);
--- a/vmnet/netif.c
+++ b/vmnet/netif.c
@@ -253,7 +253,11 @@
@@ -300,82 +354,3 @@ Fixing VMWare Player on Linux when using DHCP addresses: https://www.nikhef.nl/~
if (count < n) {
n = count;
}
-From 0ca979d4bd06144204d720bb82f0a1e29024f9fa Mon Sep 17 00:00:00 2001
-From: Michal Kubecek <mkubecek@suse.cz>
-Date: Wed, 18 Jan 2023 00:19:52 +0100
-Subject: [PATCH] vmnet: use explicit module_init() and module_exit() (#187)
-
-While vmmon module already uses explicit module_init() and module_exit()
-for its init and cleanup function, vmnet relies on traditional magic names
-init_module() and cleanup_module(). Apparently this has an unfortunate side
-effect that the two functions are not identified as indirect call targets
-by objdump and they get "sealed" when the module is built against and
-loaded into an IBT enabled kernel.
-
-Starting with 6.3-rc1, objtool is going to warn about this issue,
-indicating that the legacy module initialization is deprecated and
-module_init() and module_exit() macros should be used instead so do that
-for vmnet as well.
----
- vmnet-only/driver.c | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/vmnet-only/driver.c b/vmnet-only/driver.c
-index 197a213..b22cbfb 100644
---- a/vmnet-only/driver.c
-+++ b/vmnet-only/driver.c
-@@ -279,7 +279,7 @@ VNetRemovePortFromList(const VNetPort *port) // IN: port to remove from list
- /*
- *----------------------------------------------------------------------
- *
-- * init_module --
-+ * vmnet_init_module --
- *
- * linux module entry point. Called by /sbin/insmod command.
- * Initializes module and Registers this driver for a
-@@ -296,7 +296,7 @@ VNetRemovePortFromList(const VNetPort *port) // IN: port to remove from list
- */
-
- int
--init_module(void)
-+vmnet_init_module(void)
- {
- int retval;
-
-@@ -358,7 +358,7 @@ init_module(void)
- /*
- *----------------------------------------------------------------------
- *
-- * cleanup_module --
-+ * vmnet_cleanup_module --
- *
- * Called by /sbin/rmmod. Unregisters this driver for a
- * vnet major #, and deinitializes the modules. The 64-bit
-@@ -375,7 +375,7 @@ init_module(void)
- */
-
- void
--cleanup_module(void)
-+vmnet_cleanup_module(void)
- {
- unregister_chrdev(VNET_MAJOR_NUMBER, "vmnet");
- VNetProtoUnregister();
-@@ -1701,3 +1701,5 @@ MODULE_LICENSE("GPL v2");
- * by default (i.e., neither mkinitrd nor modprobe will accept it).
- */
- MODULE_INFO(supported, "external");
-+module_init(vmnet_init_module);
-+module_exit(vmnet_cleanup_module);
-Patch inspired from https://github.com/mkubecek/vmware-host-modules/commit/b75cd616cca0a4c9ff22124c4c91d218e64e6205.patch
---- a/vmnet/bridge.c
-+++ b/vmnet/bridge.c
-@@ -44,6 +44,9 @@
- #include <linux/if_arp.h>
- #include <net/tcp.h>
- #include <net/ipv6.h>
-+#if !defined(SKB_GSO_CB)
-+#include <net/gso.h>
-+#endif
-
- #ifdef CONFIG_NET_RADIO
- # include <linux/wireless.h>