summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2021-08-01 10:25:51 +0200
committerJean-Marc Lenoir2021-08-01 10:25:51 +0200
commit6434678fc59a9f41eeec76fe2e0b16b84c3c0c26 (patch)
tree3867a597f4c3da16e9a6807899c5e0375046acf5
parent40bd04cf9a5d029d78cb2d2d21b635641224bb94 (diff)
downloadaur-6434678fc59a9f41eeec76fe2e0b16b84c3c0c26.tar.gz
Compatibility with Linux 5.14-rc1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
-rw-r--r--vmmon.patch96
3 files changed, 100 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5ce71abe683..4c3235ec4192 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation15
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 15.5.7
- pkgrel = 3
+ pkgrel = 4
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -80,8 +80,7 @@ pkgbase = vmware-workstation15
sha256sums = d7a9fbf39a0345ae2f14f7f389f30b1110f605d187e0c241e99bbb18993c250d
sha256sums = 10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e
sha256sums = 273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac
- sha256sums = 904518b48c039611c26bf97a15784f87fcff252ce0858b6af88bbf102f9fe5be
+ sha256sums = c6192797745e19e6361e005adb98383f8877f0118e1db5c018c67cc88c7cb6e1
sha256sums = 361a3abf195098a90cbf2a4ce16dbcfcfc224c78284269b6d980972bc3647796
pkgname = vmware-workstation15
-
diff --git a/PKGBUILD b/PKGBUILD
index dab3b90a4b91..329e6c351d1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ pkgname=vmware-workstation15
pkgver=15.5.7
_buildver=17171714
_pkgver=${pkgver}_${_buildver}
-pkgrel=3
+pkgrel=4
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -117,7 +117,7 @@ sha256sums=(
'10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e'
'273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac'
- '904518b48c039611c26bf97a15784f87fcff252ce0858b6af88bbf102f9fe5be'
+ 'c6192797745e19e6361e005adb98383f8877f0118e1db5c018c67cc88c7cb6e1'
'361a3abf195098a90cbf2a4ce16dbcfcfc224c78284269b6d980972bc3647796'
)
options=(!strip emptydirs)
diff --git a/vmmon.patch b/vmmon.patch
index b8793376c863..19ba25431813 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -233,3 +233,99 @@
/*
* Do not exit thread until we are told to do so.
*/
+From 9fda02bce13527ce94a95df1a98fb6188dea22b8 Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Wed, 30 Jun 2021 11:05:16 +0200
+Subject: [PATCH] vmmon: fix task_struct::state access patterns
+
+Mainline commit 2f064a59a11f ("sched: Change task_struct::state") in
+5.14-rc1 finishes a series fixing racy access patterns to task state and
+renames task_struct::state to __state so that code old code acessing it
+directly fails to build.
+
+Two of these in HostIF_SemaphoreWait() can be rewritten into calls to
+set_current_state() unconditionally (second one may do with
+__set_current_state() but I don't feel confident enough about that).
+There are also two places where vmmon code reads task_struct::state;
+provide a compat accessor using READ_ONCE() and use it instead of
+a direct read. To avoid kernel version check, check presence of
+get_current_state() macro introduced in the same commit as state member
+rename.
+---
+ vmmon-only/include/compat_sched.h | 15 +++++++++++++++
+ vmmon-only/linux/hostif.c | 10 ++++++----
+ 2 files changed, 21 insertions(+), 4 deletions(-)
+
+diff --git a/vmmon-only/include/compat_sched.h b/vmmon-only/include/compat_sched.h
+index 3f3304b..72078e0 100644
+--- a/vmmon-only/include/compat_sched.h
++++ b/vmmon-only/include/compat_sched.h
+@@ -289,5 +289,20 @@ typedef struct pid * compat_pid;
+ #define compat_kill_pid(pid, sig, flag) kill_pid(pid, sig, flag)
+ #endif
+
++/*
++ * Since v5.14-rc1, task_struct::state hase been renamed to __state and is
++ * is longer supposed to be accessed without READ_ONCE/WRITE_ONCE.
++ */
++#ifdef get_current_state
++static inline int compat_get_task_state(const struct task_struct *t)
++{
++ return READ_ONCE(t->__state);
++}
++#else
++static inline int compat_get_task_state(const struct task_struct *t)
++{
++ return READ_ONCE(t->state);
++}
++#endif
+
+ #endif /* __COMPAT_SCHED_H__ */
+diff --git a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
+index 137062c..6910f69 100644
+--- a/vmmon-only/linux/hostif.c
++++ b/vmmon-only/linux/hostif.c
+@@ -79,6 +79,8 @@
+ #include "pgtbl.h"
+ #include "versioned_atomic.h"
+
++#include "compat_sched.h"
++
+ #if !defined(CONFIG_HIGH_RES_TIMERS)
+ #error CONFIG_HIGH_RES_TIMERS required for acceptable performance
+ #endif
+@@ -466,7 +468,7 @@ HostIF_WakeUpYielders(VMDriver *vm, // IN:
+ ASSERT(vcpuid < vm->numVCPUs);
+ t = vm->vmhost->vcpuSemaTask[vcpuid];
+ VCPUSet_Remove(&req, vcpuid);
+- if (t && (t->state & TASK_INTERRUPTIBLE)) {
++ if (t && (compat_get_task_state(t) & TASK_INTERRUPTIBLE)) {
+ wake_up_process(t);
+ }
+ }
+@@ -2613,14 +2615,14 @@ HostIF_SemaphoreWait(VMDriver *vm, // IN:
+ unsigned int mask;
+
+ poll_initwait(&table);
+- current->state = TASK_INTERRUPTIBLE;
++ set_current_state(TASK_INTERRUPTIBLE);
+ mask = file->f_op->poll(file, &table.pt);
+ if (!(mask & (POLLIN | POLLERR | POLLHUP))) {
+ vm->vmhost->vcpuSemaTask[vcpuid] = current;
+ schedule_timeout(timeoutms * HZ / 1000); // convert to Hz
+ vm->vmhost->vcpuSemaTask[vcpuid] = NULL;
+ }
+- current->state = TASK_RUNNING;
++ set_current_state(TASK_RUNNING);
+ poll_freewait(&table);
+ }
+
+@@ -2698,7 +2700,7 @@ HostIF_SemaphoreForceWakeup(VMDriver *vm, // IN:
+ */
+ struct task_struct *t =
+ (struct task_struct *)xchg(&vm->vmhost->vcpuSemaTask[vcpuid], NULL);
+- if (t && (t->state & TASK_INTERRUPTIBLE)) {
++ if (t && (compat_get_task_state(t) & TASK_INTERRUPTIBLE)) {
+ wake_up_process(t);
+ }
+ } ROF_EACH_VCPU_IN_SET_WITH_MAX();