summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVivien Maisonneuve2015-10-06 04:13:44 +0200
committerVivien Maisonneuve2015-10-06 04:13:44 +0200
commit6a1960346bafd53be3ef9fe2ebadcfeccb568e76 (patch)
tree9046f59503227eb7346127721aac4810becea94e
downloadaur-6a1960346bafd53be3ef9fe2ebadcfeccb568e76.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD24
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b954f03949ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vncdotool-git
+ pkgdesc = A command line VNC client
+ pkgver = 0.8.0.r48.g664c318
+ pkgrel = 1
+ url = https://github.com/sibson/vncdotool
+ arch = any
+ license = custom
+ depends = python2-pillow
+ depends = python2-twisted
+ depends = python2-wsgiref
+ depends = python2-zope-interface
+ provides = vncdotool
+ conflicts = vncdotool
+ source = git+https://github.com/sibson/vncdotool.git
+ md5sums = SKIP
+
+pkgname = vncdotool-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dd90fb078a35
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/*.pkg.tar.xz
+/*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b16e9d37676
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Vivien Maisonneuve <v dot maisonneuve at gmail dot com>
+# Category: system
+pkgname='vncdotool-git'
+pkgver=0.8.0.r48.g664c318
+pkgrel=1
+pkgdesc='A command line VNC client'
+arch=('any')
+url='https://github.com/sibson/vncdotool'
+license=('custom')
+depends=('python2-pillow' 'python2-twisted' 'python2-wsgiref' 'python2-zope-interface')
+provides=('vncdotool')
+conflicts=('vncdotool')
+source=('git+https://github.com/sibson/vncdotool.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/vncdotool"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/vncdotool"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}