summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-07-04 13:08:23 +0200
committerFabioLolix2022-07-04 13:08:23 +0200
commitb7fc43873fe1858e25784106f5720508b7b185f0 (patch)
tree1c7dae2aee9612f2c362c7349bc4f340ac7d203c
parentf6a4c9dab7a9363864a36ad17cc4d22bc3bc8fb1 (diff)
downloadaur-b7fc43873fe1858e25784106f5720508b7b185f0.tar.gz
v3.13.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab5039b942f6..0f6c463f1105 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vnote
pkgdesc = A Vim-inspired note-taking application, especially for Markdown.
- pkgver = 3.13.0
+ pkgver = 3.13.1
pkgrel = 1
url = https://vnotex.github.io/vnote/en_us/
arch = x86_64
@@ -13,8 +13,10 @@ pkgbase = vnote
makedepends = git
depends = qt5-webengine
depends = qt5-svg
- source = git+https://github.com/vnotex/vnote.git#tag=v3.13.0
+ depends = qt5-x11extras
+ source = git+https://github.com/vnotex/vnote.git#tag=v3.13.1
source = vnotex-vtextedit::git+https://github.com/vnotex/vtextedit
+ source = vnotex-QHotkey::git+https://github.com/vnotex/QHotkey.git
source = vnotex-syntax-highlighting::git+https://github.com/vnotex/syntax-highlighting
source = vnotex-hunspell::git+https://github.com/vnotex/hunspell
source = vnotex-sonnet::git+https://github.com/vnotex/sonnet
@@ -23,5 +25,6 @@ pkgbase = vnote
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = vnote
diff --git a/PKGBUILD b/PKGBUILD
index 82f42dee6870..9d0a4e34afde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
# Contributor: erk <v at erk dot io>
pkgname=vnote
-pkgver=3.13.0
+pkgver=3.13.1
pkgrel=1
pkgdesc="A Vim-inspired note-taking application, especially for Markdown."
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://vnotex.github.io/vnote/en_us/"
license=(LGPL3)
-depends=(qt5-webengine qt5-svg)
+depends=(qt5-webengine qt5-svg qt5-x11extras)
makedepends=(git)
source=("git+https://github.com/vnotex/vnote.git#tag=v${pkgver}"
"vnotex-vtextedit::git+https://github.com/vnotex/vtextedit"
+ "vnotex-QHotkey::git+https://github.com/vnotex/QHotkey.git"
"vnotex-syntax-highlighting::git+https://github.com/vnotex/syntax-highlighting"
"vnotex-hunspell::git+https://github.com/vnotex/hunspell"
"vnotex-sonnet::git+https://github.com/vnotex/sonnet")
@@ -19,6 +20,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
@@ -28,6 +30,7 @@ prepare() {
git submodule init
git config 'submodule.libs/vtextedit.url' "${srcdir}/vnotex-vtextedit"
+ git config 'submodule.libs/QHotkey.url' "${srcdir}/vnotex-QHotkey"
git submodule update
cd "libs/vtextedit"