summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tiá2018-09-23 09:12:19 -0600
committerJavier Tiá2018-09-23 09:12:19 -0600
commit13fc0116ad1e78d73ce25649d4b90fe59d542d2c (patch)
treeac2db2a878907b27320dad060077ba37c3758082
downloadaur-13fc0116ad1e78d73ce25649d4b90fe59d542d2c.tar.gz
Bump up vnote-bin 2.0-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD58
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b21367cde459
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vnote-bin
+ pkgdesc = A Vim-inspired note-taking application that knows programmers and Markdown better
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://tamlok.github.io/vnote
+ arch = x86_64
+ license = MIT
+ conflicts = vnote-bin
+ conflicts = vnote
+ replaces = vnote-bin
+ replaces = vnote
+ options = !strip
+ source = vnote-2.0.AppImage::https://github.com/tamlok/vnote//releases/download/v2.0/VNote-2.0-x86_64.AppImage
+ sha256sums = d5b93dc63a9aad5e690015081190f98bfaf64cc3e5197cb61b11194c763ad222
+
+pkgname = vnote-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e858bbe6b493
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Javier Tiá <javier dot tia at gmail dot com>
+
+_name=vnote
+_pkgname=VNote
+pkgname=${_name}-bin
+pkgver=2.0
+pkgrel=1
+pkgdesc='A Vim-inspired note-taking application that knows programmers and Markdown better'
+arch=('x86_64')
+url='https://tamlok.github.io/vnote'
+license=('MIT')
+# depends=('qt5-webengine')
+conflicts=("${_name}-bin" "${_name}")
+replaces=("${_name}-bin" "${_name}")
+options=(!strip)
+_url=https://github.com/tamlok/vnote/
+_binfile=${_pkgname}-${pkgver}-${CARCH}.AppImage
+_buildfile=${_name}-${pkgver}.AppImage
+source=("${_buildfile}::${_url}/releases/download/v${pkgver}/${_binfile}")
+sha256sums=('d5b93dc63a9aad5e690015081190f98bfaf64cc3e5197cb61b11194c763ad222')
+
+prepare() {
+ # Extract AppImage
+ chmod +x ${_buildfile}
+ ./${_buildfile} --appimage-extract
+ find "${srcdir}/squashfs-root/" -type d -exec chmod 755 '{}' +;
+
+ _desktopfile="${srcdir}/squashfs-root/usr/share/applications/${_name}.desktop"
+ sed -i "s#^Exec=VNote#Exec=/opt/vnote/usr/bin/VNote#" "${_desktopfile}"
+}
+
+package() {
+ # share
+ install -d "${pkgdir}/usr"
+ mv "${srcdir}/squashfs-root/usr/share" "${pkgdir}/usr"
+
+ # Install
+ install -d "${pkgdir}/opt/${_name}"
+ mv "${srcdir}/squashfs-root/usr" "${pkgdir}/opt/${_name}"
+
+ # License
+ install -d "${pkgdir}/usr/share/licenses/${_name}"
+ cp "${srcdir}"/squashfs-root/LICENSE \
+ "${pkgdir}/usr/share/licenses/${_name}"
+
+ # Binary
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/${_name}/usr/bin/${_pkgname}" \
+ "${pkgdir}/usr/bin/${_name}"
+ ln -s "/opt/${_name}/usr/bin/${_pkgname}" \
+ "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Clean up
+ rm -rf "${pkgdir}/opt/${_name}/usr/bin/${_name}"
+ rm -rf "${pkgdir}/usr/share/doc"
+}
+
+# vim:set ts=2 sw=2 et: