summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-30 11:21:40 +0800
committerzxp198210052024-01-30 11:21:40 +0800
commitb81f87c885494998658e75af91ab9400b907198d (patch)
treebf3e4fb3295629350ce6536d9418e4a16fee9549
parente73d321ec4e38485732b4addad0d0022ca3627ff (diff)
downloadaur-b81f87c885494998658e75af91ab9400b907198d.tar.gz
update to 3.17.0
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD98
-rw-r--r--vnote.sh14
3 files changed, 73 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58718c4104d4..e1ba1651d948 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,22 @@
pkgbase = vnote-bin
- pkgdesc = A Vim-inspired note-taking application that knows programmers and Markdown better
- pkgver = 2.10
+ pkgdesc = A Qt-based, free and open source note-taking application, focusing on Markdown now.
+ pkgver = 3.17.0
pkgrel = 1
- url = https://github.com/vnotex/vnote
+ url = https://app.vnote.fun/
arch = x86_64
- license = MIT
+ license = LGPL-3.0-only
+ makedepends = squashfuse
+ depends = hicolor-icon-theme
+ depends = qt5-base
+ depends = gtk3
+ depends = alsa-lib
+ depends = nss
+ provides = vnote=3.17.0
conflicts = vnote
- replaces = vnote
options = !strip
- source = vnote-2.10.AppImage::https://github.com/vnotex/vnote//releases/download/v2.10/VNote-2.10-x86_64.AppImage
- sha256sums = aeee6092ec86c140483db6ad5add53a13c42bf40fb575d7f0b3fc40238b2b9ee
+ source = vnote-3.17.0.zip::https://github.com/vnotex/vnote/releases/download/v3.17.0/vnote-linux-x64_v3.17.0.zip
+ source = vnote.sh
+ sha256sums = 6b74dd083bfa3ecec5a0ee74d8ecbc4fce7b7a81d43c9246fdd43d83f190ec98
+ sha256sums = a9c558d0ce9e8b9ae2ca6cb1933ddcb941e4554afb01c903680d969707ce735e
pkgname = vnote-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 9c54597651e0..89bf9e0de9d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,49 @@
-# Maintainer: XelK
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+# Contributor: XelK
# Contributor: Javier TiĆ” <javier dot tia at gmail dot com>
-
-_name=vnote
-_pkgname=VNote
-pkgname=${_name}-bin
-pkgver=2.10
+pkgname=vnote-bin
+pkgver=3.17.0
pkgrel=1
-pkgdesc='A Vim-inspired note-taking application that knows programmers and Markdown better'
+pkgdesc="A Qt-based, free and open source note-taking application, focusing on Markdown now."
arch=('x86_64')
-url='https://github.com/vnotex/vnote'
-license=('MIT')
-# depends=('qt5-webengine')
-conflicts=("${_name}")
-replaces=("${_name}")
-options=(!strip)
-_url=https://github.com/vnotex/vnote/
-_binfile=${_pkgname}-${pkgver}-${CARCH}.AppImage
-_buildfile=${_name}-${pkgver}.AppImage
-source=("${_buildfile}::${_url}/releases/download/v${pkgver}/${_binfile}")
-sha256sums=('aeee6092ec86c140483db6ad5add53a13c42bf40fb575d7f0b3fc40238b2b9ee')
-
-prepare() {
- # Extract AppImage
- chmod +x ${_buildfile}
- ./${_buildfile} --appimage-extract
- find "${srcdir}/squashfs-root/" -type d -exec chmod 755 '{}' +;
-
- _desktopfile="${srcdir}/squashfs-root/usr/share/applications/${_name}.desktop"
- sed -i "s#^Exec=VNote#Exec=/opt/vnote/usr/bin/VNote#" "${_desktopfile}"
+url="https://app.vnote.fun/"
+_ghurl="https://github.com/vnotex/vnote"
+license=('LGPL-3.0-only')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ 'hicolor-icon-theme'
+ 'qt5-base'
+ 'gtk3'
+ 'alsa-lib'
+ 'nss'
+)
+makedepends=(
+ 'squashfuse'
+)
+options=('!strip')
+source=(
+ "${pkgname%-bin}-${pkgver}.zip::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-x64_v${pkgver}.zip"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('6b74dd083bfa3ecec5a0ee74d8ecbc4fce7b7a81d43c9246fdd43d83f190ec98'
+ 'a9c558d0ce9e8b9ae2ca6cb1933ddcb941e4554afb01c903680d969707ce735e')
+build() {
+ sed -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|${pkgname%-bin}|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ mv "${srcdir}/${pkgname%-bin}-linux-x64_v${pkgver}.AppImage" "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
}
-
package() {
- # share
- install -d "${pkgdir}/usr"
- mv "${srcdir}/squashfs-root/usr/share" "${pkgdir}/usr"
-
- # Install
- install -d "${pkgdir}/opt/${_name}"
- mv "${srcdir}/squashfs-root/usr" "${pkgdir}/opt/${_name}"
-
- # License
- install -d "${pkgdir}/usr/share/licenses/${_name}"
- cp "${srcdir}"/squashfs-root/LICENSE \
- "${pkgdir}/usr/share/licenses/${_name}"
-
- # Binary
- install -d "${pkgdir}/usr/bin"
- ln -s "/opt/${_name}/usr/bin/${_pkgname}" \
- "${pkgdir}/usr/bin/${_name}"
- ln -s "/opt/${_name}/usr/bin/${_pkgname}" \
- "${pkgdir}/usr/bin/${_pkgname}"
-
- # Clean up
- rm -rf "${pkgdir}/opt/${_name}/usr/bin/${_name}"
- rm -rf "${pkgdir}/usr/share/doc"
-}
-
-# vim:set ts=2 sw=2 et:
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 -d "${pkgdir}/opt/${pkgname%-bin}"
+ cp -r "${srcdir}/squashfs-root/usr/"* "${pkgdir}/opt/${pkgname%-bin}"
+ for _icons in 16x16 32x32 48x48 64x64 128x128 256x256;do
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
+ done
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/scalable/apps/${pkgname%-bin}.svg" -t "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file
diff --git a/vnote.sh b/vnote.sh
new file mode 100644
index 000000000000..f7d54198bf5a
--- /dev/null
+++ b/vnote.sh
@@ -0,0 +1,14 @@
+#!/bin/sh
+set -e
+_APPDIR="/opt/@appname@"
+_RUNNAME="${_APPDIR}/bin/@runname@"
+export PATH="${_APPDIR}/bin:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export QT_PLUGIN_PATH="${_APPDIR}/plugins:${QT_PLUGIN_PATH}"
+case "${XDG_CURRENT_DESKTOP}" in
+ *GNOME*|*gnome*|*XFCE*)
+ export QT_QPA_PLATFORMTHEME=gtk3
+ ;;
+esac
+cd "${_APPDIR}"
+exec "${_RUNNAME}" "$@" || exit $? \ No newline at end of file