summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-07-04 13:09:12 +0200
committerFabioLolix2022-07-04 13:09:12 +0200
commit46718f5d193e4f4a18ce01661570f8ac9bc08e5d (patch)
treee1c64c0dc105e0607b61857a4fe7d032a18c76c3
parent0bf546d0c9d3d7d305c9fb251e429ccf4fade3eb (diff)
downloadaur-46718f5d193e4f4a18ce01661570f8ac9bc08e5d.tar.gz
vupdate deps, git submodules
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62db92ef029d..42bc76a28fe9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vnote-git
pkgdesc = A Vim-inspired note-taking application, especially for Markdown.
- pkgver = 3.6.0.r4.7cc31a5d
+ pkgver = 3.13.1.r3.g17af3b8d
pkgrel = 1
url = https://vnotex.github.io/vnote/en_us/
arch = x86_64
@@ -14,8 +14,10 @@ pkgbase = vnote-git
depends = qt5-base
depends = qt5-webengine
depends = qt5-svg
+ depends = qt5-x11extras
source = git+https://github.com/vnotex/vnote.git
source = vnotex-vtextedit::git+https://github.com/vnotex/vtextedit
+ source = vnotex-QHotkey::git+https://github.com/vnotex/QHotkey.git
source = vnotex-syntax-highlighting::git+https://github.com/vnotex/syntax-highlighting
source = vnotex-hunspell::git+https://github.com/vnotex/hunspell
source = vnotex-sonnet::git+https://github.com/vnotex/sonnet
@@ -24,5 +26,6 @@ pkgbase = vnote-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = vnote-git
diff --git a/PKGBUILD b/PKGBUILD
index 7844c1cca041..69c6963bf084 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
# Contributor: erk <v at erk dot io>
pkgname=vnote-git
-pkgver=3.6.0.r4.7cc31a5d
+pkgver=3.13.1.r3.g17af3b8d
pkgrel=1
pkgdesc="A Vim-inspired note-taking application, especially for Markdown."
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url='https://vnotex.github.io/vnote/en_us/'
license=(LGPL3)
-depends=(qt5-base qt5-webengine qt5-svg)
+depends=(qt5-base qt5-webengine qt5-svg qt5-x11extras)
makedepends=(git)
source=("git+https://github.com/vnotex/vnote.git"
"vnotex-vtextedit::git+https://github.com/vnotex/vtextedit"
+ "vnotex-QHotkey::git+https://github.com/vnotex/QHotkey.git"
"vnotex-syntax-highlighting::git+https://github.com/vnotex/syntax-highlighting"
"vnotex-hunspell::git+https://github.com/vnotex/hunspell"
"vnotex-sonnet::git+https://github.com/vnotex/sonnet")
@@ -19,13 +20,12 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
cd "${srcdir}/${pkgname%-git}"
- #printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- TAG=$(git tag --list | tail -n 1 | sed 's/^v//')
- printf "${TAG}.r%s.%s" "$(git rev-list --count v${TAG}..HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags --exclude continuous-build | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -35,6 +35,7 @@ prepare() {
git submodule init
git config 'submodule.libs/vtextedit.url' "${srcdir}/vnotex-vtextedit"
+ git config 'submodule.libs/QHotkey.url' "${srcdir}/vnotex-QHotkey"
git submodule update
cd "libs/vtextedit"