summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Dray2015-07-09 08:07:54 +1000
committerJustin Dray2015-07-09 08:07:54 +1000
commitdf08f64600a0395b63db28ebf6914a45c6a425c2 (patch)
tree4894388bc8f9d41032ba5b49cc77f7570b9f2535
downloadaur-df08f64600a0395b63db28ebf6914a45c6a425c2.tar.gz
Update to: 0.1.3-1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD28
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af9bed6cecde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vo-aacenc
+ pkgdesc = VisualOn Advanced Audio Coding (AAC) encoder
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = http://sourceforge.net/projects/opencore-amr/
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ depends = glibc
+ options = !emptydirs
+ options = !libtool
+ source = http://downloads.sourceforge.net/opencore-amr/vo-aacenc-0.1.3.tar.gz
+ sha256sums = e51a7477a359f18df7c4f82d195dab4e14e7414cbd48cf79cc195fc446850f36
+
+pkgname = vo-aacenc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..181b3460e424
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+*
+!PKGBUILD
+!.SRCINFO
+!*.patch
+!*.desktop
+!*.install
+!*.service
+!*.sh
+!*.conf
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c0f407c2b52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Justin Dray <justin@dray.be>
+# Contributor: David Roheim <david dot roheim at gmail dot com>
+# Contributor: Leonard de Ruijter <leonard@aur.archlinux.org>
+# Contributor: DrZaius <lou[at]fakeoutdoorsman[dot]com>
+
+pkgname=vo-aacenc
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="VisualOn Advanced Audio Coding (AAC) encoder"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/opencore-amr/"
+license=('APACHE')
+depends=('glibc')
+options=('!emptydirs' '!libtool')
+source=(http://downloads.sourceforge.net/opencore-amr/$pkgname-$pkgver.tar.gz)
+sha256sums=('e51a7477a359f18df7c4f82d195dab4e14e7414cbd48cf79cc195fc446850f36')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package () {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+