summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122017-05-16 10:57:26 +0200
committerwillemw122017-05-16 10:57:26 +0200
commita974e4ac66d189ee93fa2cc1a2bbab73566aa90a (patch)
tree632dbbbe8a043b6d4811d4272b721d01ece9bacf
parent2c823441375aecae97d59b719cd638a3582fd008 (diff)
downloadaur-a974e4ac66d189ee93fa2cc1a2bbab73566aa90a.tar.gz
Fix gsettings build error. Patch .deskop and .appdata.xml install.
Add install hook packages: dconf, desktop-file-utils, gtk-update-icon-cache
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD13
2 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f247c93a496a..92e4a037ec82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,27 @@
# Generated by mksrcinfo v8
-# Fri Apr 21 09:33:18 UTC 2017
+# Tue May 16 08:56:21 UTC 2017
pkgbase = vocal-git
pkgdesc = Podcast Client for the Modern Desktop
- pkgver = 2.0.13.beta.r13.gbced2e2
+ pkgver = 2.0.15.r0.g86d0456
pkgrel = 1
url = http://www.vocalproject.net
arch = i686
arch = x86_64
license = GPL3
+ makedepends = cmake
makedepends = git
makedepends = vala
- makedepends = cmake
- depends = libnotify
- depends = libxml2
+ depends = clutter-gst
+ depends = clutter-gtk
+ depends = dconf
+ depends = desktop-file-utils
depends = granite
- depends = gtk3
depends = gstreamer
+ depends = gtk-update-icon-cache
+ depends = gtk3
+ depends = libnotify
+ depends = libxml2
depends = sqlite
- depends = clutter-gtk
- depends = clutter-gst
depends = webkit2gtk
provides = vocal
conflicts = vocal
diff --git a/PKGBUILD b/PKGBUILD
index 2462148ff922..3b9b7f386ade 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
_pkgname=vocal
pkgname=$_pkgname-git
-pkgver=2.0.13.beta.r13.gbced2e2
+pkgver=2.0.15.r0.g86d0456
pkgrel=1
pkgdesc="Podcast Client for the Modern Desktop"
arch=('i686' 'x86_64')
url="http://www.vocalproject.net"
license=('GPL3')
-depends=('libnotify' 'libxml2' 'granite' 'gtk3' 'gstreamer' 'sqlite' 'clutter-gtk' 'clutter-gst' 'webkit2gtk')
-makedepends=('git' 'vala' 'cmake')
+depends=('clutter-gst' 'clutter-gtk' 'dconf' 'desktop-file-utils' 'granite' 'gstreamer' 'gtk-update-icon-cache' 'gtk3' 'libnotify' 'libxml2' 'sqlite' 'webkit2gtk')
+makedepends=('cmake' 'git' 'vala')
provides=($_pkgname)
conflicts=($_pkgname)
#source=($_pkgname::git://github.com/needle-and-thread/vocal.git)
@@ -35,12 +35,17 @@ build() {
cd $_pkgname
rm -rf build
mkdir build
+
cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr # -DGSETTINGS_LOCALINSTALL=1 -DGSETTINGS_COMPILE=1
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DGSETTINGS_COMPILE=0 # -DGSETTINGS_LOCALINSTALL=1
make
}
package() {
+ # Patch
+ mv $_pkgname/build/com.github.needle-and-thread.vocal.desktop{.in,}
+ mv $_pkgname/data/com.github.needle-and-thread.vocal.appdata.xml.in $_pkgname/build/com.github.needle-and-thread.vocal.appdata.xml
+
cd $_pkgname/build
make DESTDIR="$pkgdir/" install
}