summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author466202023-12-23 21:55:50 -0500
committer466202023-12-23 21:55:50 -0500
commit6a95cdee578544a0420815255d10eef1ef17fb7e (patch)
tree03695fa3c526f07a67efa439c2fa56697f1e716b
downloadaur-6a95cdee578544a0420815255d10eef1ef17fb7e.tar.gz
init commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c0620e7e3f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = vodbot-git
+ pkgdesc = A command line interface VOD and Clip manager for Twitch.
+ pkgver = 1.1.10.r0.g376e311
+ pkgrel = 1
+ url = https://github.com/FriendTeamInc/VodBot
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ depends = ffmpeg
+ depends = python-argcomplete
+ depends = python-dataclasses-json
+ depends = python-requests
+ depends = python-m3u8
+ depends = python-google-api-python-client
+ depends = python-google-auth-oauthlib
+ depends = python-google-auth-httplib2
+ depends = python-pillow
+ depends = python-discord-webhook
+ provides = vodbot
+ conflicts = vodbot
+ source = vodbot-git::git+https://github.com/FriendTeamInc/VodBot.git
+ sha256sums = SKIP
+
+pkgname = vodbot-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4530ae7d2db4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Mia Furze <46620osu@gmail.com>
+
+pkgname='vodbot-git'
+pkgver=1.1.10.r0.g376e311
+pkgrel=1
+pkgdesc='A command line interface VOD and Clip manager for Twitch.'
+arch=('x86_64' 'armv7h' 'aarch64')
+url="https://github.com/FriendTeamInc/VodBot"
+provides=('vodbot')
+conflicts=('vodbot')
+depends=('ffmpeg'
+ 'python-argcomplete'
+ 'python-dataclasses-json' # AUR
+ 'python-requests'
+ 'python-m3u8' # AUR
+ 'python-google-api-python-client'
+ 'python-google-auth-oauthlib'
+ 'python-google-auth-httplib2'
+ 'python-pillow'
+ 'python-discord-webhook' # AUR
+)
+license=('MIT')
+source=("$pkgname::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd "$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root="${pkgdir}/"
+}