summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaster812022-03-21 22:26:24 +0330
committerMaster812022-03-21 22:26:24 +0330
commit6530ed87841e5c029e5d4627edd29ec6a8a99e09 (patch)
tree0fb0d46d92487b284071c731a8b1468eba246ad5
downloadaur-6530ed87841e5c029e5d4627edd29ec6a8a99e09.tar.gz
Initial push
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51b1105681d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = voicegen
+ pkgdesc = Convert text to speech using multiple engines
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = https://gitlab.com/PersianGolf/voicegen/
+ arch = x86_64
+ license = GPL
+ makedepends = qt5-multimedia
+ depends = qt5-multimedia
+ depends = qt5-base
+ provides = voicegen
+ conflicts = voicegen
+ source = https://gitlab.com/PersianGolf/voicegen/-/archive/0.2.5/voicegen-0.2.5.tar.gz
+ md5sums = SKIP
+
+pkgname = voicegen
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d3830d4644d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: PersianGolf <Freefighter81@protonmail.com>
+pkgname=voicegen
+pkgver=0.2.5
+pkgrel=1
+pkgdesc="Convert text to speech using multiple engines"
+arch=(x86_64)
+url="https://gitlab.com/PersianGolf/voicegen/"
+license=('GPL')
+depends=('qt5-multimedia' 'qt5-base')
+makedepends=('qt5-multimedia')
+provides=(voicegen)
+conflicts=(voicegen)
+install=
+source=("https://gitlab.com/PersianGolf/voicegen/-/archive/${pkgver}/voicegen-${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+
+build() {
+ cd $pkgname-$pkgver
+ cmake CMakeLists.txt
+ make
+}
+
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm777 voicegen ${pkgdir}/usr/bin/voicegen
+ sed -i '11s/.*/Icon=voicegen/' Integration-Stuff/desktop/voicegen.desktop
+ install -Dm644 Integration-Stuff/desktop/voicegen.desktop $pkgdir/usr/share/applications/voicegen.desktop
+ for res in 32 64 128 256 512; do
+ install -Dm644 Integration-Stuff/icons/${res}x${res}/voicegen.png $pkgdir/usr/share/icons/hicolor/${res}x${res}/apps/voicegen.png
+ done
+}