summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaster812022-03-31 15:43:38 +0430
committerMaster812022-03-31 15:43:38 +0430
commit8159ac3cc273cedc93369e83cfba21932aae9ecf (patch)
treea3b5a2a9342a033ff90f9418b4566a9ff69c79ec
parent6530ed87841e5c029e5d4627edd29ec6a8a99e09 (diff)
downloadaur-8159ac3cc273cedc93369e83cfba21932aae9ecf.tar.gz
Release 1.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51b1105681d6..3373db5ef8d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = voicegen
pkgdesc = Convert text to speech using multiple engines
- pkgver = 0.2.5
+ pkgver = 1.0.0
pkgrel = 1
url = https://gitlab.com/PersianGolf/voicegen/
arch = x86_64
@@ -8,9 +8,11 @@ pkgbase = voicegen
makedepends = qt5-multimedia
depends = qt5-multimedia
depends = qt5-base
+ optdepends = svox-pico-bin
+ optdepends = ffmpeg
provides = voicegen
conflicts = voicegen
- source = https://gitlab.com/PersianGolf/voicegen/-/archive/0.2.5/voicegen-0.2.5.tar.gz
+ source = https://gitlab.com/PersianGolf/voicegen/-/archive/1.0.0/voicegen-1.0.0.tar.gz
md5sums = SKIP
pkgname = voicegen
diff --git a/PKGBUILD b/PKGBUILD
index 4d3830d4644d..d722601f0bb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: PersianGolf <Freefighter81@protonmail.com>
pkgname=voicegen
-pkgver=0.2.5
+pkgver=1.0.0
pkgrel=1
pkgdesc="Convert text to speech using multiple engines"
arch=(x86_64)
url="https://gitlab.com/PersianGolf/voicegen/"
license=('GPL')
depends=('qt5-multimedia' 'qt5-base')
+optdepends=('svox-pico-bin' 'ffmpeg')
makedepends=('qt5-multimedia')
provides=(voicegen)
conflicts=(voicegen)
@@ -27,7 +28,8 @@ package() {
install -Dm777 voicegen ${pkgdir}/usr/bin/voicegen
sed -i '11s/.*/Icon=voicegen/' Integration-Stuff/desktop/voicegen.desktop
install -Dm644 Integration-Stuff/desktop/voicegen.desktop $pkgdir/usr/share/applications/voicegen.desktop
- for res in 32 64 128 256 512; do
+ for res in 32 48 64 128 256 512; do
install -Dm644 Integration-Stuff/icons/${res}x${res}/voicegen.png $pkgdir/usr/share/icons/hicolor/${res}x${res}/apps/voicegen.png
done
+ install -Dm644 Integration-Stuff/icons/scalable/voicegen.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/voicegen.svg
}