summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-09-17 10:52:10 -0600
committerMark Wagie2023-09-17 10:52:10 -0600
commit152638a97f6451ff3d33b0afdf7b7b4fd6891a5a (patch)
tree3619be52761fb1f3c9879bbc7db9b5455b913a52
parente65b235c3232eefaa827a061af7e67bf8c900e28 (diff)
downloadaur-152638a97f6451ff3d33b0afdf7b7b4fd6891a5a.tar.gz
add missing build deps
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD28
3 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91bc8e3bda4f..4d3d4145415f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = volantes-cursors-git
pkgdesc = Classic cursor with a flying style.
- pkgver = r4.f5dd936
+ pkgver = r7.b13a4bb
pkgrel = 1
- url = https://github.com/varlesh/volantes-cursors
+ url = https://www.pling.com/p/1356095
arch = any
license = GPL2
makedepends = git
makedepends = inkscape
+ makedepends = libcanberra
makedepends = xorg-xcursorgen
provides = volantes-cursors
conflicts = volantes-cursors
@@ -14,4 +15,3 @@ pkgbase = volantes-cursors-git
sha256sums = SKIP
pkgname = volantes-cursors-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 5aca2c675bf4..a2a2024f4668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
-# Maintainer: Francois Menning <f.menning@pm.me>
-
-_pkgname=volantes-cursors
+# Maintainer: Mark Wagie <mark dot wage at proton dot me>
+# Contributor: Francois Menning <f.menning@pm.me>
pkgname=volantes-cursors-git
-pkgver=r4.f5dd936
+pkgver=r7.b13a4bb
pkgrel=1
-pkgdesc='Classic cursor with a flying style.'
+pkgdesc="Classic cursor with a flying style."
arch=('any')
-url='https://github.com/varlesh/volantes-cursors'
+url="https://www.pling.com/p/1356095"
license=('GPL2')
-makedepends=('git' 'inkscape' 'xorg-xcursorgen')
-provides=($_pkgname)
-conflicts=($_pkgname)
-source=("git+https://github.com/varlesh/${_pkgname}.git")
+makedepends=('git' 'inkscape' 'libcanberra' 'xorg-xcursorgen')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/varlesh/volantes-cursors.git")
sha256sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "$srcdir/${pkgname%-git}"
+ export NO_AT_BRIDGE=1
make build
}
package() {
- cd "${srcdir}/${_pkgname}"
- make DESTDIR="${pkgdir}" install
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir" install
}