summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrancoism902020-02-22 12:05:49 +0100
committerfrancoism902020-02-22 12:05:49 +0100
commit3eb15ddb20ef269a7ec8e8ada4713c26dd767dca (patch)
treefbe5bdb01d6b0cc72677f4dc66a8c3194d743c54
downloadaur-3eb15ddb20ef269a7ec8e8ada4713c26dd767dca.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29e761a8b333
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = volantes-cursors-git
+ pkgdesc = Classic cursor with a flying style.
+ pkgver = r4.f5dd936
+ pkgrel = 1
+ url = https://github.com/varlesh/volantes-cursors
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = inkscape
+ makedepends = xorg-xcursorgen
+ depends = plasma-desktop
+ provides = volantes-cursors
+ conflicts = volantes-cursors
+ source = git+https://github.com/varlesh/volantes-cursors.git
+ sha256sums = SKIP
+
+pkgname = volantes-cursors-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c0f81ec2ac1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Francois Menning <f.menning@pm.me>
+
+_pkgname=volantes-cursors
+pkgname=volantes-cursors-git
+pkgver=r4.f5dd936
+pkgrel=1
+pkgdesc='Classic cursor with a flying style.'
+arch=('any')
+url='https://github.com/varlesh/volantes-cursors'
+license=('GPL2')
+depends=('plasma-desktop')
+makedepends=('git' 'inkscape' 'xorg-xcursorgen')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("git+https://github.com/varlesh/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+} \ No newline at end of file