summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorheinrich59912019-03-30 05:34:32 +0100
committerheinrich59912019-03-30 05:34:32 +0100
commitdc33897a6e3a3cbaa600ae97e7c934ac0d57c704 (patch)
tree4d4bca8779935d2983f6f6e9760d4ff5d9cb1dfc
downloadaur-dc33897a6e3a3cbaa600ae97e7c934ac0d57c704.tar.gz
volt 0.80, initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
-rwxr-xr-xvolt_wrapper3
4 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..811e7aea4df4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Mar 30 04:10:59 UTC 2019
+pkgbase = volt
+ pkgdesc = Fast native desktop client Slack, Skype, Twitter, Telegram, and more
+ pkgver = 0.80
+ pkgrel = 1
+ url = https://volt-app.com/
+ arch = x86_64
+ license = unknown
+ depends = glfw
+ depends = libcurl-compat
+ options = !strip
+ source = https://github.com/voltapp/volt/releases/download/0.80/volt_linux.zip
+ source = volt_wrapper
+ sha256sums = c3c6e933bb680feb6c55a304fd08a61d778f07625793a81bb33998b782aa6378
+ sha256sums = SKIP
+
+pkgname = volt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..64316bd24567
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.*
+*.zip
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43da988008da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: heinrich5991 <heinrich5991@gmail.com>
+pkgname=volt
+pkgver=0.80
+pkgrel=1
+pkgdesc="Fast native desktop client Slack, Skype, Twitter, Telegram, and more"
+arch=('x86_64')
+url="https://volt-app.com/"
+license=('unknown')
+depends=(
+ 'glfw'
+ 'libcurl-compat'
+)
+options=('!strip')
+source=("https://github.com/voltapp/volt/releases/download/${pkgver}/volt_linux.zip"
+ "volt_wrapper")
+sha256sums=('c3c6e933bb680feb6c55a304fd08a61d778f07625793a81bb33998b782aa6378'
+ 'SKIP')
+
+package() {
+ install -Dm755 volt_wrapper "${pkgdir}"/usr/bin/volt
+ install -Dm755 volt "${pkgdir}"/usr/lib/volt/volt
+ install -Dm644 RobotoMono-Regular.ttf "${pkgdir}"/usr/share/volt/RobotoMono-Regular.ttf
+}
diff --git a/volt_wrapper b/volt_wrapper
new file mode 100755
index 000000000000..1a01b9ab0094
--- /dev/null
+++ b/volt_wrapper
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/volt
+exec /usr/lib/volt/volt