summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCan Celasun2015-05-31 21:46:22 +0300
committerCan Celasun2015-05-31 21:46:22 +0300
commitdc89c3d563dff9aa790f7af0382fec3b41acc0f6 (patch)
tree0d3590d92b947bfbe358fb804773c0f25d35b877
downloadaur-dc89c3d563dff9aa790f7af0382fec3b41acc0f6.tar.gz
New structure
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD57
-rw-r--r--voltdb-enterprise.install4
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd73b5faaf12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = voltdb-enterprise
+ pkgdesc = An in-memory database with pre-compiled Java stored procedures (Enterprise Edition)
+ pkgver = 5.2.2
+ pkgrel = 1
+ url = http://voltdb.com/
+ install = voltdb-enterprise.install
+ arch = i686
+ arch = x86_64
+ license = proprietary
+ depends = python2
+ depends = java-environment
+ conflicts = voltdb
+ source = LICENSE
+ md5sums = 3215b6fd0649bdc4d988b7b934139851
+
+pkgname = voltdb-enterprise
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..9c6182e0b087
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+VoltDB (R) Enterprise Edition
+
+Copyright (C) 2008-2015 VoltDB Inc. All rights reserved.
+
+Portions of the VoltDB (R) Enterprise Edition may include or be distributed with copyrighted
+information of third parties. Title thereto is retained, and all rights therein are reserved,
+by the respective copyright owners.
+
+The VoltDB (R) Enterprise Edition is provided under license. It may not be installed, accessed,
+loaded, reproduced, modified, disclosed, distributed or used in any other manner, in any form
+or by any means, except and only to the extent expressly permitted in the written license
+agreement executed and delivered by VoltDB, Inc. and the enterprise that obtained this software
+from VoltDB, Inc. However, if no such written license agreement was executed and delivered by
+both parties, then the version of VoltDB's standard license agreement (located at
+http://voltdb.com/voltdb-enterprise-software-license-agreement) that was in effect when your
+enterprise obtained the software shall apply. Contact your licensing officer to determine
+the scope of the license applicable to you.
+
+VoltDB (R) is a registered trademark of VoltDB, Inc.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2572c31547c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: D. Can Celasun <dcelasun[at]gmail[dot]com>
+pkgname=voltdb-enterprise
+_pkgname=voltdb-ent
+pkgver=5.2.2
+pkgrel=1
+pkgdesc="An in-memory database with pre-compiled Java stored procedures (Enterprise Edition)"
+arch=('i686' 'x86_64')
+url="http://voltdb.com/"
+license=('proprietary')
+depends=('python2' 'java-environment')
+conflicts=('voltdb')
+source=(LICENSE)
+install=${pkgname}.install
+md5sums=('3215b6fd0649bdc4d988b7b934139851')
+
+_vpkg=LINUX-voltdb-ent-${pkgver}.tar.gz
+
+build() {
+ msg "You need a full copy of the program in order to install it"
+ msg "Searching for ${_vpkg} in dir: \"$startdir\""
+ pkgpath="$startdir"
+ if [[ ! -f "${pkgpath}/${_vpkg}" ]]; then
+ error "Package not found, please type absolute path to ${_vpkg} (/home/joe):"
+ read pkgpath
+ if [[ ! -f "${pkgpath}/${_vpkg}" ]]; then
+ error "Unable to package." && return 1
+ fi
+ fi
+ msg "Found package, unpacking..."
+ tar xf "${pkgpath}/${_vpkg}" -C "${srcdir}"
+
+
+ cd "${srcdir}"/${_pkgname}-${pkgver}
+
+ find -name '*.py' -exec sed -i 's|^#!/usr/bin/env python\s*$|#!/usr/bin/env python2|' {} \;
+ find bin/* -exec sed -i 's|^#!/usr/bin/env python\s*$|#!/usr/bin/env python2|' {} \;
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt/voltdb"
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/licenses/voltdb"
+
+ mv "${srcdir}"/${_pkgname}-${pkgver}/* "${pkgdir}"/opt/voltdb
+
+ ln -s /opt/voltdb/bin/csvloader "${pkgdir}"/usr/bin/csvloader
+ ln -s /opt/voltdb/bin/dragent "${pkgdir}"/usr/bin/dragent
+ ln -s /opt/voltdb/bin/jdbcloader "${pkgdir}"/usr/bin/jdbcloader
+ ln -s /opt/voltdb/bin/kafkaloader "${pkgdir}"/usr/bin/kafkaloader
+ ln -s /opt/voltdb/bin/sqlcmd "${pkgdir}"/usr/bin/sqlcmd
+ ln -s /opt/voltdb/bin/voltadmin "${pkgdir}"/usr/bin/voltadmin
+ ln -s /opt/voltdb/bin/voltcompiler "${pkgdir}"/usr/bin/voltcompiler
+ ln -s /opt/voltdb/bin/voltdb "${pkgdir}"/usr/bin/voltdb
+ ln -s /opt/voltdb/bin/voltdb3 "${pkgdir}"/usr/bin/voltdb3
+
+ install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/voltdb/LICENSE"
+}
diff --git a/voltdb-enterprise.install b/voltdb-enterprise.install
new file mode 100644
index 000000000000..8d747dbd6ce8
--- /dev/null
+++ b/voltdb-enterprise.install
@@ -0,0 +1,4 @@
+# arg 1: the new package version
+post_install() {
+ echo "You should add /opt/voltdb/bin to your \$PATH"
+}