summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Avance2024-03-24 18:35:43 -0500
committerAlex Avance2024-03-24 18:36:23 -0500
commit8411a50e380f5b3ae14c937115ff5983d2ecefbd (patch)
tree3bbdc30a45f0b9d577be036005c0613b76ad2e79
downloadaur-8411a50e380f5b3ae14c937115ff5983d2ecefbd.tar.gz
feat: initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..580efabce49e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = volume-sync-git
+ pkgdesc = A utility for keeping volume in sync across multiple pulse volume sinks
+ pkgver = 7.3d26107
+ pkgrel = 1
+ url = https://github.com/aravance/volume-sync
+ arch = x86_64
+ makedepends = cargo
+ depends = libpulse
+ source = volume-sync::git+https://github.com/aravance/volume-sync.git
+ sha256sums = SKIP
+
+pkgname = volume-sync-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8d1f9cb33419
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.*
+/pkg
+/src
+/volume-sync
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6136b0fd78a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alex Avance <aravance(at)gmail(dot)com>
+
+_pkgname=volume-sync
+pkgname=$_pkgname-git
+pkgver=7.3d26107
+pkgrel=1
+pkgdesc="A utility for keeping volume in sync across multiple pulse volume sinks"
+url="https://github.com/aravance/volume-sync"
+depends=('libpulse')
+makedepends=('cargo')
+arch=('x86_64')
+source=("volume-sync::git+https://github.com/aravance/volume-sync.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release --locked
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm0755 -t "$pkgdir/usr/bin" "target/release/$_pkgname"
+}