summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2021-06-23 03:48:44 +0200
committerMichal Wojdyla2021-06-23 03:48:44 +0200
commitfd02c5c0937ef0d4534bc9bdaf029c4021b72b40 (patch)
treea78a7ecdc776f713ae16a8b163f5863616139b14
parentfabc122d45eab2ea059c051cbb03d5b731abb2e8 (diff)
downloadaur-fd02c5c0937ef0d4534bc9bdaf029c4021b72b40.tar.gz
update
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD45
-rw-r--r--volumeicon.desktop9
-rw-r--r--volumeicon.install7
4 files changed, 52 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df1e5a794f4e..0f1773f7f65e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = volumeicon-git
- pkgdesc = Volume control for your system tray
- pkgver = 0.r46.9e3755f
- pkgrel = 2
- url = http://softwarebakery.com/maato/volumeicon.html
+ pkgdesc = Volume control for the system tray
+ pkgver = 0.5.1.r40.g27be3d4
+ pkgrel = 1
+ url = https://softwarebakery.com/maato/volumeicon.html
+ install = volumeicon.install
arch = x86_64
- arch = i686
license = GPL3
makedepends = git
- depends = gtk3
+ makedepends = intltool
depends = alsa-lib
+ depends = gtk3
depends = libnotify
- depends = intltool
+ provides = volumeicon
conflicts = volumeicon
- replaces = volumeicon
- source = volumeicon-git::git+https://github.com/Maato/volumeicon.git
- md5sums = SKIP
+ source = git+https://github.com/Maato/volumeicon.git
+ source = volumeicon.desktop
+ sha256sums = SKIP
+ sha256sums = 3f989bce3a080b2446af6d7ed7e8a22dfd3019f888a7b11a0759bf7cf704f975
pkgname = volumeicon-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a9dbc2778891..311ef9b560ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,39 @@
-# Maintainer: Valère Monseur <valere dot monseur at ymail dot com>
+# Contributor: Valère Monseur <valere dot monseur at ymail dot com>
pkgname=volumeicon-git
-pkgver=0.r46.9e3755f
-pkgrel=2
-pkgdesc='Volume control for your system tray'
-arch=('x86_64' 'i686')
-url="http://softwarebakery.com/maato/volumeicon.html"
-license=('GPL3')
-depends=('gtk3' 'alsa-lib' 'libnotify' 'intltool')
-makedepends=('git')
-source=("${pkgname}"::'git+https://github.com/Maato/volumeicon.git')
-md5sums=('SKIP')
-
+pkgver=0.5.1.r40.g27be3d4
+pkgrel=1
+pkgdesc='Volume control for the system tray'
+arch=(x86_64)
+url='https://softwarebakery.com/maato/volumeicon.html'
+license=(GPL3)
+depends=(alsa-lib gtk3 libnotify)
+makedepends=(git intltool)
+install=volumeicon.install
+source=("git+https://github.com/Maato/volumeicon.git"
+ volumeicon.desktop)
+sha256sums=('SKIP'
+ '3f989bce3a080b2446af6d7ed7e8a22dfd3019f888a7b11a0759bf7cf704f975')
conflicts=('volumeicon')
-replaces=('volumeicon')
+provides=('volumeicon')
pkgver() {
- cd "${srcdir}/${pkgname}"
+ cd volumeicon
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
- printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+prepare() {
+ cd volumeicon
+ ./autogen.sh
}
build() {
- cd "${srcdir}/${pkgname}"
-
- ./autogen.sh
+ cd volumeicon
./configure --prefix=/usr --enable-notify
make
}
package() {
- cd "${srcdir}/${pkgname}"
-
- make DESTDIR="${pkgdir}" install
+ make -C volumeicon DESTDIR="$pkgdir" install
+ install -Dm644 volumeicon.desktop "$pkgdir/usr/share/applications/volumeicon.desktop"
}
diff --git a/volumeicon.desktop b/volumeicon.desktop
new file mode 100644
index 000000000000..d67884aec77c
--- /dev/null
+++ b/volumeicon.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Volume Icon
+Comment=Lightweight volume control for the systray
+Exec=volumeicon
+Icon=multimedia-volume-control
+Type=Application
+Terminal=false
+StartupNotify=false
+Categories=GTK;AudioVideo;Audio;Mixer;
diff --git a/volumeicon.install b/volumeicon.install
new file mode 100644
index 000000000000..582cc86731c3
--- /dev/null
+++ b/volumeicon.install
@@ -0,0 +1,7 @@
+post_install() {
+ # See FS#34239 for more information
+ echo 'If there are problems running volumeicon, try:'
+ echo 'rm -iv ~/.config/volumeicon/volumeicon'
+}
+
+# vim:set ts=2 sw=2 et: