summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2017-05-29 03:17:14 +0300
committerArtem Vorotnikov2017-05-29 03:17:14 +0300
commitc7feaea5f6ef10931ef35b2bf1131534f9910eb4 (patch)
tree8ee1e840f7bbb0359f849e874784177de4896752
parentba30e3b2779605e332128a06d8d660f78019d1ec (diff)
downloadaur-c7feaea5f6ef10931ef35b2bf1131534f9910eb4.tar.gz
Update
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 21 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bb2392856aa..478307aa610f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,22 @@
# Generated by mksrcinfo v8
-# Sun Dec 11 13:56:31 UTC 2016
+# Mon May 29 00:16:18 UTC 2017
pkgbase = volunode-git
pkgdesc = Next generation client for Berkeley Open Infrastructure for Network Computing.
- pkgver = r29415.bea54ec
+ pkgver = r30167.6d90b58c2
pkgrel = 1
- url = https://github.com/boinc-next/volunode
+ url = https://github.com/vorot93/volunode
install = volunode.install
arch = i686
arch = x86_64
license = LGPL
- makedepends = libxslt
- makedepends = perl-xml-sax
makedepends = git
makedepends = curl
- makedepends = inetutils
+ makedepends = meson
makedepends = pstreams
- makedepends = rsync
- depends = glibmm
depends = curl
depends = boinc-app-api
options = !staticlibs
- source = git+https://github.com/boinc-next/volunode
+ source = git+https://github.com/vorot93/volunode
source = volunode.desktop
source = volunode.service
source = volunode.sysusers
diff --git a/PKGBUILD b/PKGBUILD
index 0f33bbfefdfe..c76f816dda63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,16 @@
-# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
-# Contributor: Felix Yan <felixonmars@archlinux.org>
-# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
-# Contributor: Michal Krenek <mikos@sg1.cz>
-
-_username=boinc-next
+_username=vorot93
_reponame=volunode
#_ref="#branch=develop"
_pkgbase=volunode
pkgname=${_pkgbase}-git
pkgdesc="Next generation client for Berkeley Open Infrastructure for Network Computing."
-pkgver=r29415.bea54ec
+pkgver=r30167.6d90b58c2
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/$_username/${_reponame/}"
license=('LGPL')
-depends=('glibmm' 'curl' 'boinc-app-api')
-makedepends=('libxslt' 'perl-xml-sax' 'git' 'curl' 'inetutils' 'pstreams' 'rsync')
+depends=('curl' 'boinc-app-api')
+makedepends=('git' 'curl' 'meson' 'pstreams')
install=$_pkgbase.install
options=('!staticlibs')
source=("git+https://github.com/${_username}/${_reponame}${_ref}"
@@ -30,22 +25,27 @@ sha256sums=(
)
pkgver() {
- cd "$_reponame"
+ cd "${_reponame}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd ${srcdir}/${_reponame}
+ if [ ! ${srcdir}/build ]; then
+ mkdir -p ${srcdir}/build
+ cd ${srcdir}/${_reponame}
+ meson --prefix=/usr --buildtype=release ${srcdir}/build
+ cd ..
+ fi
+
+ cd ${srcdir}/build
- autoreconf -i
- ./configure --prefix=/usr --disable-documentation --enable-headers
- make
+ ninja
}
package() {
- cd ${_reponame}
+ cd ${srcdir}/build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
#install systemd unit
install -Dm644 "${srcdir}/${_pkgbase}.service" "${pkgdir}/usr/lib/systemd/system/${_pkgbase}.service"