summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrueWarg2022-03-12 19:25:22 +0300
committerTrueWarg2022-03-12 20:22:42 +0300
commitee8df299a3b1ba01500ee52df4f5cd80bbf91efa (patch)
tree8a82f6d3472237d2420072a228dc42457c9de318
downloadaur-ee8df299a3b1ba01500ee52df4f5cd80bbf91efa.tar.gz
Create package v1.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..270afb89e960
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = vorbild
+ pkgdesc = Files generation from templates
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/TrueWarg/vorbild
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = gmp
+ source = https://github.com/TrueWarg/vorbild/releases/download/v1.0.0/linux_vorbild-1.0.0.tar.gz
+ sha256sums = dfd7cf030934d1214e966dc4c8727a1322eb9eff45ba7986991617e607648f3b
+
+pkgname = vorbild
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bd20c544c23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: TrueWarg irrmm9000@gmail.com
+pkgname=vorbild
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Files generation from templates"
+arch=('i686' 'x86_64')
+url="https://github.com/TrueWarg/vorbild"
+license=('Apache')
+groups=()
+depends=('gmp')
+makedepends=()
+optdepends=()
+source=("https://github.com/TrueWarg/vorbild/releases/download/v$pkgver/linux_$pkgname-$pkgver.tar.gz")
+noextract=()
+sha256sums=('dfd7cf030934d1214e966dc4c8727a1322eb9eff45ba7986991617e607648f3b')
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "$srcdir/${pkgname}-${pkgver}/vorbild" "${pkgdir}/usr/bin/vorbild"
+ chmod +x "${pkgdir}/usr/bin/vorbild"
+}